kazuni

vmxnet3 on 1.03b for ESXi on DSM 6.2.1

Recommended Posts

Has anyone successfuly connected a vmxnet3 and make it functional in a DSM 6.2.1 environment?  I've done the precautions of adding an extra mac (valid synology mac/serial), vmxnet3 matching mac, and yet it isn't shown up after boot (i have a e1000e as primary)

Share this post


Link to post
Share on other sites

bud - if you read any other thread about 6.2.1 you'd know that third party ethernet adapters only work in DSM 6.2 and below. As soon as you jump up to 6.2.1, you play yourself.

 

either switch over to E1000 or drop back to 6.1.7 or 6.2

Share this post


Link to post
Share on other sites

If you read my threads I was one of the first few that made 1.04B work on esxi.

I've read enough to know that it's not natively going to work, but have you heard of loading extra.lzma to make non-standards to work?

Precisely, if people adds certified 10Gbe NICs they would on a real DS environment, so I am asking if anyone had successfully injected card drivers that works (like the works of IG-88 for example).

 

Edited by kazuni

Share this post


Link to post
Share on other sites
1 hour ago, kazuni said:

[...]so I am asking if anyone had successfully injected card drivers that works[...]

 

Hi kazuni,

i have tried to compile some drivers for 6.2.1. Some of them without success(Skystar2 and TT-Budget-s2-4200 Cards), others needs testing (Broadcom TG3 from https://xpenology.com/forum/topic/12866-drivers-requests-for-dsm-62/?do=findComment&comment=99410). The compile process is working for the tv-cards but injecting through errors like "can not load driver. Error -12". i cant reproduce the error on 6.2..but until now i havent find the time to compile other drivers, like vmxnet. i will try it in some days.

 

Share this post


Link to post
Share on other sites
1 hour ago, fa2k said:

Hi kazuni,

i have tried to compile some drivers for 6.2.1. Some of them without success(Skystar2 and TT-Budget-s2-4200 Cards), others needs testing (Broadcom TG3 from https://xpenology.com/forum/topic/12866-drivers-requests-for-dsm-62/?do=findComment&comment=99410). The compile process is working for the tv-cards but injecting through errors like "can not load driver. Error -12". i cant reproduce the error on 6.2..but until now i havent find the time to compile other drivers, like vmxnet. i will try it in some days.

 

 

 

Much, much appreciated.  I will do so on my own time to do the compilation too, because I wanted to also passthru a Connectx-2/3/4 to the PowerEdge server I have.

The built in Broadcom NetXtreme II s on the server (R510/610/710s) do not work with compiled drivers as they require a special boot process that requires an intel NIC being booted up first, and also a certain version of the Firmware, amongst other things.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.