sergelhr

Serial Console issue

Recommended Posts

Hi Guys.
Since the begining of Xpenology i'm building few Nas as my old syno ds209+ didn't go above dsm 4.2
Since recently i was not using serial console; last week i receive my new mobo J5005-itx and then i decide to use the serial port
as an example see below a screen copy of the serial console

 

" GNU GRUB  version 2.02

 +----------------------------------------------------------------------------+
 |*DS918+ 6.2.1/6.2 Baremetal with Jun's Mod v1.04b                           | 
 | DS918+ 6.2.1/6.2 Baremetal with Jun's Mod v1.04b Reinstall                 |
 | DS918+ 6.2.1/6.2 VMWare/ESXI with Jun's Mod v1.04b                         |
 |                                                                            |
 |                                                                            |
 |                                                                            |
 |                                                                            |
 |                                                                            |
 |                                                                            |
 |                                                                            |
 |                                                                            |
 |                                                                            | 
 +----------------------------------------------------------------------------+

      Use the ^ and v keys to select which entry is highlighted.          
      Press enter to boot the selected OS, `e' to edit the commands       
      before booting or `c' for a command-line.                           
   The highlighted entry will be executed automatically in 0s.                 

error: no suitable video mode found.
Booting in blind mode
[    0.021841] Spectre V2 : kernel not compiled with retpoline; no mitigation available!
patching file etc/rc
etc.......

at the initial install of dsm 23739 and after the first configuration, serial console was fine, login into dsm via serial was ok.
i postponed the dsm upadate as i was thinking that the last dsm 23824 was causing issue with the serial port.
The issue was the following: 
without changing any hardaware/software paramaters ,the serial console becomes unreadable see below


Xshell 6 (Build 0109)
Copyright (c) 2002 NetSarang Computer, Inc. All rights reserved.

Type `help' to learn how to use Xshell prompt.
[C:\~]$ 

Connecting to COM1...
Connected.


  ?»³?»
       t4#Bwº?;¸»Uwwº
                     ?º?»
                         t4#FwºFc´HK??3@±K¼?77T3G°4?»?»CtD#F·?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?;?Gb??4¿wºGb??dC·w?#F?w^4¿wº
                                 Gb??4¿wºKb??t~wºKp?#F?:??û?úd#B??£<0ûU8lD#F?l??û¸·??D#F??:t??û?Btd#B??????Ztd#B??£<0?[8?#F????ûU8?D#F·?»?7»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»?»¶³»?»?»?»?»?»?;?·»
                                                                                  tD#FwºKF<??»?"k;K?¼C·±??O7tC?t³;-???N¹³{?7@" 
??[·¸¼c[3»³??@"??"@"@"wºKGx4wº?wwºkGc[K8???3?o"°??k[·1C?@D @Kl7¼?¸?t¼{¼@;?  
                                                 ;wzt¢´=¼{?@?1b
                                                 
                                                 
But unfortunately it was the same issue with dsm 23739 the following day!!
stangely after the initial install and  few reboots no issue; after system stopped for the nite, the folowing days with the same dsm version, the serial console showing unreadable text?
I'm lost,from syno nil setting from dsm for the serial port/console.Encrypted text or need to change of the police caracter?
Anyone have some ideas ? 
Thanks

 

NAS
Asrock J5005-itx bios 1.40
Memory: 8GB
Loader jun 1.04b

Edited by sergelhr
typo

Share this post


Link to post
Share on other sites

1. Troubles with cable or connectors

2. Invalid settings in the terminal, right you can see in the head of grub.cfg

Edited by Olegin

Share this post


Link to post
Share on other sites

Dear Olegin

During my trouble shooting, i already use a second serial card onto my computeur and cable, no help

No settings change regarding terminal setting or hardware when problem occurs

In fact by re-formating my jun's loader usb key and hdd re-formated the serial console is working for some time and after some reboots or stop the problem re-occurs.

So i believe the issue is from my xpenology install. 

Edited by sergelhr
typo

Share this post


Link to post
Share on other sites
28 минут назад, sergelhr сказал:

So i believe the issue is from my xpenology install. 

I don't know and can't try to connect by com terminal because DSM is far away from me.

 

 

Share this post


Link to post
Share on other sites

Why are you connecting the serial console? This is usually used for debugging boot loader issues.

If your XPE box is running ok, you don't need serial connection.

You can use telnet/ssh to access the system for most diagnostics.

Anyway, check the FAQ for the correct serial settings and maybe also try another connection app like putty.

Share this post


Link to post
Share on other sites

Dear Sbv3000

I'm just curoius that why i was using the serial and by reading xpenology forums, few guys had issue when connecting a screen, also by using the console i was able to see the boot process without screen.I don't known if this screen issue  it still applying to jun's loader 1.04b and processor close to original ds918+.

Telnet/ssh working fine.

serial settings 115200 8 1 none none software xshell 6     and other various with the same issue

Thanks

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.