EVOTk

[RESOLU] Plex, Docker et Hardware Decodeur

Recommended Posts

Bonjour,

Tout est dans le titre ! J'ai une install de plex dans Docker et je n'arrive pas a activer le décodage matériel malgré les différents tuto que j'ai pu trouver ! Certain d'entre vous ont réussi ?

Share this post


Link to post
Share on other sites

Salut,

 

 4 mots : Je ne sais pas!

 

Mais pour être honnête, j'utilisais Docker depuis 1 an avec 1 seul container : Haproxy pour faire de reverse proxy. A mes yeux ça marchait très bien, puis j'ai découvert que le Nginx de base de DSM permettait de répondre à mes besoins. J'ai donc essayer..... et j'ai tout de suite vu la différence en terme de perf! c'est juste hallucinant à laquelle se chargent mes pages maintenant. En gros le docker-engine compiler pour DSM me semble pas terrible.

 

Donc Dockeriser Plex, à part pour faire un test je ne pense pas que ce soit une bonne idée! 

 

Pourquoi ne pas utiliser la distrib de Plex en natif ?

Share this post


Link to post
Share on other sites

C’était principalement un test, et si pas exemple, le bouge mon dossier Filmothèques de volume, en docker cela na pas d'incidence, car les liens sont du genre /data/Filmothèques et non /volume5/Filmothèques, je trouvé cela pratique. 

Mais cette histoire de décodage matériel, c'est bien dommage. Je pense que je vais retourner a une installation classique, tout se travail pour rien, snif snif snif ;)

Par contre j'ai tautulli en docker, c'est tout récent ce logiciel pour moi, je ne fait que le découvrir pour le moment mais c'est plutot sympas !

Share this post


Link to post
Share on other sites

Pour l'utiliser au quotidien au boulot en tant que développeur/architecte, mon retour d'expérience me faire dire que c’est pratique et puissant en environnement non-production.

 

 

Je suppose que tu t'es appuyé sur ce tuoto :

https://www.nas-forum.com/forum/topic/59118-plex-via-docker-avec-ou-sans-transcodage-matériel/

La partie sur la modif du json doit (je pense) être vérifié selon ton NAS. En effet /dev/dri n'est typiquement pas présent chez moi (en particulier la valeur correspondante à "PathOnHost"

"devices" : [
      {
         "CgroupPermissions" : "rwm",
         "PathInContainer" : "/dev/dri",
         "PathOnHost" : "/dev/dri"
      }
   ],

A creuser de ce coté-là je pense

 

[EDIT] Je pense que /dev/dri n'est présent que si l'on dispose d'une carte graphique (ie. un contrôleur vidéo) - ce qui n'est effectivement pas mon cas, et toi ?

Share this post


Link to post
Share on other sites

Salut,

J'ai une carte graphique intégré ( ASRock Z370M PRO4  et i5-8600K ) et effectivement, j'ai regarder en ssh, ce dossier n'existe pas ( /dev oui, mais /dev/dri non )

 

Oui c'est bien ce tuto que j'ai suivi principalement.

Edited by EVOTk

Share this post


Link to post
Share on other sites

Je suis repasser en installation "classique" est pas de décodage matériel non plus ! ..... J'ai bien l'option que je peut activer mais je ne le voit jamais faire ! Pas de (hw) dans la fenetre des activité ...

Share this post


Link to post
Share on other sites

pour avoir le Hardware il faut avoir le Plex Pass activer, est ce que tu la?

Share this post


Link to post
Share on other sites

Oui mais j'ai ma réponse c'est un problème de licence 

Share this post


Link to post
Share on other sites

Bonjour Evotk,

 

J'ai testé avec le loader 1.04 pour DS918, j'ai un plex pass, et le transcodage fonctionne.

 

Je ne comprends pas quand tu parles de licence, tu parles de quelle licence ?

Share this post


Link to post
Share on other sites

Salut, 

Chez moi aussi le transcodage fonctionne très bien mais uniquement software (Cpu) et non hardware (gpu, igpu,..) 

 Regarde l'avant dernier message de la page 1, 

 

Share this post


Link to post
Share on other sites
Posted (edited)

re,

 

justement moi je parle bien du hardware, c'est un i5 4460 avec intel HD, et lors d'un transcodage, si je regarde l'utilisation CPU, je ne monte pas du tout (l'inverse si je désactive dans plex le transcodage Hardware).. même en vérifiant en CLI avec un top.

 

par contre, il faut installer l'appli en passant par le site plex et non le store syno et prendre la 64 bits et biensur avoir le plexpass

Edited by thom_484

Share this post


Link to post
Share on other sites

j'aimerai bien pouvoir en faire de meme, enb ssh que te retourne cette commande ? :

Citation

cat /usr/syno/etc/codec/activation.conf

 

Chez moi, j'ai 

Citation

{"success":false,"msg":"SN format is wrong."}

 

Share this post


Link to post
Share on other sites
Posted (edited)

outch malheureusement je ne peux tester que en fin d'aprem. 

je te dis quoi. mais ton problème m'a l'air étrange . tu viens d'un 3615 ou tu as fais une fresh intall en DS918+ ?

 

Ou ton proco est trop récent ? 😕 (aucune idée) je ne sais pas trop. Je te screen aussi un transcodage.

Edited by thom_484

Share this post


Link to post
Share on other sites

C'est une migration depuis un ds3615 mais sans conservation de la configuration.

Share this post


Link to post
Share on other sites

Je me demande si ce n'est pas ça .. as tu l'occaz de retester (autre clé et DD de test) ? tu veux transcoder quoi ? du h264 ( 1080P  )

Share this post


Link to post
Share on other sites

Salut,

je suis jaloux chez moi fonctionne pas :(

Tu est en docker aussi ?

Share this post


Link to post
Share on other sites

non, j'ai récupéré plex directement sur le site en version 64 bits

Share this post


Link to post
Share on other sites

Bon ... 

j'ai trouver un SN valide mais toujours pas de transcodage hard !

 

j'ai toujours le {"success":false,"msg":"SN format is wrong."}

Pourtant j'ai vérifier mon sn sur le site de syno qui me le valide bien comme 918+ :(

Share this post


Link to post
Share on other sites

Petit retour, après l'obtention d'un SN Valide=, j'ai du faire une réinstallation complète ( avec conservation des données, mais pertes des paramètres de DSM ) afin que le nouveau SN soit pris en compte ! 

 

Maintenant tout est OK.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.