whatever

HDD's not detected loader 1.03b

Recommended Posts

Hi need assistance regarding a baremetal install of dsm 6.2 using ds3617 1.03b loader.

 

I have a self built system that is running ds3617 on 1.02b dsm 6.1 without issue but I use an older Advent Firefly FP-3104 as a test system I have installed dsm 5.2 loader ds3615xs 5.2-5592.1 and 6.1 loader ds3617xs loader 1.02b on this computer with no issue's I've tried to install dsm 6.2 today to test it out before moving my main system over to it and although I can get it to post and find it on my network with synology assistant it does not detect any drives attached to the sata ports. I have not had this issue with the older bootloaders. The board has a legacy bios not uefi.

 

Anybody any ideas ?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I didn't get as far as trying to install the pat file as it won't detect a hdd so it does not give me the option to select the pat file to install the os but the file I have is 6.2/23739. It's the boot loader stage where I'm stuck. Also the hdd's I'm using are all formatted. I've tried different ports and 3 different hdd's with no luck. when I switch back to 1.02b loader it finds the drive's and gives me the option to install dsm. 

 

Thanks.

Share this post


Link to post
Share on other sites

Ahh, OK.

Note that in the BIOS, the drives have to be detected as ACHI not IDE, if it's in IDE it will not been seen in DSM

Share this post


Link to post
Share on other sites

Hi again,

 

Set as ACHI the drives are recognized on all ports using dsm 5.2 loader ds3615xs 5.2-5592.1 and 6.1 loader ds3617xs loader 1.02b using loader 1.03b drives are not recognized so I'm unable to install dsm. Anything else I could look at would be appreciated I'd like to get it running on this system before I try on my main rig.

 

The only thing I've done different on this install to usual is convert the image file to an iso file as I can never get xpenology working using the image files I always have to use an iso file normally I download 1 but this time I could not find 1 so converted it myself.

 

Just to check it's not this that is causing the problem I converted an image file of the 1.02b loader into an iso and it worked fine so I don't think me converting the image is the problem.

Edited by whatever

Share this post


Link to post
Share on other sites

I don't know your hardware,

but Google indicate that the "Advent Firefly FP-3104" might be using a H55 based chipset, 

do you know what the SATA controller is?

You might get lucky using a "driver extentsion" and adding a "extra.lzma" to your bootimage as the 6.2 loader might have dropped some older hw support?

 

As to why you have to convert into an .ISO and if that might cause problem, thats another story ;-)

Share this post


Link to post
Share on other sites

Thanks for the quick reply I'll add the driver extension to the loader and see how I get on I'll let you know either way.

 

Cheers

Share this post


Link to post
Share on other sites

Hi again,

 

Adding the extra.lzma makes it worse I know get the splash screen but it does not show on the network previously I could connect but it would not detected hdd's to install dsm.

 

This is the first time I've used the extra drivers so I have listed my process below please let me know if I'm doing something wrong thanks.

 

1) Mount the image partition 0  15MB and updated vid pid s/n & mac

2) to add drivers mount partition 2  30MB and replace the existing extra.lzma with the new extra.lzma.

3) dismount

 

I've check I did not leave in read only and have remounted both partitions to make sure the changes were saved.

 

If this looks right let me know if you have any more suggestions.

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.