DSM 5 4458


Recommended Posts

habe auch einen H340 laufen. Wenn im BIOS nichts umgestellt wurde, bootet er automatisch von einem USB-Stick, den man in einen der hinteren (!) USB-Steckplätze steckt.

Er hat intern noch so etwas wie einen USB-Speicher. Da ist normalerweise das Windows-Notfallstartsystem (WHSv1) drauf. Das scheint bei Dir überschrieben worden zu sein. Ist aber kein Problem, solange im BIOS nichts umgestellt wurde. (s.o.)

 

man kann auch die bootmenüeinträge so ändern, dass man keine Tasten drücken muss. :smile:

Habe ich auch so installiert. Wenn es läuft, kann man entweder den internen USB-Speicher mit dem Inhalt des Start-USB-Sticks überschreiben, oder man lässt ihn einfach hinten stecken. (Ist etwas flexibler). Als Start-Stick reicht auch ein kleiner alter Stick, da das Image von gnoboot gerade mal 32MB (!) nutzt.

 

 

@d3dx9: prima Anleitung!

Link to post
Share on other sites

@d3dx9: Schöner Blog! Vielen Dank!

 

@all: Wichtig zu wissen ist, wenn ihr über Android auf die DS Audiostation zugreifen wollt kommt ein Fehler. Dieser resultiert anscheinend tatsächlich daraus das bei gnoboot vom Start weg keine SN mit kommt. Die Lösung ist die Venderdatei einzufügen und eine weitere anzupassen siehe [http://xpenology.com/forum/viewtopic.php?f=2&t=2765] im englischen Forenteil. Nun funktioniert auch die DS Audiostation. Also keine Panik, ist alles gut nach dem Upgrade :wink:

Link to post
Share on other sites

warum so kompliziert mit der vender-Datei?

 

Einfach als bootoption beim Start mitgeben. (Man muss dann auch nicht die Prüfsumme berechnen, etc.) Das hat auch schon bei den letzten Trantor-Releases funktioniert.

 

Bei Änderung der entsprechenden Datei (für den Betrieb menu_alpha.lst) unter Windows am Besten Notepad Plus oder so benutzen und auf den Unix-Zeilenumbruch achten.

 

http://xpenology.com/forum/viewtopic.php?f=2&t=1353&p=15339#p15339

 

title gnoboot-alpha
root (hd0,0)
kernel /zImage sn=XXXXXXXXXXX

Link to post
Share on other sites

@d3dx9

 

Hi, hab mal zum testen eine neue Installation gemacht, die im Moment noch "jungfräulich" ist.

Nach Deiner Anleitung wollte ich auf gnoBoot: Update auf 4458 Update 1 aktualisieren.

Klappt aber nicht, bekomme den Fehler:

 

DiskStation> su

 

 

BusyBox v1.16.1 (2014-03-06 14:29:13 CST) built-in shell (ash)

Enter 'help' for a list of built-in commands.

 

~ # sed 's/flashupdateDeb/flashupdateDeb1/' /autoupd@te.info > /autoupd@te.info1

sed: /autoupd@te.info: No such file or directory

~ # mv /autoupd@te.info1 /autoupd@te.info

 

 

Kannst Du mir einen Tip geben?

 

Gruss lopo

Link to post
Share on other sites

ahhhh jetzt, dummbatz ich.....

 

Habs die *.pat auf dem Laptop gespeichert, das bringt natürlich wenig :grin:

Im Moment sieht das sehr gut aus, noch 7 min :smile:

 

Und nun fertig, hat prima geklappt.

 

Danke!

Link to post
Share on other sites

@ d3dx9

 

hab ne Frage:

 

Wenn ich das Image 4.3 von Trantor mit dem Win32diskimager auf den Stick schreib, bottet der Rechner damit und läuft auch wunderbar.

Schreib ich gnobot alpha10.4 oder 10.5 dann bootet der Rechner nicht.

Kein bootdevice kommt dann.

 

Hast du ein Tip voran das liegen kann ?

 

Mfg

Link to post
Share on other sites

Ich habe heute (mehr oder minder) erfolgreich ein update von trantor 4.3 auf gnoboot 5 durchgeführt.

 

Dabei bin ich leider bei der guten MariaDB auf einige Probleme gelaufen.

 

Standardmeldung nach dem Versuch, mariadb zu starten, war, dass das mit my.cnf nicht möglich sei.

 

Ich hab dann etwas rumgesucht und gefunden, das man Rechte verändern muss.

 

chmod 777 /run/mysqld

 

Siehe da, damit funktioniert es. Leider sind diese Einstellungen nach jedem Boot weg. Kann man das irgendwie dauerhaft ändern?

 

Gruß

Hoovercraft

Link to post
Share on other sites

@stifler1111: Sorry, weiß da keine Lösung..

 

@Hoovercraft: Liegt daran dass das Image als RAMdisk geladen wird, also das OS liegt im Arbeitsspeicher, und wird nicht zurückgeschrieben, aber du kannst ein Bootscript machen, welches dass automatisch für dich macht.

 

Lege dazu in /usr/syno/etc/rc.d/ eine Datei Namens S99ABC_chmod_mysqld.sh an und mit dem Inhalt "chmod 777 /run/mysqld".

 

Gruß!

Link to post
Share on other sites

Habe das DSM 5.0-4458 Update 2 auf dem HP 54L und bekomme die Fehlermeldung in DS Photo

SN is invalid. Gnoboot ist 10.5.

Habe schon versucht die menu_alpha.lst zu modifizieren, zusätzlich die vendor Datei passend zu MAC und sn gepatched alles ohne Erfolg.

Hat jemand mit dem Update 2 erfolgreich eine Seriennummer eintragen können?

Bei mir lässt sich Photo Station nicht aufrufen und im Paket Zentrum steht bei der photo Station

läuft, darunter in blau "feedback" und wenn man auf feedback klickt steht dort "SN is invalid".

Edited by Guest
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.