TeleDDim

Аппаратный транскодинг на Asrock J4205-ITX

Recommended Posts

25 минут назад, TeleDDim сказал:

В его dmesg явно отключена vt-d, может с ней будет лучше, ну и вопрос что значит low perfomance - если один поток 4К осилит - отлично )

Тут кто то жаловался что у него плохо транскодиг с потоком 80 мб/сек справляется - у каждого свое понимание)

Тут каждому свое... (а нужно ли оно вообще), просто эксперимент - на телефон нормально, а на комп подключенный через тот же канал по телефону + вафля между ними - звук хорошо, а картинка тормозит.

P.S. вафля  - ac, 867 вроде должна держать.

P.P.S. Сорри, что чуть наофтопил, но из огрызочного телефона роутер LTE-Wifi не вышел 😁

Edited by Olegin

Share this post


Link to post
Share on other sites

Вобщем такая ботва:

1. Extra.lzma от @Olegin ситуацию с выключением и транскодингом не решил, те же ошибки в dmesg:

Spoiler

[  125.579518] ACPI: Power Button [PWRB]
[  125.627272] Linux agpgart interface v0.103
[  125.754141] [drm] VT-d active for gfx access
[  125.762423] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[  125.762428] [drm] Driver supports precise vblank timestamp query.
[  125.762538] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:o
s=io+mem
[  125.763005] [drm] Finished loading DMC firmware i915/bxt_dmc_ver1_07.bin (v1.7)
[  125.765826] [drm] Disabling framebuffer compression (FBC) to prevent screen flicker with VT-d e
bled
[  125.766784] BUG: unable to handle kernel NULL pointer dereference at           (null)
[  125.774995] IP: [<          (null)>]           (null)
[  125.780278] PGD 46206e067 PUD 46601a067 PMD 0
[  125.785005] Oops: 0010 [#1] PREEMPT SMP
[  125.789134] Modules linked in: i915(E+) drm_kms_helper(E) syscopyarea(E) sysfillrect(E) sysimgb
(E) fb_sys_fops(E) cfbfillrect(E) cfbcopyarea(E) cfbimgblt(E) drm(E) fb(E) fbdev intel_agp(E) inte
gtt(E) agpgart(E) video backlight button synoacl_vfs(PO) hfsplus md4 hmac r8168(OE) ixgbe(E) igb(E
i2c_algo_bit e1000e(E) vxlan ip6_udp_tunnel udp_tunnel fuse vfat fat crc32c_intel aesni_intel glue
elper lrw gf128mul ablk_helper arc4 cryptd ecryptfs sha256_generic ecb aes_x86_64 authenc des_gene
c ansi_cprng cts md5 cbc cpufreq_powersave cpufreq_performance acpi_cpufreq processor cpufreq_stat
dm_snapshot dm_bufio crc_itu_t crc_ccitt quota_v2 quota_tree psnap p8022 llc sit tunnel4 ip_tunnel
pv6 zram sg etxhci_hcd rtc_cmos(E) mdio(E) mpt3sas(E) raid_class(E) scsi_transport_sas(E) megaraid
as(E) megaraid(E)
[  125.864600]  mptctl(E) mptspi(E) mptscsih(E) mptbase(E) scsi_transport_spi(E) megaraid_mbox(E)
garaid_mm(E) vmw_pvscsi(E) BusLogic(E) usb_storage xhci_pci xhci_hcd usbcore usb_common imwz(OE) [
st unloaded: apollolake_synobios]
[  125.884822] CPU: 2 PID: 6769 Comm: insmod Tainted: P           OE   4.4.59+ #23824
[  125.892723] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./J4205-ITX, BIOS P1.80
/21/2018
[  125.902718] task: ffff880461140440 ti: ffff880460b34000 task.ti: ffff880460b34000
[  125.910491] RIP: 0010:[<0000000000000000>]  [<          (null)>]           (null)
[  125.918358] RSP: 0018:ffff880460b37950  EFLAGS: 00010202
[  125.923892] RAX: 0000000000000246 RBX: ffff88046a0861c0 RCX: 0000000000000010
[  125.931276] RDX: 0000000000000002 RSI: 0000000000000002 RDI: ffff88046a0861c0
[  125.938706] RBP: ffff880460b37970 R08: 0000000000000000 R09: 0000000000000000
[  125.946129] R10: 0000000000000001 R11: 0000000000000001 R12: ffff880460b37990
[  125.953593] R13: 0000000000000002 R14: 0000000000000002 R15: ffff88046a086ba0
[  125.961023] FS:  00007f5e06d25700(0000) GS:ffff88047fd00000(0000) knlGS:0000000000000000
[  125.969483] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  125.975477] CR2: 0000000000000000 CR3: 000000046206d000 CR4: 00000000003406f0
[  125.982915] Stack:
[  125.984998]  ffffffff8140c409 ffff88046a0861c0 ffff88046a086000 ffff88046a0861c0
[  125.992757]  ffff880460b379b8 ffffffffa059da68 ffff880460b379e7 0000000000000000
[  126.000548]  0000000100000040 ffff880460b3798c ffff001000010040 ffff880460b379d0
[  126.008310] Call Trace:
[  126.010891]  [<ffffffff8140c409>] ? i2c_transfer+0x79/0x90
[  126.016631]  [<ffffffffa059da68>] drm_dp_dual_mode_read+0x58/0x80 [drm_kms_helper]
[  126.024503]  [<ffffffffa059dcb2>] drm_dp_dual_mode_detect+0x32/0x150 [drm_kms_helper]
[  126.032671]  [<ffffffffa0683adc>] lspcon_init+0x6c/0x1a0 [i915]
[  126.038923]  [<ffffffffa066b480>] intel_ddi_init+0x2d0/0x4f0 [i915]
[  126.045483]  [<ffffffffa0649537>] intel_modeset_init+0x15e7/0x1a70 [i915]
[  126.052588]  [<ffffffffa0683507>] ? intel_setup_gmbus+0x2e7/0x310 [i915]
[  126.059612]  [<ffffffffa05beccf>] i915_driver_load+0xa0f/0xe00 [i915]
[  126.066325]  [<ffffffffa05c9797>] i915_pci_probe+0x27/0x40 [i915]
[  126.072675]  [<ffffffff812fc85c>] pci_device_probe+0x8c/0x100
[  126.078636]  [<ffffffff813842d1>] driver_probe_device+0x1f1/0x310
[  126.084923]  [<ffffffff81384472>] __driver_attach+0x82/0x90
[  126.090693]  [<ffffffff813843f0>] ? driver_probe_device+0x310/0x310
[  126.097214]  [<ffffffff81382361>] bus_for_each_dev+0x61/0xa0
[  126.103126]  [<ffffffff81383d69>] driver_attach+0x19/0x20
[  126.108759]  [<ffffffff81383993>] bus_add_driver+0x1b3/0x230
[  126.114621]  [<ffffffffa06fa000>] ? 0xffffffffa06fa000
[  126.120017]  [<ffffffff81384c7b>] driver_register+0x5b/0xe0
[  126.125865]  [<ffffffff812fb337>] __pci_register_driver+0x47/0x50
[  126.132258]  [<ffffffffa06fa03e>] i915_init+0x3e/0x45 [i915]
[  126.138166]  [<ffffffff810003b6>] do_one_initcall+0x86/0x1b0
[  126.144056]  [<ffffffff810dfdd8>] do_init_module+0x56/0x1be
[  126.149859]  [<ffffffff810b61ad>] load_module+0x1ded/0x2070
[  126.155613]  [<ffffffff810b3510>] ? __symbol_put+0x50/0x50
[  126.161360]  [<ffffffff810b65b9>] SYSC_finit_module+0x79/0x80
[  126.167320]  [<ffffffff810b65d9>] SyS_finit_module+0x9/0x10
[  126.173131]  [<ffffffff81567444>] entry_SYSCALL_64_fastpath+0x18/0x8c
[  126.179855] Code:  Bad RIP value.
[  126.183356] RIP  [<          (null)>]           (null)
[  126.188781]  RSP <ffff880460b37950>
[  126.192392] CR2: 0000000000000000
[  126.195851] ---[ end trace ab9999c612959e5b ]---
[  126.249564] ------------[ cut here ]------------
[  126.254330] WARNING: CPU: 2 PID: 6769 at kernel/softirq.c:150 __local_bh_enable_ip+0x65/0x90()
[  126.263234] Modules linked in: i915(E+) drm_kms_helper(E) syscopyarea(E) sysfillrect(E) sysimgb
(E) fb_sys_fops(E) cfbfillrect(E) cfbcopyarea(E) cfbimgblt(E) drm(E) fb(E) fbdev intel_agp(E) inte
gtt(E) agpgart(E) video backlight button synoacl_vfs(PO) hfsplus md4 hmac r8168(OE) ixgbe(E) igb(E
i2c_algo_bit e1000e(E) vxlan ip6_udp_tunnel udp_tunnel fuse vfat fat crc32c_intel aesni_intel glue
elper lrw gf128mul ablk_helper arc4 cryptd ecryptfs sha256_generic ecb aes_x86_64 authenc des_gene
c ansi_cprng cts md5 cbc cpufreq_powersave cpufreq_performance acpi_cpufreq processor cpufreq_stat
dm_snapshot dm_bufio crc_itu_t crc_ccitt quota_v2 quota_tree psnap p8022 llc sit tunnel4 ip_tunnel
pv6 zram sg etxhci_hcd rtc_cmos(E) mdio(E) mpt3sas(E) raid_class(E) scsi_transport_sas(E) megaraid
as(E) megaraid(E)
[  126.338920]  mptctl(E) mptspi(E) mptscsih(E) mptbase(E) scsi_transport_spi(E) megaraid_mbox(E)
garaid_mm(E) vmw_pvscsi(E) BusLogic(E) usb_storage xhci_pci xhci_hcd usbcore usb_common imwz(OE) [
st unloaded: apollolake_synobios]
[  126.359201] CPU: 2 PID: 6769 Comm: insmod Tainted: P      D    OE   4.4.59+ #23824
[  126.367043] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./J4205-ITX, BIOS P1.80
/21/2018
[  126.376958]  0000000000000000 ffff880460b37658 ffffffff812b673d 0000000000000000
[  126.384767]  ffffffff81720af4 ffff880460b37690 ffffffff8104794d 0000000000000201
[  126.392556]  ffff880461140440 ffff880461140ab8 ffff880461140440 ffff88046bfb71e8
[  126.400398] Call Trace:
[  126.402974]  [<ffffffff812b673d>] dump_stack+0x4d/0x70
[  126.408296]  [<ffffffff8104794d>] warn_slowpath_common+0x7d/0xc0
[  126.414571]  [<ffffffff81047a46>] warn_slowpath_null+0x16/0x20
[  126.420669]  [<ffffffff8104b1b5>] __local_bh_enable_ip+0x65/0x90
[  126.426943]  [<ffffffff81566f75>] _raw_spin_unlock_bh+0x15/0x20
[  126.433053]  [<ffffffff810c2a6b>] cgroup_exit+0x4b/0xa0
[  126.438516]  [<ffffffff8104a29d>] do_exit+0x36d/0xab0
[  126.443761]  [<ffffffff810073a4>] oops_end+0x84/0xc0
[  126.448929]  [<ffffffff8103a34b>] no_context+0xfb/0x2b0
[  126.454368]  [<ffffffff8103a570>] __bad_area_nosemaphore+0x70/0x1f0
[  126.460834]  [<ffffffff8103a6fe>] bad_area_nosemaphore+0xe/0x10
[  126.466983]  [<ffffffff8103a949>] __do_page_fault+0x79/0x370
[  126.472925]  [<ffffffff8103ac7c>] do_page_fault+0xc/0x10
[  126.478446]  [<ffffffff81568c02>] page_fault+0x22/0x30
[  126.483799]  [<ffffffff8140c409>] ? i2c_transfer+0x79/0x90
[  126.489496]  [<ffffffffa059da68>] drm_dp_dual_mode_read+0x58/0x80 [drm_kms_helper]
[  126.497393]  [<ffffffffa059dcb2>] drm_dp_dual_mode_detect+0x32/0x150 [drm_kms_helper]
[  126.505660]  [<ffffffffa0683adc>] lspcon_init+0x6c/0x1a0 [i915]
[  126.511875]  [<ffffffffa066b480>] intel_ddi_init+0x2d0/0x4f0 [i915]
[  126.518515]  [<ffffffffa0649537>] intel_modeset_init+0x15e7/0x1a70 [i915]
[  126.525620]  [<ffffffffa0683507>] ? intel_setup_gmbus+0x2e7/0x310 [i915]
[  126.532670]  [<ffffffffa05beccf>] i915_driver_load+0xa0f/0xe00 [i915]
[  126.539488]  [<ffffffffa05c9797>] i915_pci_probe+0x27/0x40 [i915]
[  126.545745]  [<ffffffff812fc85c>] pci_device_probe+0x8c/0x100
[  126.551753]  [<ffffffff813842d1>] driver_probe_device+0x1f1/0x310
[  126.558056]  [<ffffffff81384472>] __driver_attach+0x82/0x90
[  126.563843]  [<ffffffff813843f0>] ? driver_probe_device+0x310/0x310
[  126.570397]  [<ffffffff81382361>] bus_for_each_dev+0x61/0xa0
[  126.576298]  [<ffffffff81383d69>] driver_attach+0x19/0x20
[  126.581975]  [<ffffffff81383993>] bus_add_driver+0x1b3/0x230
[  126.587881]  [<ffffffffa06fa000>] ? 0xffffffffa06fa000
[  126.593195]  [<ffffffff81384c7b>] driver_register+0x5b/0xe0
[  126.598970]  [<ffffffff812fb337>] __pci_register_driver+0x47/0x50
[  126.605371]  [<ffffffffa06fa03e>] i915_init+0x3e/0x45 [i915]
[  126.611249]  [<ffffffff810003b6>] do_one_initcall+0x86/0x1b0
[  126.617134]  [<ffffffff810dfdd8>] do_init_module+0x56/0x1be
[  126.622942]  [<ffffffff810b61ad>] load_module+0x1ded/0x2070
[  126.628741]  [<ffffffff810b3510>] ? __symbol_put+0x50/0x50
[  126.634458]  [<ffffffff810b65b9>] SYSC_finit_module+0x79/0x80
[  126.640443]  [<ffffffff810b65d9>] SyS_finit_module+0x9/0x10
[  126.646266]  [<ffffffff81567444>] entry_SYSCALL_64_fastpath+0x18/0x8c
[  126.652924] ---[ end trace ab9999c612959e5c ]---

 

2. С extra.lzma от @x01015918 не смог установить и запустить систему, но судя по всему по такой причине: сразу в grub прописал отключение мониторов, что то было такое и с моей версией extra.lzma

 

3. С моей версией extra.lzma при отключенном мониторе транскодинг работает, но действительно плохо, точнее странно:

 3.1 В VS проигрывается с подгрузкой каждый 5-10 сек, при это нагрузке не процессоре нет, то есть что то с буферизацией чтоль, буду разбираться.

 

3.2 По DLNA через меню телека через "Сервер Мультимедиа" такая же история - постоянные фризы картинки, при отсутствии загрузки проца.

 

3.3. В Плексе с плекспассом всё работает без фризов, нагрузка на проце 10-20% при FullHD на котором раньше было 80-90 софтовом.

 

4K нету у меня, скиньте ссыль на какой то "эталон", качну и завтра потестчу в Плексе.

 

Проблему с фризами на VS и Сервере мультимедиа хочу попробовать решить параметрами драйвера i915 прописал в загрузку ядра в груб.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

кстати, у меня тоже фризы появились, хотя до этого все было хорошо

Share this post


Link to post
Share on other sites

Вчера прилетало обновление VS, не обновляли?

Share this post


Link to post
Share on other sites

нет, не обновлялся. это на той тестовой машине.

обновился, фризы остались.

но блин совершенно точно все работало несколько дней назад!

Edited by Kizilkum

Share this post


Link to post
Share on other sites
11 minutes ago, Kizilkum said:

нет, не обновлялся. это на той тестовой машине.

 

может биос ковырял? )) 

Share this post


Link to post
Share on other sites
Только что, TeleDDim сказал:

может биос ковырял? )) 

такое может быть. позже проверю

Share this post


Link to post
Share on other sites

У меня вот такой конфиг (память настроена в соответствии с планками):

Bios version: 1.80

CPU Configuration: Intel SpeedStep Technology: disable; CPU C States Support: disable; Intel Virtualization Technology: enable; IntelVt-d: enable;

Chipset Configuration: DRAM Frequency: 1866; DRAM Voltage: 1.5; Primary Graphics Adapter: Onboard; Share Memory: 512; 

ACPI Configuration: Suspend to RAM:disable; ACPI HPET Table: disable;

Boot: UEFI; CSM: disable.

 

У человека вот стоит  CSM\UEFI only - может в этом дело )

 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 1/28/2019 at 8:55 PM, T-REX-XP said:

Может кто скомпилить модуль для нашего ядра с предложенным фиксом с гитхаба?? 

Я скомпилил, но не очень понимаю что с ним делать ))

Ну то есть патч он для модуля drm_kms_helper.ko, я код в исходниках Сино подменил (бета 6.2) и скомпилил.

А дальше что? У джуна скопилины ещё отдельно вот такие модули: agpgart intel-gtt intel-agp drm cfbfillrect cfbimgblt cfbcopyarea sysfillrect sysimgblt syscopyarea fb_sys_fops fb drm_kms_helper i915

Если я тупо подменю в его загрузчике этот модуль, он как с остальными взаимодействовать интересно будет? ) Я же только кусочек его заменил, а Джун мог больше патчей применить и соответственно всё развалится...

Или вот думаю его отдельно просто в свой extra.lzma кинуть и прописать в OPTIONAL_MODDULES? 

 

Хотя нафига это уже надо не очень понятно - собрали уже extra.lzma единственным недостатком которого является то что моник надо отключить ))

Edited by TeleDDim
  • Thanks 1

Share this post


Link to post
Share on other sites
14 минуты назад, TeleDDim сказал:

Или вот думаю его отдельно просто в свой extra.lzma кинуть и прописать в OPTIONAL_MODDULES? 

Попытка - не пытка. Я бы оба варианта попробовал - и новый модуль добавить и патченный поменять.

14 минуты назад, TeleDDim сказал:

Хотя нафига это уже надо не очень понятно - собрали уже extra.lzma единственным недостатком которого является то что моник надо отключить ))

Ну, я так понял из переписки, что с VS совсем все не хорошо.

Edited by Olegin

Share this post


Link to post
Share on other sites
15 minutes ago, TeleDDim said:

Если я тупо подменю в его загрузчике этот модуль, он как с остальными взаимодействовать интересно будет? ) Я же только кусочек его заменил, а Джун мог больше патчей применить и соответственно всё развалится...

да, я так и думал, надо подкинуть новый модуль в extra.lzma и тестить с этим модулем.

3 minutes ago, Olegin said:

Ну, я так понял из переписки, что с VS совсем все не хорошо.

Вы правы.

 

Было бы не плохо в шапку добавить ссылки или основные результаты тестов. И так сказать более менее рабочий вариант. А то тяжело понимать, что и у кого работает прыгая между двумя ветками форума.

Share this post


Link to post
Share on other sites
12 minutes ago, Olegin said:

Ну, я так понял из переписки, что с VS совсем все не хорошо.

Есть мнение что это проблемы настроек драйвера/биоса, не требующая новых версий модулей )

Меня вот такая штука смутила: по dmesg памяти выделяется 4гига, в то время как в биосе стоит 512 )) поменюя на авто и проверю )

9 minutes ago, T-REX-XP said:

Было бы не плохо в шапку добавить ссылки или основные результаты тестов.

Я как придет какое то более явное понимание напишу более развернуто и со ссылками )

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
12 минуты назад, TeleDDim сказал:

Есть мнение что это проблемы настроек драйвера/биоса, не требующая новых версий модулей )

Меня вот такая штука смутила: по dmesg памяти выделяется 4гига, в то время как в биосе стоит 512 )) поменюя на авто и проверю ) 

Думаю, что не так все просто, вспомните про время загрузки...

Share this post


Link to post
Share on other sites
28 minutes ago, Olegin said:

Думаю, что не так все просто, вспомните про время загрузки...

а что про него вспоминать, в зависимости от настроек от 150 до 540 сек )) Меня и 540 устроит если после этого всё будет работать )))

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 час назад, Kizilkum сказал:

время загрузки для NAS  роли не играет. это не десктоп

Именно.

А тем, кто использует больше для просмотра фильмов на телевизоре и только для дома (не нужен все остальное время) - проще на телефоне настроить сценарий, что бы при подключении к домашнему WiFi WoLом будился NAS.

Share this post


Link to post
Share on other sites
2 минуты назад, Kitaro сказал:

не нужен все остальное время

можно что бы только диски засыпали, время старта пара секунд

Share this post


Link to post
Share on other sites
1 минуту назад, Kizilkum сказал:

диски засыпали

Не у всех помнится это работало. Но это уже не относится к теме.

Share this post


Link to post
Share on other sites
3 минуты назад, Kitaro сказал:

Не у всех помнится это работало. Но это уже не относится к теме.

и я из их числа. на 918+ все работает как надо

Share this post


Link to post
Share on other sites

пока смешное:

Если запустить VS в траснкодинг , то идет замирание картинки каждый 10-20 сек, если одновременно запустить Plex - то VS тоже работает нормально.

Похоже реально дело в параметрах драйвера ))

Как разберусь в чем дело - отпишусь )

 

Как оказалось, транскодинг работает только на FullHD, при попытке запустить какой то HEVC 4K плекс падает, похоже надо не как я, все модули снести, а те что за framebuffer отвечают - оставить )) 

 

Ан нет: Плекс всё играет, но до тех пор пока не запустишь VS - она может или в ребут отправить или ещё что ) 

Edited by TeleDDim

Share this post


Link to post
Share on other sites

VideoStation experience is bad for me also, but I don't use it. I don't think it's a matter of drivers anymore but codecs. VS is using their proprietary version of ffmpeg and in the older versions could sideload parts of 3rd party ffmpeg functions but no longer. 

https://github.com/SynoCommunity/spksrc/issues/2952#issuecomment-337214013

 

I can transcode 2 4k HEVC simultaneously with plex but VS is buffering on 1 1080p

Share this post


Link to post
Share on other sites
2 minutes ago, x01015918 said:

I can transcode 2 4k HEVC simultaneously with plex but VS is buffering on 1 1080p

I have the same.

4K HEVC in VS  reloads the system.

Share this post


Link to post
Share on other sites

mine is not rebooting, just buffering every 3-5 sec, I do always keep the display unplugged (that is causing me reboots but also in plex) my point is that if the drivers is loading fine in dmesg, hw trancoding is working in one of the apps the only different thing is the version of the codes VS is using.

Edited by x01015918

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.