How to install xpenology on an old Netgear RNDU 4000


Recommended Posts

Hi there,

 

I'm following for few month now this fantastic project, and it's time for me today to bring contribution.

For 3 months now, I'm testing xpenology both with trantor boot and gnoboot.

Seeing it's really reliable I decided to build a home made nas with motherboard and disks, migrating data from my old netgeat readynas rndu 4000.

IMO, this is a fine piece of hardware, as it always is with netgear but the software, downside is pure crap.

 

After a first try with readynas OS 6.1.6 with has been ported to older hardware by community, I was steel unsatisfied, less but still crappy.

So I thought ... why not try to install xpenology huh ?

 

Well It was not easy at first look. This little nas does have all the attributes of a standard computer ... motherboard, bios, ram, x86 atom... but no vga (there is a vga header I beleive, but unsoldered)

 

Well It's possible to boot from external usb key however.

 

So I made usb boot key with trantor kernel and pluged it in the front usb port and a keyboard in the top back usb port.

Booting with "backup" button pressed, well, this is not readynas os booting here, nothing on the lcd screen of the nas.

Pressing "enter" and then ran to my computer and starting Synology assistant.... Nothing !... no wait ! after 2 minutes, the nas showed up !

So I started an installation on DSM 5.0 beta.... after pre-install, I booted again the nas with backup button pressed and ... voilà ! The nas was up with xpenology on it.

 

This was not hard but not really reliable to have to press this button on every boot.

 

So I ssh'd the nas and saw that 2 usb storages where there. The netgear (125mb) and my boot key.

 

So I decided to backup the netgear (to have the possibility to rollback to readynas os)

 

  dd if=/dev/sdu of=some_file_name

 

And then I overwrote the boot with the xpenology boot img :

 

 dd if=synoboot-5-beta.img of=/dev/sdu

 

Reboot and .... you definitively have a xpenology nas :wink:

 

After that, I've done the same with gnoboot latest version "gnoboot-alpha10.3-vfat.img".

It's a bit tricky for install because you do not have a display but ..

"Down arrow", (wait 3 secs.) then "Enter"

Wait for 2-3 mins and then your nas shows up in Synology Assistant. You can now upgrade to DSM 5 final.

You can flash the internal usb storage with gnoboot img file, it works fine.

 

Hope it will please some old users of readynas nas which are like me, appreciate their hardware and hate their software :wink:

 

C.G.

Link to post
Share on other sites

squallef

 

The hardware is Netgear Readynas Ultra 4 (RNDU 4000)

Atom D410 1,6 Ghz (Single core)

This processor does have a full 64 bit support.

2 gb ram (so-dimm ddr2 )

4 disks...

 

It is not the weakest processor at all but not powerfull also. But the system and plex are running fairly well.

 

Regarding Asustor, if you have the hability to boot from external usb (usb key, cd or dvd...) or to have a bios access to change the boot order (some nas does have internal vga header) it might be possible to install xpenology. Once you've boot the system, the biggest part is done :wink:

 

 

C.G.

Link to post
Share on other sites

interested :

You're right about the fan noise, but it's easy to solve that with few shell tricks :

 

ipkg install mktemp
ipkg install lm-sensors

 

Then you issue :

 

sensors

 

It should read something like :

 

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +37.0°C  (crit = +100.0°C)

it8721-isa-0a10
Adapter: ISA adapter
in0:          +3.06 V  (min =  +2.20 V, max =  +3.06 V)  ALARM
in1:          +2.86 V  (min =  +0.00 V, max =  +2.08 V)  ALARM
in2:          +2.22 V  (min =  +2.12 V, max =  +1.42 V)  ALARM
+3.3V:        +3.34 V  (min =  +2.69 V, max =  +4.01 V)
in4:          +2.76 V  (min =  +2.05 V, max =  +1.91 V)  ALARM
in5:          +1.16 V  (min =  +1.46 V, max =  +1.40 V)  ALARM
in6:          +2.80 V  (min =  +0.08 V, max =  +1.52 V)  ALARM
3VSB:         +3.29 V  (min =  +5.93 V, max =  +6.05 V)  ALARM
Vbat:         +3.31 V
fan1:        2033 RPM  (min =   10 RPM)
fan2:           0 RPM  (min =   14 RPM)  ALARM
temp1:        +49.0°C  (low  = +112.0°C, high =  -5.0°C)  ALARM  sensor = thermal diode
temp2:        +33.0°C  (low  = -53.0°C, high = +61.0°C)  sensor = thermal diode
temp3:       -128.0°C  (low  = +79.0°C, high =  -7.0°C)  sensor = disabled
intrusion0:  ALARM

 

Then you issue :

sensors -s

 

It will build default config files.

 

After that you can config the pwm behavior with :

 

pwmconfig

 

It does build a /etc/fancontrol like this :

 

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=2
DEVPATH=hwmon0= hwmon1=
DEVNAME=hwmon0=coretemp hwmon1=it8721
FCTEMPS=hwmon1/device/pwm1=hwmon0/device/temp2_input
FCFANS= hwmon1/device/pwm1=hwmon1/device/fan1_input
MINTEMP=hwmon1/device/pwm1=20
MAXTEMP=hwmon1/device/pwm1=60
MINSTART=hwmon1/device/pwm1=8
MINSTOP=hwmon1/device/pwm1=10
MINPWM=hwmon1/device/pwm1=10
MAXPWM=hwmon1/device/pwm1=165

 

Then you create a startup script for fancontrol :

 

/usr/syno/etc/rc.d/S99fancontrol.sh

#!/bin/sh
#
# S99fancontrol.sh - startup script for fancontrol
#
# This goes in /usr/syno/etc/rc.d and gets run at boot-time.

FANCONTROL=/opt/sbin/fancontrol


case "$1" in

start)
       if [ -x "$FANCONTROL" ] ; then
               echo "start fancontrol"
               $FANCONTROL &
       fi
       ;;

stop)
       echo "stop fancontrol"
       kill -TERM `cat /var/run/fancontrol.pid` > /dev/null 2>&1
       logger -p daemon.error "$0 stop fancontrol"
       sleep 1
       ;;

*)
       echo "usage: $0 { start | stop }" >&2
       exit 1
       ;;

esac

 

then you do

chmod 755 /usr/syno/etc/rc.d/S99fancontrol.sh

 

After a reboot you will enjoy the sound of silence, the system will automaticaly regulate the fan speed !

 

Concerning the front display, which is the top most useless functionnality imo, I've.... unplugged it ! :smile:

When you remove the right side cover of your nas you will see a ribbon cable, just unplug it...

 

C.G.

Link to post
Share on other sites
  • 4 weeks later...

This trick work like charm, but in my ReadyNAS Pro 2 need a few improvements.

I wrote it in red :smile::

 

interested :

You're right about the fan noise, but it's easy to solve that with few shell tricks :

 

Of couse bootstrap must install and add to $PATH /opt/bin: & /opt/sbin:

 

ipkg install mktemp
ipkg install lm-sensors

 

Then you issue :

 

sensors

 

It should read something like :

 

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +37.0°C  (crit = +100.0°C)

it8721-isa-0a10
Adapter: ISA adapter
in0:          +3.06 V  (min =  +2.20 V, max =  +3.06 V)  ALARM
in1:          +2.86 V  (min =  +0.00 V, max =  +2.08 V)  ALARM
in2:          +2.22 V  (min =  +2.12 V, max =  +1.42 V)  ALARM
+3.3V:        +3.34 V  (min =  +2.69 V, max =  +4.01 V)
in4:          +2.76 V  (min =  +2.05 V, max =  +1.91 V)  ALARM
in5:          +1.16 V  (min =  +1.46 V, max =  +1.40 V)  ALARM
in6:          +2.80 V  (min =  +0.08 V, max =  +1.52 V)  ALARM
3VSB:         +3.29 V  (min =  +5.93 V, max =  +6.05 V)  ALARM
Vbat:         +3.31 V
fan1:        2033 RPM  (min =   10 RPM)
fan2:           0 RPM  (min =   14 RPM)  ALARM
temp1:        +49.0°C  (low  = +112.0°C, high =  -5.0°C)  ALARM  sensor = thermal diode
temp2:        +33.0°C  (low  = -53.0°C, high = +61.0°C)  sensor = thermal diode
temp3:       -128.0°C  (low  = +79.0°C, high =  -7.0°C)  sensor = disabled
intrusion0:  ALARM

 

Then you issue :

sensors -s

 

It will build default config files.

 

After that you can config the pwm behavior with :

 

pwmconfig

 

This work only if is installed perl on dsm :smile:

 

It does build a /etc/fancontrol like this :

 

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=2
DEVPATH=hwmon0= hwmon1=
DEVNAME=hwmon0=coretemp hwmon1=it8721
FCTEMPS=hwmon1/device/pwm1=hwmon0/device/temp2_input
FCFANS= hwmon1/device/pwm1=hwmon1/device/fan1_input
MINTEMP=hwmon1/device/pwm1=20
MAXTEMP=hwmon1/device/pwm1=60
MINSTART=hwmon1/device/pwm1=8
MINSTOP=hwmon1/device/pwm1=10
MINPWM=hwmon1/device/pwm1=10
MAXPWM=hwmon1/device/pwm1=165

 

Then you create a startup script for fancontrol :

 

In DSM 5.0 ash is default shell and this script won't work.

So install bash and change head of script, becouse bash is install in /opt/bin, not /bin

 

/usr/syno/etc/rc.d/S99fancontrol.sh

#!/opt/bin/sh 

#and this same head in fancotrol script

#
# S99fancontrol.sh - startup script for fancontrol
#
# This goes in /usr/syno/etc/rc.d and gets run at boot-time.

FANCONTROL=/opt/sbin/fancontrol


case "$1" in

start)
       if [ -x "$FANCONTROL" ] ; then
               echo "start fancontrol"
               $FANCONTROL &
       fi
       ;;

stop)
       echo "stop fancontrol"
       kill -TERM `cat /var/run/fancontrol.pid` > /dev/null 2>&1
       logger -p daemon.error "$0 stop fancontrol"
       sleep 1
       ;;

*)
       echo "usage: $0 { start | stop }" >&2
       exit 1
       ;;

esac

 

then you do

chmod 755 /usr/syno/etc/rc.d/S99fancontrol.sh

 

After a reboot you will enjoy the sound of silence, the system will automaticaly regulate the fan speed !

 

And now this trick work, fan i silent on ReadyNAS Pro 2 !!

 

Concerning the front display, which is the top most useless functionnality imo, I've.... unplugged it ! :smile:

When you remove the right side cover of your nas you will see a ribbon cable, just unplug it...

 

C.G.

Link to post
Share on other sites
  • 3 weeks later...

Hi, maybe a simple question, but where did you get/can I get the current bootcode? (synoboot-5-beta.img).

I've got my Readynas already booting from USBStick and saved the old bootcode, but where can I find the right version now?

 

Maybe a second question once I've got this finished, bootstrapping the Readynas with DSM, is it just a matter of finding the right bootstrap-code for this processor-type? I've got an Atom A410.

 

Thanks for sharing and hope I'll get a response from you guys!

Reagrds,

Ton.

Hi there,

 

So I decided to backup the netgear (to have the possibility to rollback to readynas os)

 

  dd if=/dev/sdu of=some_file_name

 

And then I overwrote the boot with the xpenology boot img :

 

 dd if=synoboot-5-beta.img of=/dev/sdu

 

Reboot and .... you definitively have a xpenology nas :wink:

 

C.G.

Link to post
Share on other sites
You must use just gnobbot image file ( i use this: gnoboot-alpha10.4-vfat.img only vfat img work !!)

 

Thanks for your response! I expected one of the zip-parts had to be the right one, but the size of the backup I created (the dd-statement) created a dump of 128MB (the size of the filesystem), so I was reluctant to just "try a file" with the risk of bricking the readynas.

 

Any idea on "How to bootstrap this device once gnoboot is running on it? "Is that a process regardless of whether the Readynas is using Radiator or Gnoboot?

 

Ton.

Link to post
Share on other sites

Do not worry to damage the ReadyNAS is not possible if you try to boot it from a usb stick.

Just moving image gnoboot xxxvfat.img to usb key (no larger than 2GB - I used 1GB) with HDDRawCopy (Windows) and you start ReadyNAS-and with this usb key like boot devices.

Don't worry about size of img it's don't matter.

 

DD copy of integral boot memory has always size full flash chip :smile:

 

The rest of the installation xpenology is described further.

Good luck !

Link to post
Share on other sites
Do not worry to damage the ReadyNAS is not possible if you try to boot it from a usb stick.

Just moving image gnoboot xxxvfat.img to usb key (no larger than 2GB - I used 1GB) with HDDRawCopy (Windows) and you start ReadyNAS-and with this usb key like boot devices.

Don't worry about size of img it's don't matter.

 

DD copy of integral boot memory has always size full flash chip :smile:

 

The rest of the installation xpenology is described further.

Good luck !

 

Thanks again mate!

I was preparing for the process of copying the vfat-img to the internal flash-memory which, imho (but I'd like to see myself as a n00b), will render the Readynas into a nice brick, hence the hesitation.

Meanwhile, I've indeed copied the *vfat.img to internal flash memory, just tried the bootstrap-script for Atom D410, rebooted and got myself the ipkg-command:-)

Did a "ipkg update" and "ipkg upgrade", then installed the packages mentioned to silence the fans.

In that process, added bash-shell through "ipkg install bash" to follow the original posters solution as much as possible and rebooted the Readynas.

 

Unfortunately, fan still running at full speed, but checking the start from the fan control daemon, must be something wrong with it.

 

Thank you very much for your contribution.

 

P.s. I'm told that the lcd CAN be put to work. I picked up the following init-script from nexentastor.org:

$ cat /etc/init.d/lcd

#!/bin/bash

echo "E" > /dev/term/b

sleep 0.5

echo "L NexentaStor" > /dev/term/b

Link to post
Share on other sites
  • 2 months later...

Hello

 

Installed nanoboot on Readynas Ultra 2 , working fine. Only problem with fanspeed, not working. Did everything you wrote. Only don't understand what you mean by " Of couse bootstrap must install and add to $PATH /opt/bin: & /opt/sbin:"

I installed IPKG and bash /opt/bin: & /opt/sbin is added in etc/profile, still not working. Any suggestions please?

 

Greets

Link to post
Share on other sites

I do not know what's not working - how to install bootstrap is quite clear, I added only what is not is not specified when installing the remaining modifications for ReadyNAS (perl installation, change the headers in the scripts, etc.) and Xpenology.

Carefully follow the directions - first you need to have a working ipkg packages (ie you need to have added the path to the binaries optware what you are doing by adding them to a .profiles file - that's why I mentioned it, then installing lm_sensors, etc.

 

You have installed perl ?

 

You have changed the header in the file "/ usr/syno/etc/rc.d/S99fancontrol.sh" to "#!/opt/bin/sh " ?

 

If so it must work!

Link to post
Share on other sites

pwmconfig command is working well, fan is responding, slowing down stopping and starting again. saving to /etc/fancontrol. /usr/syno/etc/rc.d/S99fancontrol.sh is filled, head changed to #!/opt/bin/sh. Fan is ok, is responding to pwm config. But still no reaction after reboot.

Synoready> echo $PATH

/opt/bin:/opt/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin:/opt/bin:/opt/sbin

 

Maybe I better buy a varistor from Zalman.

Link to post
Share on other sites

Ok one question: after reboot when you logged in nas over ssh could see bash prompt or synoready prompt - because S99fancontrol script work only over bash not ash, whitch is default shell syno

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites

Now all is clear: fancontrol script don't work under ash shell only bash and your netgear boot with default shell. You must install bash and edit . profile file for switch default shell to installed bash.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

After a long time I did turn my ReadyNASPRO6 on, so I need some help here, please ...

 

I have instaled:

 

- syno-i686-bootstrap_1.2-7_i686.xsh

- chmod +x syno-i686-bootstrap_1.2-7_i686.xsh

- sh syno-i686-bootstrap_1.2-7_i686.xsh

- ipkg update

- ipkg upgrade

 

edit file .profile in /root (add # before this two lines)

 

#PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin

#export PATH

 

save on exit

reboot

 

 

- ipkg install mktemp

- ipkg install lm-sensors

 

SYNOLOGY3> sensors
coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +46.0°C  (high = +76.0°C, crit = +100.0°C)
Core 1:       +36.0°C  (high = +76.0°C, crit = +100.0°C)

 

pwmconfig (comand not working ???)

Link to post
Share on other sites