Jump to content
XPEnology Community

Tutorial: DSM 6.2 on VMWare Workstation Player 15


WhileDekker
 Share

Recommended Posts

Hi

 

this is how I managed to get DSM 6.2 running on the free VMWare Workstation Player 15.

 

I know there are other tutorials for VMWare Workstation Pro and the procedure is quite similar. Following on of these tutorials (https://xpenology.com/forum/topic/13006-tutorial-vmware-workstation-dsm-62-install-esxi-compatible) brought me very close to my goal but still I had to do some try and error, therefore I am sharing my piece of the cake here.

 

Please note: This is how I made it work, dont blame me if this is not working for you.

 

1. Loader

Download Jun's Loader v1.03b DS3617xs

Synoboot_3617.zip | 19.5 MB | MD5 = 94d18efbc349da2bd45d6e57adabc54f

 

2. Convert Loader img to vmdk with Starwind V2V Image Converter (free)

image.png.db0b1438d80ada750658cfd46c4d9284.png

image.png.04527cf0535dc07d9fbf6f4b02312ad7.png

 

3. Run the "new vm wizzard" on VMWare Workstation Player

image.png.2b06f36ef6af8e1b3469c4a188dd674c.png

image.png.9a18d57fa1adaf28e751e0e9b04f2e68.png

 

The wizzard always creates a data hd, you can use this as your first data hd or delete it later.

 

image.png.c175517597da4a68d46d3d738f14746c.png

 

 Finish the wizard

 

Now edit the virtual machine settings

This is what I do usually

-          Change cpu and ram to 4/4

-          remove cd, soundcard, printer

-          change LAN to bridged

-          add x more scsi hds (same settings as when using the wizard)

 

Copy the two vmdk files from the conversion above and add as a SATA hd (select the 1k file) and select keep existing format

image.png.21fcab52ee0fe593bfa50db2c6148cba.png

image.png.dd76ce57bd9e47da1a10fd1527444993.png

image.png.3373a05f3c8348640fed6a50f9dfcf5b.png

 

This is how my setup looks after that

image.png.22dc7fa2a09a883632ef2d476e1520cb.png

 

Power up the vm and you will realize it doesnt boot – change bios boot order and after saving select VMWare while booting (you need to be real quick this is only showing for some secs).

image.png.f4e6d0d371168eb71196ed39d77a3669.png

image.png.abd2161b2d7810cd1af6bf12c65e3a85.png

 

Find your ds via find.synology.com and run installation as usual (I downloaded latest 6.2. using the link on xpenology to be sure to use a supported version).

 

When the HD erase notification appears it should show you all your data hds you added – I added 1 boot hd and 3 data hds so 3 hds should be shown.

image.png.ed7c606f74dc236848a1f57e9a8c1b42.png

 

 

Takeaways:

-          I was using an old version of Starwind V2V converter, this converted the image but apparently sth was different and it didnt really boot up correctly (no LAN).

-          When configuring the synoboot as scsi I was not able to connect to my nas (didnt get an IP from DHCP)

-          I had to select VMWare/ESXi on boot otherwise no data hd was shown during installation and dsm installation failed

-          I tried the same with DS918+, but this got me into a installation loop

-          Tested upgrade to 6.2.1. after that ds was broken – I guess the loader is not ready for it yet – so make sure auto update is disabled

 

Again, this is just my thoughts and how I managed it. Maybe things in this are wrong or understood wrong by me - but at least this is how I managed to get it running.

 

Cheers

 

Edited by WhileDekker
  • Like 1
Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...

Hi WhileDekker,

 

Great tutorial. I followed it and can very easily spin up a XPE VM in VMWare Workstation 15. All is good except 2 problems

 

1. XPE will not recognize more than the SATA boot drive and 1 other SCSI disk. No matter what other port I choose for the SCSI disks, they are not visible in XPE. I think I recreated this VM about 20 times trying different configurations. I tried adding up to 12 drives in the initial creation of the VM, no luck. I tried with just the boot drive and adding data drives one by one, and all at once, after booting XPE, no luck. No matter what I do, it will only see one data drive. Other than that, I can create a volume and pool with that single drive, share it to my home network, and add packages with no problems. 

 

2. XPE will reset whenever I reboot the VM. It boots right up, but goes to the initial menu of setting up a new Synology, including reinstalling DSM. All settings, drives are gone. I checked and the VM sees the boot drive as persistent, and the data drive is also listed as persistent. I can create and revert to a snapshot no problem, but weird that I cannot reboot the VM.

 

Have you experienced any of these issues? If not, perhaps I should create a new topic and see if the other members can shed some light.

 

Thanks again for the simple tutorial.

Link to comment
Share on other sites

Well apparently now I can add/remove drives if I use SATA drives during a live VM session, so that is good. The system just will not see SCSI drives other than the first one. I still have the problem that the VM resets if rebooted. I will keep looking into it and post back.

Link to comment
Share on other sites

  • 11 months later...
  • 1 month later...

Scratch that;) For unknown reason I was selecting SCSI as a drive type for main disk instead of SATA. Rookie's mistake.

DSM 6.2.2-24922 Update 5 works great on VMWare Fusion v.11 running on MacOs 10.14. I was however using modded loader. Should also work with standard 1.04b though

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...