The New Active Backup


Recommended Posts

On 1/25/2019 at 7:53 AM, Neos said:

Appear this error:  {"error":{"code":400},"success":false}

 

The error codes for login:

 

100 Unknown error.
101 The account parameter is not specified.
400 Invalid password.
401 Guest or disabled account.
402 Permission denied.
403 One time password not specified.
404 One time password authenticate failed.
405 App portal incorrect.
406 OTP code enforced.
407 Max Tries (if auto blocking is set to true).
408 Password Expired Can not Change.
409 Password Expired.
410 Password must change (when first time use or after reset password by admin).
411 Account Locked (when account max try exc

  • Thanks 2
Link to post
Share on other sites
Just now, hoppler said:

 

The error codes for login:

 

100 Unknown error.
101 The account parameter is not specified.
400 Invalid password.
401 Guest or disabled account.
402 Permission denied.
403 One time password not specified.
404 One time password authenticate failed.
405 App portal incorrect.
406 OTP code enforced.
407 Max Tries (if auto blocking is set to true).
408 Password Expired Can not Change.
409 Password Expired.
410 Password must change (when first time use or after reset password by admin).
411 Account Locked (when account max try exc

 

 

I've already activated it!

 

Very thx

Link to post
Share on other sites
  • 4 weeks later...
  • 2 weeks later...
  • 3 weeks later...
On 1/25/2019 at 2:53 PM, Neos said:

Hi,

 

This option for activate the Active Backup for Business is not functional.

 

When type the first URL:

Login (replace URL, PORT, USER, PASS)

https://URL:PORT/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=USER&passwd=PASS

 

Appear this error:  {"error":{"code":400},"success":false}

 

Any idea??

 

My config is:

 

Ds3615xs

ESXI 6.7

 

 

 

Have u solved the problem ?

 

I met the exactly same problem with those errors,  and I login system before activating ,  It's works!

Link to post
Share on other sites
35 minutes ago, Sbansar said:

 

Have u solved the problem ?

 

I met the exactly same problem with those errors,  and I login system before activating ,  It's works!

 

Hi,

 

the user has to be in the "administrators" group and if the password contains special characters like +?%, you have to encode it first. https://meyerweb.com/eric/tools/dencoder/

 

Example:

 

Username: test

Password: 1+?%abc

has to be encoded to: 1%2B%3F%25abc

 

Result:

https://URL:PORT/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=test&passwd=1%2B%3F%25abc

Link to post
Share on other sites
On 12/7/2018 at 7:28 PM, hoppler said:

 

  • Login (replace URL, PORT, USER, PASS)
    • https://URL:PORT/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=USER&passwd=PASS

 

for ActiveBackup its the following urls

  • Get Activationstatus
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=get&version=1
  • Set ActivationStatus (use your SERIALNUMBER)
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=set&version=1&activated=true&serial_number="SERIALNUMBER" 

 

for Office365 its the following urls

  • Get Activationstatus
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackupOffice365&method=get_activation&version=1
  • Set ActivationStatus (use your SERIALNUMBER)
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackupOffice365&method=set_activation&version=1&serial_number="SERIALNUMBER"

 

for GSuite its the following urls

  • Get Activationstatus
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackupGSuite&method=get_activation&version=1
  • Set ActivationStatus (use your SERIALNUMBER)
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackupGSuite&method=set_activation&version=1&serial_number="SERIALNUMBER"

 

THANK YOU VERY MUCH!!

Link to post
Share on other sites
15 hours ago, anibalin said:

Thanks hoppler for this workaround. I feel like goofy here since somehow it tries to google te url instead of going directly to it. Tried http and https. Odd enough it opens the status successfully.

 

Hi,

 

the issue is not because of you, but there is a hidden character between PORT and / which causes the browser to search the url instead of opening it. Here is a version without the hidden character:

 

https://URL:PORT/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=USER&passwd=PASS

Link to post
Share on other sites
On 4/5/2019 at 6:01 PM, hoppler said:

 

Hi,

 

the issue is not because of you, but there is a hidden character between PORT and / which causes the browser to search the url instead of opening it. Here is a version without the hidden character:

 

https://URL:PORT/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=USER&passwd=PASS

 

Yikes! Almost there!

What am I doing wrong now?

btw I have to use http instead of https otherwise I get an unavoidable ssl error (don't know if this relates or not).

Thanks again man!

Screenshot 2019-04-06 23.08.28.png

Screenshot 2019-04-06 23.04.png

 

edit: fixed. I'm not sure what kind of black magic is under this (I mean it) since I decided to go to your first post where you address:

https://server:5001/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=set&version=1&activated=true&serial_number="123400"

and edited the data to my case and it worked. 

Moreover, I pasted the links, as a secure step, on a text only textedit just to be sure.

 

Edited by anibalin
fixed
Link to post
Share on other sites
  • 2 weeks later...
On 4/7/2019 at 4:08 AM, anibalin said:

 

Yikes! Almost there!

What am I doing wrong now?

btw I have to use http instead of https otherwise I get an unavoidable ssl error (don't know if this relates or not).

Thanks again man!

Screenshot 2019-04-06 23.08.28.png

Screenshot 2019-04-06 23.04.png

 

edit: fixed. I'm not sure what kind of black magic is under this (I mean it) since I decided to go to your first post where you address:

https://server:5001/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=set&version=1&activated=true&serial_number="123400"

and edited the data to my case and it worked. 

Moreover, I pasted the links, as a secure step, on a text only textedit just to be sure.

 

 

Thank you.

Link to post
Share on other sites

Hello! Im trying these links for Active Backup for Office 365

Quote

for Office365 its the following urls

  • Get Activationstatus
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackupOffice365&method=get_activation&version=1
  • Set ActivationStatus (use your SERIALNUMBER)
    • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackupOffice365&method=set_activation&version=1&serial_number="SERIALNUMBER" 

 

But I'm getting a  error code 105. I have not seen anybody have that code before.

Someone who knows what to do?

 

Edit: Solved it! Did not login at first...

Edited by joulester
Link to post
Share on other sites
8 hours ago, nqn_vnn said:

I'm getting error code 103. Someone who knows what to do? Thanks all.

 

100 Unknown error
101 Invalid parameter
102 The requested API does not exist
103 The requested method does not exist
104 The requested version does not support the functionality
105 The logged in session does not have permission
106 Session timeout107Session interrupted by duplicate login

 

Either ActiveBackup is not installed or its deactivated

Link to post
Share on other sites
On 5/1/2019 at 7:57 PM, hoppler said:

 

100 Unknown error
101 Invalid parameter
102 The requested API does not exist
103 The requested method does not exist
104 The requested version does not support the functionality
105 The logged in session does not have permission
106 Session timeout107Session interrupted by duplicate login

 

Either ActiveBackup is not installed or its deactivated

Thanks All, i changed my serial and done :)

Link to post
Share on other sites
  • 2 months later...
  • 4 weeks later...

hoppler method worked for me eventually but on first URL I had to turn of two factor authentication on my NAS or I got the error code 402.   I then renable two factor once I got bothURLS to say success. Just FYI to others that may have two factor turned on.

 

On 12/4/2018 at 9:24 AM, hoppler said:

There is a better way^^ Just activate it:

 

In your browser open the following urls one after another:

 

Replace the following: URL, PORT, USER, PASS, SERIALNUMBER (dont replace any other symbols like : oder ")

  1. https://URL:PORT/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=USER&passwd=PASS
  2. https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=set&version=1&activated=true&serial_number="SERIALNUMBER"

To get the current activation status call the 1. query above and then

  • https://URL:PORT/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=get&version=1

------------------------------

Example for

url: server,

port: 5001,

user: admin,

pass: admin,

serialnumber: 123400

  1. https://server:5001/webapi/auth.cgi?api=SYNO.API.Auth&method=Login&version=1&account=admin&passwd=admin
  2. https://server:5001/webapi/entry.cgi?api=SYNO.ActiveBackup.Activation&method=set&version=1&activated=true&serial_number="123400"

 

Link to post
Share on other sites

This is stupid question.  I got the Active backup activated.  But I can't get it to connect to my esxi server. I open active backup and go to virtual machine, add,  then enter the following.

 

server address: 192.168.1.10 This is the address i use to access the gui in chrome.

web services port:443

data transferport: 902

account: admin

password: password

 

I get error "Fail to connect to the host {192.168.1.10]. Please check the server address, acountt settings and your network settings.

 

I disable synology firewall just to make sure synology wasn't blocking something.

ESXI has firewall rules for  443 & 902.

 

Any help is appreciated

 

 

Link to post
Share on other sites
On 8/23/2019 at 3:32 AM, rockytoptim said:

This is stupid question.  I got the Active backup activated.  But I can't get it to connect to my esxi server. I open active backup and go to virtual machine, add,  then enter the following.

 

server address: 192.168.1.10 This is the address i use to access the gui in chrome.

web services port:443

data transferport: 902

account: admin

password: password

 

I get error "Fail to connect to the host {192.168.1.10]. Please check the server address, acountt settings and your network settings.

 

I disable synology firewall just to make sure synology wasn't blocking something.

ESXI has firewall rules for  443 & 902.

 

Any help is appreciated

 

 

 

You will need to start SSH and ESXi-Shell in the ESXi host (configuration tab), start the deamon and set the option to "start and stop with the host"

Link to post
Share on other sites

Hi All,

 

Installed Active Backup and Active Backup for Office 365. I was able to activate Active Backup for Business but when I try to activate Active Backup for Office 365, I get the code below.

 

{"error":{"code":102},"success":false}

 

I checked the Installed section and it does show Active Backup for Office 365 as Running.

 

Is the serial different for each package? 

 

Logged in as admin. Again, I didn't have any problems with Active Backup for Business.

 

Thanks!

Link to post
Share on other sites
9 hours ago, Chuck12 said:

Hi All,

 

Installed Active Backup and Active Backup for Office 365. I was able to activate Active Backup for Business but when I try to activate Active Backup for Office 365, I get the code below.

 

{"error":{"code":102},"success":false}

 

I checked the Installed section and it does show Active Backup for Office 365 as Running.

 

Is the serial different for each package? 

 

Logged in as admin. Again, I didn't have any problems with Active Backup for Business.

 

Thanks!

Nevermind. I got it working after a good night's sleep and reading the instructions again. 

 

Thank you!

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.