Jump to content
XPEnology Community

Hp n40l


Recommended Posts



I updated with my NICs as stated above, and I confirm, that is does not work!

Just to be sure: I disabled the internal NIC and I went to the grub command line adjusting the mac1 to one of my intel MAC addresses. (Not sure it it is the first or the second NIC of the card)

Is there something, I have overseen, but I should have done?

So is it sure now, that my NIC is not compatible?

Nevermind, it is only a backup server, I have time to fix it.

Regards, Tomte

Link to comment
Share on other sites



I inserted now a NC360T NIC and adjusted the MAC1 and MAC2 entries, however, it does still not boot.

Anything else I can do? Or how do I initiate a reinstall without loosing my data? Do I have to regenerate the stick from scratch?


Regards, Tomte

Link to comment
Share on other sites


now this is very strange:

I got as far as the spash screen "Happy Hacking" ....

Nothing happended.

Now, I generated a new stick, startet again: Now the HP showed up in the Synology Assistant with status "repairabel" (in German).

I chose this, but it did not succeed.

Selecting "Reinstall" in GRUB also did not help.

So I regenerated the USB stick once again and removed all drives and simply chose the upper option.

Waited until it showed up in "find.synology.com", put all drives back in place and reinstalled DSM 6.2.

Fine so far, all worked fine.

Then I activated SSH, checked the driver - e1000e, ok.

Finally, I selcted in the WebGUI to update to 6.2.1 - and it never appeared again.

Booting simply ends with "Happy Hacking" and this is it. No futher HDD activities.

Have I missed something? I adjusted mac1,mac2, pid, vid, serial, ...

Should I have updated to 6.2.1 manually by .pat file?


Regards, Tomte

Edited by Tomte
Link to comment
Share on other sites

i have get a 2dn Hand HP N40L and was able to install DSM 6.2.1-23824 Update 1 with an Intel® PRO/1000 PT Quad Port Server Adapter  what i found in a old Dell Server.


I used the this Boot File https://mega.nz/#!OV4gVKyZ!dCgfXx1bgAOyvbFwFiov3s7RSNoFuqnAcNmSllLoUiw

adjusted the grub file with the S/N of a 3615xs add first MAC of the 4 i have on the NIC and everything was reconized.

i can see in the Network Interface List all 4 Nic Ports in the DSM Manager

Link to comment
Share on other sites



stupid me, I found my problem. I used the DS3617xs image. With this, 6.2.1 is not working.

Now I tried DS3615xs - works like a charm!😁


This is the NIC I bought:


(in case somebody is searching for a suitable NIC)


Thanks to everybody who tried to help me!


Regards, Tomte

  • Thanks 1
Link to comment
Share on other sites

  • 2 months later...

Hi Guys. I installed a Intel NIC and 6.2.1 its working just fine. One question though, but I'm not sure of the answer since I have read opposed ones. Do I need the USB if I shutdown the server and power on again? Seems that its my case since it wont load from any of the 4 internal drives now running DSM.

I guess I can unplug the usb key once DMS loads but seems I need it to start the system.


Thanks in advance for clarifying this. 

Link to comment
Share on other sites

8 hours ago, bearcat said:

@anibalin Since the USB stick holds your boot-image, it is mandatory to keep it installed if you want/need to boot/reboot your NAS.


Short and simple said:  leave your USB stick connected at all times!


Thanks bearcat! got it.

Is is possible then to install it on a small ssd instead of relying on an external usb?


Link to comment
Share on other sites

  • 4 months later...
On 11/18/2018 at 2:06 PM, bearcat said:

@MrJonesiii The HP NC360T, is a dual port NIC, using the 82571EB chipset. And it can be found on E-bay as well as other places.


It's not that you must use this card, as most Intel based NIC's are compatible using these drivers:

e1000: Intel PCI/PCI-X Gigabit Network Adapters Intel PRO/1000 CT/F/GT/MF/MT/T/XF/XT 82573L/82572EI/82571EB/82573E/82573V/82567/82574L/82566MM/82566MC
e1000e: Intel PCIe PRO/1000 82563/82566/82567/82571/82572/82573/82574/82577/82578/82583/Gigabit CT Desktop Adapter/PRO/1000 PT/PF/I217-LM/V/I218-V/LM/I219 LM/V (tested, v3.4.0.2 from external source)
i40e: Intel 40 Gigabit X710-AM2/XL710-AM1/XL710-AM2/X710-DA2/X710-DA4/XL710-QDA1/XL710-QDA2
igb: Intel Gigabit Ethernet 82575/82576/82580/I350/I210/I211


If you want the 6.2 (not the 6.2.1):

Optional step 0 - Find a compatible NIC (just in case an update will come)

1 - Download Jun's Loader v1.03b DS3615xs

2 - Prepare a new USB stick

3 - Find your vid/pid/mac/serialnr,

4 - Edit the grub.cfg in your synoboot.img 

5- Write synoboot.img to your new USB stick

6 - Download DSM_DS3615xs_23739.pat to do a local install.

7 - Shotdown your NAS, replace the USB stick with the new.

8 - Power on your NAS, enter BIOS, disable C1.

9 - Reboot your NAS, find it using Syno Assistent, connect and update using the local copy of the .PAT file.

10 - Something, something missing ... 

11 - Something, something missing ... 

12 - Something, something missing ... 
13 - Something, something missing ... 

14 - DSM automatic updates should be disabled in Control Panel > Update & Restore to avoid bricking your box if an update is not compatible with the loader.


The picture below, is actually from a HP N40L, running DSM 6.2-23739 Update 2, wanting me to update to 6.2.1.





I have The HP NC364T, is a quad port NIC, using the 82571EB chipset => it's good too ? 


How i can have MAC Adress ?


thanks for help

Link to comment
Share on other sites

  • 3 weeks later...

@bambou78000 Hi, I have been away and not seen your post before now.

Yes, as you might see, both the NC360T and NC364T are using the same chipset, and should work well. If you search the forum, yo might see other users with the same card.

The MAC addresses should be found on a label on the NIC, else you have to boot a computer with the NIC installed, and find it in the POST as it should be reported there.

(in "worst case" connect all 4 ports to a router/DHCP server, and check the log for the MAC's).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...