DSM 5.x/6.x CPU name & cores infomation Change tool


Recommended Posts

15 hours ago, flyride said:

When I look at /proc/cpuinfo, I see an output block for each thread (core ID increments and core count is accurate with 4 cores).  You only have 1.  That would be alarming to me.

 

can you be more specific? i don't get it.

do you know a solution for this issue?

Link to post
Share on other sites
1 minute ago, m_catalin said:

can you be more specific? i don't get it.

do you know a solution for this issue?

 

Your concern is whether your processor cores are all active with DSM, and by the looks of /proc/cpuinfo, they are not.  My only thought is to ask if you are running a VM with processor restrictions?

Link to post
Share on other sites
  • 1 month later...
On 7/7/2020 at 10:00 PM, m_catalin said:

no, is bare metal. is not virtual. On the old DSM it worked fine. my concern is the same, i don't know if it's using all 6 cores. 

as long as it is within the limit of the kernel it will be used, these limits are predefined by synologys precompiled kernel that is used with xpenology (HT counts a cpu threat so if HT is available the core count needs to be doubled - thats the reason why its 8 for 3615, the original cpu had 4 cores with HT)

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

in your case there is no HT, just  6 cores and thats ok for all three available loader/images

Link to post
Share on other sites
  • 2 months later...
  • 1 month later...

Works on baremetal install, script version: 2.2.1-r01. 

 

Needed to chmod 777 the file once extracted, then it ran and selected option 1, no issues. 

 

My Hardware:

ASUSTEK - 90MB10N0-M0EAY0  - PRIME B365M-A 

INTEL - BX80684I59400  - CORE I5-9400 

KINGSTON - HX424C15FB3/8  - HyperX FURY - DDR4 - module - 8 GB

SEAGATE - ST6000VN001  - IRONWOLF 6TB

 

image.png.a6818c2e3a5b64614fd28c67f225706e.png

Edited by kevinmce
Link to post
Share on other sites
В 01.01.2021 в 19:17, TNa681 сказал:

Hi and Happy New Year.

 

Tried it but failed. Does anybody know why and how to solve it?

 

 

2132680693_Bildschirmfoto2021-01-01um17_15_46.thumb.png.966fbac2ef1ccd319f5849021385a604.png

You must do this over SSH on your DiskStation. After unpacking tar issue the command "chmod +x ch_cpuinfo"

  • Thanks 1
Link to post
Share on other sites

Hi Guys, 

 

I know this question has been asked elsewhere, but seeing as this tool is somewhat related im wondering if the OP noticed any possible changes that could be made to fix bare metal xpenology installs not showing the correct CPU temperature?

 

Its a minor inconvenience but a noticeable one since i have my servers monitored by home assistant.

image.png.aa984edf47cb0b60ca089a8312cf2b0c.png

image.thumb.png.fd185836ec886b769ca585abaa04d983.png

Link to post
Share on other sites

Hi all

 i can run this script.

But when i select option 1 there is a message :

There is a history of running the same version please select option 2 i have done this many times.

Every time i have the same message.

Any tip Please help

Thank you

DSM CPU Information Change Tool ver. 2.2.1-r01 - made by FOXBI

Your version of DSM is DSM 6.2.3-25426 Update 3  continue...

1) First run  2) Redo  3) Restore - Select Number : 1

There is a history of running the same version. Please run again select 2) redo                                                                                         .

root@JANCOLER:/volume1/homes#
 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.