n40l usb3 pci-e card not functioning in DSM 6.2


Recommended Posts

Hi,

 

I have recently updated DSM on my HP N36/40L microserver. Prior to the upgrade to DSM 6.2 I had a working 2 port USB3 PCI-E card. However I have just gone to plug my external HDD into the card and it spins up but does not register in DSM. The disk is fine, I have checked on my Windows PC and also it is visible (and usable) when plugged into one of the USB2 ports built into the server.

Not sure where to go with this but would be good to get USB3 working to speed up backups. The card is a TS-PDC3.

 

Thanks in advance

Link to post
Share on other sites
  • 2 months later...
  • 2 weeks later...
  • 4 weeks later...

Lspci output :


0000:03:00.0 Class 0c03: Device 1912:0015 (rev 02) (prog-if 30)
        Flags: fast devsel, IRQ 16
        Memory at fe9fe000 (64-bit, non-prefetchable)
        Capabilities: [50] Power Management version 3
        Capabilities: [70] MSI: Enable- Count=1/8 Maskable- 64bit+
        Capabilities: [90] MSI-X: Enable- Count=8 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [150] Latency Tolerance Reporting

Link to post
Share on other sites

As an update because I had inadvertantly upgraded to 6.2 and didnt feel like trying to downgrade to get my card to work, I purchased a Dell U3N2-D pci-e USB3 card which seems to work ok. There was another thread on here discussing compatible cards. Just need to sort out the not fully powering off issue now!

  • Like 1
Link to post
Share on other sites
  • 1 month later...

Hi.

I managed to get my uPD720202 work again. I flashed newest firmware (2.0.2.6) for this card and everything works. Firmware downloaded from Station Drivers

 

https://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=fileinfo&id=1348&lang=en

 

Flasher is for windows only, so I must boot microserver from USB with Windows PE

Edited by sszpila
  • Like 1
Link to post
Share on other sites
  • 4 weeks later...
On 2/9/2019 at 12:16 PM, sszpila said:

Hi.

I managed to get my uPD720202 work again. I flashed newest firmware (2.0.2.6) for this card and everything works. Firmware downloaded from Station Drivers

 

https://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=fileinfo&id=1348&lang=en

 

Flasher is for windows only, so I must boot microserver from USB with Windows PE

Hi sszpila, i would like to thank you for the tip!!!

it worked perfectly for my Startech PEXUSB3S25 Renesas/NEC uPD720202 that is just arrived today.

p.s. I have an HP N40L with 1.0.3b loader with latest DSM 6.2.1 U6 update

Edited by Stefano
Link to post
Share on other sites
  • 11 months later...
On 2/9/2019 at 12:16 PM, sszpila said:

Hi.

I managed to get my uPD720202 work again. I flashed newest firmware (2.0.2.6) for this card and everything works. Firmware downloaded from Station Drivers

 

https://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=fileinfo&id=1348&lang=en

 

Flasher is for windows only, so I must boot microserver from USB with Windows PE

Hello sszpila, 

Thank you for the hint, I bought this USB 3 PCIe card https://www.amazon.fr/gp/product/B0094H9NK8/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1 and I made the firmware update like you wrote and now all is good with my HP N54L 1.03b loader DSM 6.2.2-24922 Update 4

Regards,

TomX

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.