Recommended Posts

il y a 1 minute, pi3r3 a dit :

Réponse à moi même, j'ai positionné la MAC que tu m'a indiqué manuellement sur la carte réseau et ça fonctionne!
Par curiosité je vais tester avec le 918+

Avec le 918+, ta mac est 00:11:32:12:34:56

Link to post
Share on other sites
il y a 22 minutes, nicoueron a dit :

Avec le 918+, ta mac est 00:11:32:12:34:56

 

ça fonctionne! Je pense ne pas avoir vu cette information dans le tuto (passer manuellement la MAC sur la carte réseau).

Merci pour tes retours très rapide!!

Pour une nouvelle installation autant que je parte sur le DS918+ avec un loader plus récent?

 

J'ai tenté d'installer DSM_DS918+_23739.pat avec l'erreur suivante?

image.png.e59f5dc29965d78eec19bb8ea59ad1b7.png

Edited by pi3r3
Link to post
Share on other sites

Normal que ce ne soit pas sur le tuto car il n'y a pas a modifier quoique ce soit concernant l'adresse mac sauf si tu veux utiliser plus d'une VM DSM sur le même réseau. Là ton pb c'est que sur ta Livebox tu as du activer la restriction sur liste blanche au niveau du DHCP, ce qui t'a obligé à ajouter cette adresse au niveau de sa config.

 

Pour une nouvelle installation, peu importe la version. Du moment que c'est compatible tu n'y verras que du feu. Après il me semble que le DS918+ est plus "souple" pour le transcodage que les autres. 

Link to post
Share on other sites

Parfait je parviens bien à installer le DS918+ et j'avais oublié de mettre un disque d'où l'erreur de formattage!

 

Pour le filtrage DHCP je n'ai rien configuré coté Livebox mais dans le Grub l'adresse MAC est inscrite en dur et ne correspond pas à la vraie MAC de la carte de la VM il doit y avoir eu un soucis de coté là.

 

Tout roule donc de mon coté je n'ai plus qu'à configurer :)

Link to post
Share on other sites
à l’instant, pi3r3 a dit :

Pour le filtrage DHCP je n'ai rien configuré coté Livebox mais dans le Grub l'adresse MAC est inscrite en dur et ne correspond pas à la vraie MAC de la carte de la VM il doit y avoir eu un soucis de coté là.

C'est toujours l'adresse mac du loader qui fait foi, pas celle de la VM. Celle de la VM est modifiée par le loader afin de laisser la main au propriétaire de mettre celle d'un vrai NAS Synology.

Link to post
Share on other sites

Bonjour; j'ai essayé deux des templates présent sur ton tuto mais je n'arrive pas, à obtenir d'adresse IP. J'ai essayé de forcer avec l'adresse MAC mais c'est pareil... J'avoue être nouveau sur Exsi (même si j'ai réussi à importer et lancer des machines virtuelles pour Jeedom par exemple que je faisais tourner sur un PC). Qu'est ce que je peux essayer de vérifier? Merci 😕

Edited by Nerso
Link to post
Share on other sites
2 hours ago, Nerso said:

Bonjour; j'ai essayé deux des templates présent sur ton tuto mais je n'arrive pas, à obtenir d'adresse IP. J'ai essayé de forcer avec l'adresse MAC mais c'est pareil... J'avoue être nouveau sur Exsi (même si j'ai réussi à importer et lancer des machines virtuelles pour Jeedom par exemple que je faisais tourner sur un PC). Qu'est ce que je peux essayer de vérifier? Merci 😕


je peux te conseiller ceci;

- 1) Essaye de changé le type de carte réseau 

-2) regarde au niveau de ton serveur dhcp si il voit ta vm  sur le réseau

- 3) configure la sortie d’écran vers un fichier output tu pourras voir lire les logs du boot via ce fichier et voir ou cela peu coincé éventuellement...

Link to post
Share on other sites
il y a 45 minutes, prbreezy a dit :


je peux te conseiller ceci;

- 1) Essaye de changé le type de carte réseau 

-2) regarde au niveau de ton serveur dhcp si il voit ta vm  sur le réseau

- 3) configure la sortie d’écran vers un fichier output tu pourras voir lire les logs du boot via ce fichier et voir ou cela peu coincé éventuellement...

Voilà le fichier serial.out

 

:: Starting syslogd ... [  OK  ]
:: Starting scemd
:: Starting services in background
Starting findhostd in flash_rd...
Starting services in flash_rd...
Running /usr/syno/etc/rc.d/J01httpd.sh...
Starting httpd:80 in flash_rd...
Starting httpd:5000 in flash_rd...
Running /usr/syno/etc/rc.d/J03ssdpd.sh...
/usr/bin/minissdpd -i eth0
(15): upnp:rootdevice
(51): uuid:upnp_SynologyNAS-0011322ca603::upnp:rootdevice
(60): Synology/synology_broadwell_3617xs/6.2-23739/169.254.145.210
(48): http://169.254.145.210:5000/description-eth0.xml
Connected.
done.
/usr/syno/bin/reg_ssdp_service 169.254.145.210 0011322ca603 6.2-23739 synology_broadwell_3617xs eth0
Running /usr/syno/etc/rc.d/J04synoagentregisterd.sh...
Starting synoagentregisterd...
Running /usr/syno/etc/rc.d/J30DisableNCQ.sh...
Running /usr/syno/etc/rc.d/J80ADTFanControl.sh...
Running /usr/syno/etc/rc.d/J98nbnsd.sh...
Starting nbnsd...
Running /usr/syno/etc/rc.d/J99avahi.sh...
Starting Avahi mDNS/DNS-SD Daemon
cname_load_conf failed:/var/tmp/nginx/avahi-aliases.conf
:: Loading module hid ... [  OK  ]
:: Loading module usbhid[   16.825343] usbcore: registered new interface driver usbhid
[   16.826330] usbhid: USB HID core driver
 ... [  OK  ]
============ Date ============
Sun Oct 18 17:43:44 UTC 2020
==============================
starting pid 6391, tty '': '/sbin/getty 115200 console'

Sun Oct 18 17:43:45 2020

DiskStation login: [   95.770558] e1000e: eth0 NIC Link is Down
[   96.673074] e1000e 0000:03:00.0: irq 77 for MSI/MSI-X
[   96.775230] e1000e 0000:03:00.0: irq 77 for MSI/MSI-X
[   96.783522] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

Link to post
Share on other sites
4 hours ago, Nerso said:

e1000e: eth0 NIC Link is Down

C’est pas bon signe cela... mais après elle est up

 

tu as tenté de changer le type de carte réseau ? Vérifie que elle est connecté au boot la carte réseau?

Edited by prbreezy
Link to post
Share on other sites

Salut,

 

oui mais 1s plus tard elle est de nouveau up.

reste ces options :

  • soit la carte réseau de la VM n'est pas raccordée au bon vSwitch 
  • soit le serveur DHCP n'est pas autorisé à attribuer l'IP, genre tu as mis une liste blanche d'adresse MAC.
Link to post
Share on other sites

Merci de vos réponses. Sans trop savoir pourquoi à force d'insister et après avoir reboot mon routeur etc c'est passé. J'ai même réussi à mettre le disque de mon DS123j en RDM (grâce à des tutos trouvés sur Youtube) et j'ai pu récupérer mes données sans rien faire. On sent quand même bien la différence avec mon 13j, je lui ai attribué 4 coeurs et 4go de RAM.

Link to post
Share on other sites
  • 3 weeks later...

Question bete, mais je trouve pas la réponse ...

Ca sert a quoi la virtualisation concretement (VM) ? pour mon gen8 stock c'est quoi le mieux ? (et le plus simple car je suis paumé ^^"; je suis en 5.2 mais je dois absolument le mettre a jour a cause de plex ...)

Merci de vos réponses et votre patience !

Link to post
Share on other sites

Bonjour,

La virtualisation a de nombreux intérêts, mais dans le cas de XPenology, le principal est de s'affranchir du matériel existant.

Un VM (machine virtuelle) présentera toujours le même type de matériel (supposé être géré par XPenology quelque soit sa version, comme la carte réseau par exemple) et se basera sur les fonctionnalités d'un hyperviseur (système d'exploitation spécifique chargé de gérer plusieurs VM à la fois) qui transcrira les requêtes faites au niveau du matériel de façon à les rendre compatibles avec le matériel existant physiquement.

Les VM vont donc devoir se partager les ressources réelles (c'est à dire celles du matériel comme le/les proc(s), la RAM, l'espace disque, le réseau, etc...) et c'est l'hyperviseur qui arbitrera le tout. Pour illustrer avec le cas du réseau, une VM XPenology fera des requêtes en utilisant un driver pour une carte Intel e1000e (1Gb/s) mais ensuite l'hyperviseur insèrera le trafic vers la (ou les) carte(s) physique(s) qui peu(ven)t très bien être de type Dlink, 3com ou autre si elle sont gérées par l'hyperviseur.

Le plus professionnel des hyperviseurs est probablement ESXi de VMware et une version gratuite est disponible (et suffisante pour bien des cas). Il y a aussi HyperV de Microsoft.

D'autres approches existent comme VirtualBox (racheté par Oracle) qui n'est pas vraiment un hyperviseur mais un logiciel qui s'interface entre les VM et le système d'exploitation de l'ordinateur (Window, Linuw, Mac). Dans ce cas les performances et les possibilités sont plus limitées mais quand il s'agit juste de faire tourner une VM de temps en temps, il peut très bien suffire. Pour un NAS en service en permanence, ce n'est pas vraiment adapté, mais pour des tests, pourquoi pas.

L'avantage aussi des VM est de pouvoir revenir à une configuration initiale (utilisation de snapshots) après installation de patches, de changement de version, etc... ce qui permet des tests de compatibilité sans risque pour les données (tant qu'on ne formate pas les disques bien entendu).

 

Pour XPenology, ESXi permet d'avoir un environnement stable, éprouvé, et constant pour suivre les évolutions de version quelque soit le matériel en dessous. De plus, comme les entreprises utilisent très souvent VMware pour leurs environnements de développement et de tests, on est à peu près certain de conserver une compatibilité avec les prochaines versions. Une VM de test peut être créé pour vérifier la stabilité d'une nouvelle version et si ça fonctionne mettre ensuite à jour la version de la VM "réelle". Cela permet aussi d'héberger plusieurs VM pour de la domotique, un NAS, un test avec Linux ou Windows, etc... Tout dépendra des capacités de la machine "hôte" à faire fonctionner plusieurs VM simultanément (RAM et ressources PROC et HDD).

 

Jacques

Edited by JacquesF
Link to post
Share on other sites

Et pour compléter la réponse de @JacquesFje dirai plus simplement que l'usage de la virtualisation répond simplement à un besoin de disposer de plusieurs OS sur une seule et même machine. Ceci afin de réduire drastiquement les coûts liés au matériel.

Ex : sur une seule machine physique dotée par exemple de 16Go de RAM et d'un CPU Intel core i5 on peut facilement faire tourner 1 ou plusieurs Linux, 1 Windows, 1 DSM en même temps! (si l'espace disque le permet évidemment).

Link to post
Share on other sites

bonjour a tous,

 

j'ai un soucis sur mon xpenology depuis hier et je sèche...

 

hier j'ai voulu installer un conteneur docker, je vais sur mon dash, je cherche mon conteneur dans docker, je l'installe jusque la pas de soucis....et la les soucis commence, impossible d'arrêter mon conteneur, je decide alors de relancer docker....et la impossible aussi de redémarrer docker....bon je tente de relancer mon dsm...et la le drame...

 

je vois bien dsm sur le réseaux, j'ai acces a mes disque partagés sur le réseaux, l'appli synology vois aussi mon syno, mais impossible d'aller sur le dash....j'ai testé avec plusieurs pc, téléphone, tablette...avec ip local ou ip externe, port http et https...mon port est bien ouvert sur la box.

 

 

il y a t'il une méthode pour pouvoir sur quel port dsm tourne, car j'ai l'impression qu'ils ont changés

 

sinon je referais l'installation de mon syno, j'ai pas fait de snapshot....mon installe est sur un hp gen8 sous esxi...et dsm a jours

 

 

Link to post
Share on other sites

Bonjour,

Voir sur quel port tourne le DSM peut se faire de la manière suivante :

1) Si tu as accès en SSH au NAS, la commande netstat -lataupen (éventuellement via sudo) permet de voir quels sont les ports ouverts (le "n" indique d'afficher les numéros et non les noms). En principe, c'est le serveur nginx qui supporte les connexions HTTP(S) au DSM (c'est le cas sur le mien).

La commande n'affiche le nom des process que si on en est propriétaire ou si le compte root est utilisé (d'où l'intérêt d'utiliser sudo).

2) Lancer la commande nmap @IP_du_NAS sur une machine Linux ou installer le programme et le lancer sur une machine Windows.

Celui-ci va scanner tous les ports par défaut (voir le manuel pour indiquer les plages de ports à tester) sur l'adresse IP (ou le nom DNS local du NAS) et afficher quels sont les ports ouverts.

 

Jacques

Edited by JacquesF
  • Like 1
Link to post
Share on other sites
Il y a 2 heures, JacquesF a dit :

Bonjour,

Voir sur quel port tourne le DSM peut se faire de la manière suivante :

1) Si tu as accès en SSH au NAS, la commande netstat -lataupen (éventuellement via sudo) permet de voir quels sont les ports ouverts (le "n" indique d'afficher les numéros et non les noms). En principe, c'est le serveur nginx qui supporte les connexions HTTP(S) au DSM (c'est le cas sur le mien).

La commande n'affiche le nom des process que si on en est propriétaire ou si le compte root est utilisé (d'où l'intérêt d'utiliser sudo).

2) Lancer la commande nmap @IP_du_NAS sur une machine Linux ou installer le programme et le lancer sur une machine Windows.

Celui-ci va scanner tous les ports par défaut (voir le manuel pour indiquer les plages de ports à tester) sur l'adresse IP (ou le nom DNS local du NAS) et afficher quels sont les ports ouverts.

 

Jacques

merci de l'explication tres bien decrite

 

N'ayant pas acces via ssh a dsm, je l'avais desactivé...j'ai fais un scan via l'appli sur windows et j'ai joint le resultat

 

je ne vois pas le port de dsm...j'ai bien ftp, samba, et d'autre port mais ne me donne pas acces au dash.

scan port.pdf

Edited by z750leovince
Link to post
Share on other sites

Bonsoir,

 

Je ne vois pas non plus le(s) port(s) DSM.

As-tu lancé nmap avec l'option de scan de tous les ports ? ( nmap -p1-65535 IP_du_NAS ) ?

Sur le mien, le scan retourne ceci :

PORT      STATE SERVICE
22/tcp    open  ssh
80/tcp    open  http
139/tcp   open  netbios-ssn
443/tcp   open  https
445/tcp   open  microsoft-ds
3261/tcp  open  winshadow
3262/tcp  open  unknown
3263/tcp  open  ecolor-imager
3264/tcp  open  ccmail
3690/tcp  open  svn
5000/tcp  open  upnp
5001/tcp  open  commplex-link
6690/tcp  open  unknown
49160/tcp open  unknown
49170/tcp open  unknown
50001/tcp open  unknown
50002/tcp open  iiimsf

Nmap done: 1 IP address (1 host up) scanned in 52.32 seconds

Les ports DSM sont indiqués comme upnp (DAM-http) et complex-link (DSM-https) comme ils sont référencés dans le fichiers services de ma amchine (principaux ports connus).

Si tous les ports ont été scannés, alors le DSM ne tourne pas à priori.

Sinon, relancer le test en analysant tous les ports et tenter une connexion http://IP_du_NAS:Numero_du_port/ et voir ce qui réagit en face.

 

Bon courage

Jacques

Link to post
Share on other sites
Il y a 1 heure, JacquesF a dit :

Bonsoir,

 

Je ne vois pas non plus le(s) port(s) DSM.

As-tu lancé nmap avec l'option de scan de tous les ports ? ( nmap -p1-65535 IP_du_NAS ) ?

Sur le mien, le scan retourne ceci :


PORT      STATE SERVICE
22/tcp    open  ssh
80/tcp    open  http
139/tcp   open  netbios-ssn
443/tcp   open  https
445/tcp   open  microsoft-ds
3261/tcp  open  winshadow
3262/tcp  open  unknown
3263/tcp  open  ecolor-imager
3264/tcp  open  ccmail
3690/tcp  open  svn
5000/tcp  open  upnp
5001/tcp  open  commplex-link
6690/tcp  open  unknown
49160/tcp open  unknown
49170/tcp open  unknown
50001/tcp open  unknown
50002/tcp open  iiimsf

Nmap done: 1 IP address (1 host up) scanned in 52.32 seconds

Les ports DSM sont indiqués comme upnp (DAM-http) et complex-link (DSM-https) comme ils sont référencés dans le fichiers services de ma amchine (principaux ports connus).

Si tous les ports ont été scannés, alors le DSM ne tourne pas à priori.

Sinon, relancer le test en analysant tous les ports et tenter une connexion http://IP_du_NAS:Numero_du_port/ et voir ce qui réagit en face.

 

Bon courage

Jacques

j'ai utilise cet ligne de commande nmap -T4 -A -v ip du nas

 

c'est une ligne qui est cree directement sur l'app, c'est profil intens scan...

Link to post
Share on other sites

Ces options ne permettent pas un scan complet des ports.

Je te conseille de refaire le test avec -p1-65535 pour être certain que tout est scanné.

Si le DSM tourne sur un port non standard, c'est la seule méthode (du moins que je vois pour le moment) pour voir ce qui tourne sur le NAs et est accessible depuis le LAN.

Jacques

Link to post
Share on other sites

j'ai refais un test avec ta ligne de commande, idem je ne vois pas les port de dsm. je n'y est pourtant pas toucher...de base c'est ceux d'origine.

 

de plus mon syno tourne car j'accède aux disque en samba via Windows, et aussi j'accède en ftp.

 

je pense que je vais être bon pour réinstaller dsm au propre, mais je vois pas ce qui c'est passé...

 

meme mon port 80 n'est pas visible...j

Edited by z750leovince
Link to post
Share on other sites
  • 1 month later...

Bonjour à tous et merci pour les configs.

 

Je suis nouveau dans le monde de la virtualisation, tout fonctionne pour moi sur VMware Workstation mais un petit soucis subsiste.

Je n'arrive pas à avoir des disques virtuels de plus de 2040 Go, c'est embêtant car mon but était de faire un volume en raid 5 (DSM) avec 3x 4to et d'avoir un volume secondaire avec un HDD de 3to.

 

En fouillant un peu j'ai trouvé des sujets traitants du RDM, j'avoue être un peu perdu.

 

Dans l'attente d'une âme charitable, je vous souhaite de bonnes fêtes :)

Link to post
Share on other sites
Il y a 16 heures, IDSR a dit :

Bonjour à tous et merci pour les configs.

 

Je suis nouveau dans le monde de la virtualisation, tout fonctionne pour moi sur VMware Workstation mais un petit soucis subsiste.

Je n'arrive pas à avoir des disques virtuels de plus de 2040 Go, c'est embêtant car mon but était de faire un volume en raid 5 (DSM) avec 3x 4to et d'avoir un volume secondaire avec un HDD de 3to.

 

En fouillant un peu j'ai trouvé des sujets traitants du RDM, j'avoue être un peu perdu.

 

Dans l'attente d'une âme charitable, je vous souhaite de bonnes fêtes :)

Salut,

 

J'avoue ne pas avoir testé avec des gros disques sous Workstation. Si la partition est en FAT32 ça explique ton pb, soit tu migres en NTFS, soit effectivement tu bascules sur du RDM :

 

Pour faire du RDM avec VMware Workstation, dans mon tuto je l'indique entre l'étape 8 et 9 (section cachée nommée RDM).

 

Pour rappel, le RDM c'est dédier un disque physique à une VM. Sous ESXi c'est totalement transparent mais avec Workstation il faut s'assurer que le(s) disque(s) sont reconnus par Windows avec l'utilitaire FDISK par exemple. Ensuite tu utilises cette portion de mon tuto pour allouer ce(s) disque(s) à ta VM DSM.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.