nicoueron

N54L + ESXi 6 + DSM 6.2 + Loader 1.03 : OK

Recommended Posts

Posted (edited)

Bonjour,

 

Je tiens à vous faire partager mon retour sur l'installation de DSM 6.2-23739 update 2 sur mon HP N54L avec ESXi 6.0.2 :

 

Je n'ai rencontré qu'une seule difficulté à savoir la recréation d'une nouvelle VM, en effet je n'ai pas réussi à mettre le nouveau loader depuis ma VM existante, j'ai du en recréer une nouvelle et réallouer mes disques dur mappés en RDM. Le loader refusant de se lancer après la sélection d'ESXi lors du boot. Mis à part ceci, tout marche impec. La migration n'a prise que 7 minutes montre en main.

 

Et voici le fichier OVF: 

  

Edited by Polanskiman
Ajout du lien vers fichier OVF.
  • Like 1

Share this post


Link to post
Share on other sites

merci jenvisage justement de migré mon n54l sous 6.2 par contre jai completement oublié comment je gerai alors si tu peut preciser ta procedure en quelques ligne ce serait sympa .

 

 

par contre petit question jai un hdd considerer comme crashed par syno sur le quel je narrive plus rien a ecrire dessus pas bien grave il est preque full mais jarrive à lire et consulter ce qui est stocké .

 

jai peur quune mise à jour m'enleve  l'acces à ces fichiers ?  votre avis sur la question?

 

merci

Share this post


Link to post
Share on other sites

Ben en fait la proc est toujours la même sauf que j'ai pas réussi à faire une mise à jour directement sur la VM 6.1.

 

Deux pré-requis :

  1. il faut convertir le fichier synoboot.img de jun en synoboot.vmdk (en mode ESXi évidemment) avec le logiciel StarWind V2V Converter et le transférer sur le datastore d'ESXi.
  2. Télécharger le fichier pat https://archive.synology.com/download/DSM/release/6.2/23739/DSM_DS3615xs_23739.pat

 

Deux recommandations

  1. Je recommande fortement d'ajouter un port série avec une sortie dans un fichier. Ceci permet de voir les logs du loader au moment du boot via la commande :
tail -f /vmfs/volumes/datastore1/[VM_DSM]/serial.out

 

       2. Partez sur la version DS3615xs, c'est une valeur sûre!

 

 

Procédure

       1. Recréer une machine virtuelle from scratch avec les caractéristiques suivantes

  • Un controleur de disques SATA 
  • Un controleur de disques SCSI de type VMWare Paravirtual 
  • Le vmdk contenant le bootloader doit être rattaché au controleur de disque SATA (0,0) - Mode de disque Dépendant
  • Le(s) vmdsk contenant les données doivent être rattaché au controleur disque SCSI - Mode de disque indépendant / persistant
  • Le controleur réseau doit être de type E1000

       2. une fois la VM démarrée et que le fichier serial.out indique [DiskStation  login :] c'est que tout est prêt.

       3. Se connecter à l'ihm : http://[IP_NAS]:5000 

       4. lancer la procédure de migration en déployant le fichier pat préalablement téléchargé

       5. attendre la fin de la migration (la VM doit rebooter)

  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour nicoueron,

 

j’ai suivi à la lettre ton tuto malheureusement Synology Assistant ne trouve rien. j’ai un esxi 6.0, j’ai tester en UFi également. Une idée ?

 

Ci-joint mon fichier de sortie série.

 

Merci d’avance 

serial (1).out

Share this post


Link to post
Share on other sites

Bonjour,

 

La dernière information de la sortie série est "mount failed"...

Visiblement, l'affectation de tes disques durs ne semble pas correspondre à ce qui est attendu dans le DSM.

Regarde cette partie de la configuration dans ta VM, ça devrait pouvoir se corriger facilement en relisant le tuto.

 

Bons tests

Jacques

Share this post


Link to post
Share on other sites

yes, j'ai eu ce message sur ma VM de test, j'avais mal paramétré mes disques durs

le vmdk du loader (synoboot.vmdk) doit être lié au controleur SATA (0,0) Mode de disque Dépendant et les autres (les datas) doivent être reliés au controleurs scsi Mode de disque indépendant / persistant

 

 

Voici une capture de ma config

Capture.PNG

Share this post


Link to post
Share on other sites

Hello, 

effectivement je les avais inverses 😕 du coup plus de message d’erreur mais toujours pas visible. Mon loader qui serais moisie ? 

 

Merci.

 

Nico 

serial (2).out

Share this post


Link to post
Share on other sites

Tu as typiquement le pb que j'ai eu en utilisant le synoboot.vmdk sur mon ancienne VM : à savoir rien ne se passe :/ En recréant une VM from scratch avec le mm synoboot.vmdk aucun souci. Si tu es toujours dans ce cas là avec une nouvelle VM c'est que la config de ta VM comporte encore une différence. Essaie avec mon fichier OVF pour être sûr.

Share this post


Link to post
Share on other sites

Je viens de tester avec ton fichier et sa fonctionne parfaitement :)

 

Pourtant aucune différence entre ta config et la mienne du coup je pense plus un problème de mon loader ou alors encore un mystère informatique :D

 

Merci à toi ! 

Share this post


Link to post
Share on other sites

.ovf ou recréation de VM echec (aucun load)

 

Je n'ai pas de connecteur SATA.

Faut'il activer une option dans le BIOS ou autre ?

 

Version actuelle N54L 16GB Xpenology 6.1 ESXI 6.0 tous les disques en SCSI

Share this post


Link to post
Share on other sites

comment c'est possible de ne pas avoir de controleur SATA ? c'est de base et il est inclus dans mon OVF.

 

Normalement il n'y a rien a faire dans le bios, la seule chose à faire étant d'ajouter ses disques de données virtuels à la VM en SCSI. Seul le loader doit etre rattaché en SATA (même si j'avoue avoir réussi aussi à le faire marcher en SCSI sans savoir comment^^)

Share this post


Link to post
Share on other sites

J'ai IDE ou SCSI mais pas de possibilité d'avoir SATA.

En IDE cela ne marche pas il ne se passe rien, comme avec votre .ovf

 

Je crée le loader IDE ou SCSI au choix avec Starwind V2

J'ai essayer de charger votre loader sur un disque IDE sans succès

Share this post


Link to post
Share on other sites

Si tu utilises mon OVF, nul besoin de passer par Starwind, le loader est directement fournir avec l'OVF.

 

A mon avis, quand tu charges mon OVF tu dois avoir un autre souci que tu n'as pas vu. Peux-tu poster une capture d'écran de la config de ta VM depuis le client web d'ESXi ?

Share this post


Link to post
Share on other sites

Merci ton dernier post m'a mis sur la voie, j'ai trouvé les problèmes.

 

J'utilisait VSphere Client qui fonctionne jusqu'à la version 8 d'ESXI version 5.5 je suppose (sans connecteur SATA)

Au delà version 6.x il faut utiliser le client web d'ESXi permettant notamment de disposer du connecteur SATA depuis la version 9.

 

Ensuite est venue le second problème du fait que je voulais créer une version test de DSM 6.2.

Pour cela je dois arrêter DSM 6.1 car elles se créent sous la même IP fixe.

Share this post


Link to post
Share on other sites

je suis sous esxi 5.5.0 je souhaite pouvoir utiliser vos fichier preconfig .

 

du coup je vais mettre a jour esxi par contre jai des difficulté a trouver l information crutial quel version maximun supporte le ht n54l sachant que j ai installer 10 Go de Ram .

 

est il envisaeagable que je passe directement a 6.7 ou suis je obligé de passer a 6.02 comme vous ou tout simplemement es la version maximun supporté

 

merci

Share this post


Link to post
Share on other sites

Salut,

 

Perso, j'ai essayé sur 2 HP N54L différents de mettre ESXi 6.5 et je n'ai jamais réussi à lancer DSM. Dès que je met la 6.0.2 aucun problème. 

Quand on voit les différences apportées par la 6.5 ou 6.7 autant rester sur la 6.0.2! Après je suis preneur d'un autre retour d'expérience sur ESXi 6.7 avec DSM 6.2...

 

La quantité de RAM n'importe peu du moment qu'elle soit >= 4Go.

Share this post


Link to post
Share on other sites

jai update mon esxi vers la 6.02 pour plus de sureté .

 

par contre jai creer un Vm depuis la web ui de esxi en utilisant le OVF et vmdk en ayant bien eteint mon autre Vm au prealable.

 

par contre dans la console jai le message de jun donc le loader semble bien ce lancer.  apres je fait quoi ? procedure d installation depuis syno assistant ? avec quel Pat dans ce cas ?

ou bien jai juste a me connecter ?

et mes disque de donner je les reli a quel moment ?

 

merci

Share this post


Link to post
Share on other sites

bon j avance tout doux  il semblerait que je n ai rien a faire de plus normalement pas besoin de pat rien.

 

pr contre impossible d ajouter mes disques.

 

il me dit que les disque sont plus gros que ma banque et que sa risque de la ssatturer mais impossible de forcer pour qu il  les ajoute une idéé? ou une explication de comment ajouter les ancien disque merci

Share this post


Link to post
Share on other sites

Les disques doivent être ajoutés AVANT d'allumer la VM pour que DSM puisse s'installer.

Pour le pat, soit tu fais l'install auto, auquel cas DSM va le télécharger tout seul MAIS si DSM sort une mise à jour, il est possible que ça ne marche plus, c'est pourquoi il vaut mieux préalablement télécharger The pat : https://archive.synology.com/download/DSM/release/6.2/23739/DSM_DS3615xs_23739.pat

 

Pour ton cas où "il" te dit que les disques sont plus gros que la banque, c'est qui il? ESXi ou DSM ? 

Tes disques sont des disques virtuels ou physiques (mappés en RDM) ?

Share this post


Link to post
Share on other sites
Il y a 2 heures, vorach a dit :

par contre dans la console jai le message de jun donc le loader semble bien ce lancer.  

C'est possible mais pas sûr à 100%, c'est pourquoi je conseil d'aller regarder les logs associées via le port série (le fameux serial.out situés dans le dossier de ta VM)

Share this post


Link to post
Share on other sites

D'accord donc vaut mieux que je fasse la procédure avec l'assistant suyno du coup.

 

Pour les disque dur c'est esxi qui me dit sa j'ai 3 disque physique un seul et deux en raid spécial suyno.

 

Je les ajout depuis le msdk présent dans ma banque

Share this post


Link to post
Share on other sites

en règle général pour faire du RAID dans une machine virtuelle DSM le mieux est de dédier des disques physiques à la VM (=RDM) et non un disque virtuel vmdk dont la taille est positionnée arbitrairement à sa création.

Pourquoi ? parce que si un des disques durs physiques qui constitue ton datastore crache alors il devient impossible à DSM de reconstruire son RAID logiciel ton datastore étant corrompu. Alors que si le disque physique est "mappé" directement à la VM si celui crache, tu le changes, le remappe à la VM à la place et hop DSM reconstruit son RAID sans rien voir - comme si c'était un vrai NAS Syno!

 

La seule subtilité dans mon explication est qu'un disque mappé en RDM crée aussi un fichier vmdk, mais ce dernier n'est qu'un pointeur vers le disque dur.

 

Il y a 1 heure, vorach a dit :

Pour les disque dur c'est esxi qui me dit sa j'ai 3 disque physique un seul et deux en raid spécial suyno

Il faut que tu saches clairement comment sont organisés tes disques dans ton HP N54L. Par exemple chez moi, j'ai un disque de 250Go sur lequel j'ai créé mon datastore (pour rappel un datastore permet de stocker les données d'une VM au sein d'un vmdk). Et j'ai aussi 3 disques dur de 2To qui sont dédiés physiquement à ma VM DSM et pour lesquels ESXi ne fait absolument rien a part passe-plat entre DSM et les plateaux.

Share this post


Link to post
Share on other sites

Et bien normalement j'avais configuré comme tu l'explique j'utilise les vmdk passe plat et j'avais numéroté dans le nom pour être sur d'avoir le bon ordre je pense que c'est en les ajoutant que je doit faire une erreur.

 

Existe il un moyen de m'assurer que j'ai bien mi en passe plat ou bien le mieux c'est de refaire à zéro en gardant un seul stimuler enlever le second le formater le remettre en physique mappé puis copié mes donnés et refaire pareil avec le second puis recrée un rdm.

 

Concernant le 3 ème c'est un 1To seul qui justement est celui à problème car conciderer comme casher par xpenology du coup je ne peux plus rien écrire dessus mais j'ai accès à toutes les données qui sont dessus. C'est principalement mes sauvegarde de photo et vidéo j'ai déjà copié les données ailleurs au cas où mais c'est pratique de pouvoir y accéder ici.

 

Merci

Share this post


Link to post
Share on other sites

alors il semble que mon probleme soit lutilisation de l interface web plutot que de lapplication concernant les HDD car il sont bien mappé mais il semblerait que ce soit une histoire de version apres l'update de esxi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now