RainbowShaggy

DSM 6.2, IIS Reverse Proxy and /webman not rewrite

Recommended Posts

Hello,

 

so I'm successfully set up Reverse Proxy on IIS today to access to my DSM through my own domain and without port. And I found an interesting thing. Everything works great except when I'm redirect to https://mydomain.com/webman/index.cgi or https://mydomain.com/webman. I found this, when I playing with Office. When I wanted to create a new document, every time it redirected me to login page without rewrite to address https://ipaddress:5001/webman/index.cgi and I don't know why. Why every other pages works and this don't? Even If I create Portal Application with alias rewrite works.

 

Here's my rewrite rules:

<rewrite>
  <rules useOriginalURLEncoding="false">
    <clear />
    <rule name="HTTP/S to HTTPS Redirect" enabled="true" stopProcessing="true">
      <match url="(.*)" />
      <conditions logicalGrouping="MatchAny">
        <add input="{SERVER_PORT_SECURE}" pattern="^0$" />
      </conditions>
      <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" />
    </rule>
    <rule name="ReverseProxyInboundRule2" enabled="true" stopProcessing="true">
      <match url="(.*)" />
      <action type="Rewrite" url="https://192.168.1.240:5001/{R:1}" appendQueryString="true" logRewrittenUrl="true" />
    </rule>
  </rules>
</rewrite>

 

Thanks for your help and suggestions.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.