jun

DSM 6.2 Loader

Recommended Posts

Yes, that's clear.  However, your sample set of one does not make your assertion (that an iGPU is required) in fact true.

 

Share this post


Link to post
Share on other sites
10 hours ago, CheapSk8 said:

I would love to...but Acer Revo One RL85 is such as THIS

 

It is a perfect little machine to have running at work for offsite backups of my home NAS. It has on board Realtek that shows as PCIe but can't be taken out and there is just no way of replacing it. USB LAN would not work for sure...so I am stuck. I just don't understand how come it shows up on LAN reliably with 1.04b, even let's me start the install. And until it errors out it is swift and works like you would expect...

Not giving up...will try what IG-88 recommends next... Thanks for your reply though. If this was a regular PC I would definitely agree that this would be the best possible fix or at least a good place to start.Cheers mate

 

Sorry missed that part. Nice little box!

 

In addition to what IG-88 suggests, have you tried running ESXI on the machine first and then hosting xpenology as a vm?  1.03b with 3615 is the most stable setup and if it's only for offsite backups you don't need hw transcoding.

 

Good luck!

Share this post


Link to post
Share on other sites
23 hours ago, Black6spdZ said:

 

also, would the loader need to be modified to get these 5GB USB adapters to work?

no never heard of that one before, i might integrate it in a new extra.lzma

but the link you provided also goes to a git and there is a spk package for download that can be installed to get the driver into a already working system

that should be good enough to get it working on a running 918+, so you dont need to wait for a new extra.lzma to use this usb adapter

https://github.com/bb-qq/aqc111/releases/download/1.3.3.0-1/aqc111-apollolake-1.3.3.0-1.spk

 

Share this post


Link to post
Share on other sites
12 minutes ago, IG-88 said:

no never heard of that one before, i might integrate it in a new extra.lzma

but the link you provided also goes to a git and there is a spk package for download that can be installed to get the driver into a already working system

that should be good enough to get it working on a running 918+, so you dont need to wait for a new extra.lzma to use this usb adapter

https://github.com/bb-qq/aqc111/releases/download/1.3.3.0-1/aqc111-apollolake-1.3.3.0-1.spk

 

yep, I got it working.. had to enable the interface afterwards "ifconfig eth2 up"

Share this post


Link to post
Share on other sites
8 minutes ago, Black6spdZ said:

yep, I got it working.. had to enable the interface afterwards "ifconfig eth2 up"

the 918+ image has a max default of two nic's i guess to get it permanent working you might need to change the /etc.defaults/synoinfo.conf

maxlanport="2"

->

maxlanport="4"

 

Edited by IG-88

Share this post


Link to post
Share on other sites
16 hours ago, baratta930 said:

 

Sorry missed that part. Nice little box!

 

In addition to what IG-88 suggests, have you tried running ESXI on the machine first and then hosting xpenology as a vm?  1.03b with 3615 is the most stable setup and if it's only for offsite backups you don't need hw transcoding.

 

Good luck!

It is a nice little box. I also run Domoticz home automation and that what actually made me upgrade. The latest version only supports DSM 6.2 + and I need to run in in order to support some of my automation hw at my work. 1.03b was running flawlessly until now.

 

I will gladly try ESXi. Seems like lot of folks are using it and I am happy to give it a shot. I'll report back. In the worst case I'll go back to 1.03b with 3615 and try to run Domoticz in a docker container... Thanks for all the advice...hope to have good news soon

Share this post


Link to post
Share on other sites
On 9/30/2019 at 4:18 AM, flyride said:

 

Integrated graphics is not required.  Any Haswell or later (AFAIK it's support of the FMA3 instructions) is ok.

 

@CheapSk8, I think your system should run 1.04b and DS918 DSM fine, keep at it.

Right... Apart from trying the ESXi route this is definitely the best shot I got. Will do as you suggest and hopefully report back soon with some progress.. Thanks!!

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, IG-88 said:

the 918+ image has a max default of two nic's i guess to get it permanent working you might need to change the /etc.defaults/synoinfo.conf

maxlanport="2"

->

maxlanport="4"

 

made this change but after a restart my eth2 is still disabled.. so even set at two the third nic "usb" worked before the change

just made a boot task to enable the interface.. this works. Is it because the usb driver for this adapter is loaded after the native interfaces are brought up? I also just checked the ifcfg-eth2 file, ONBOOT=yes. what else might cause this interface not to be enabled?
 

Edited by Black6spdZ

Share this post


Link to post
Share on other sites
3 hours ago, Black6spdZ said:

Is it because the usb driver for this adapter is loaded after the native interfaces are brought up?

 

maybe

you can try to copy the module to the same folder where the extra.lzma places its files

aqc111.ko (the spk is just zip so you can unpack it, the driver files are in package.tgz)

to /lib/modules/update

(usbnet.ko is already present from synology, mii.ko from jun's extra.lzma)

then edit /etc/rc.modules, at the end of EXTRA_MODULES you add the 3 modules

 mii.ko usbnet.ko aqc111.ko"

after a reboot it might work (thats how it would end up when doing it in a new extra.lzma)

you can check the boot log for the driver being loaded

Share this post


Link to post
Share on other sites
Posted (edited)

I bought an Intel e1000e eth and installed on ASRock J3160, disabled the onboard ether, and boot up to 6.1.3, working well.

 

And I thought I could upgrade to 6.2, but after upgrade done, e1000e never brought up, and I could not connect to my nas anymore.

 

Is there any thing I forgot before upgrading to 6.2?

Or is there any way that I could reinstall without losing any data?

Edited by jemyzhang

Share this post


Link to post
Share on other sites

 

On 9/29/2019 at 9:59 PM, IG-88 said:

 

cpu is i4-4005u from what i've seen, thats ok for 918+ and the fact that you see it in network after booting from usb says clearly "it's working"

you could try "DSM_DS918+_23739" (aka 6.2."0"), older one but tested to work with my extra.lzma from last year (if that does not work check usb vid/pid in your grub.conf and make sure your destination disk is empty aka no partitions)

after confirmed to install correct you can try updating to 6.2.2, depending on the hardware you will loose network connection or even storage because all additional drivers from my old extra.lzma will fail to load with 6.2.2

BUT you can take your usb to another system and overwrite your old extra.lzma with the one olegin created, when booting the newer extra.lzma drivers should be used and the system should be up again

atm i'm testing a new nas hardware and that was my first try when looking around and it worked, it found the onboard realtek and two different intel nic's (e1000e and igb, btw. the DS918+ default is max. 2 nic's in synoinfo.conf, jun's patch only extends the max. drive count but does not lift that nic's value to the "normal" 4 known from 3615/3517), also the good old mpt sas card showed up again with olegins extra.lzma

 

....

 

I have a small update.

 

I tried and tried. Every different version of 6.2 out there and (possibly extra.lzma)

Every time is basically the same...

 

It boots up , shows up in assistant, I connect to it, start installation, it finds the drives, goes through creating partitions, uploads DSM, and at about 56%, when it says Installing DSM it interrupts, goes to bla bla, file is corrupted (13). and offers to migrate...of course ending with the same error...

 

Can you please point me to the extra.lzma you mentioned to try, just to make sure I've exhausted all the options?

I tried DSM 6.2 23739/23824/24922 and it all ends up being the same exact error. I have no idea why, as it creates the partitions (so it tells me there should be no sata controller issues)...

 

I have managed to finally install ESXi 6.7 with support for my Realtek NIC (most time wasted registering for a free ESXi with VmWare)... That will be my next (parallel) attempt...

 

Thank you very much for your help and time...

 

Share this post


Link to post
Share on other sites
Posted (edited)

can you try the usb created with 1.04b and the disk on a different hardware?

are you sure you set the vid/pid of the usb the right way (i once  had a typo and only on 3rd look i saw it, in some cases your brain makes you see things you expect to see), so check both read vid/pid in windows again and check that against the grub.cfg

Edited by IG-88

Share this post


Link to post
Share on other sites
7 hours ago, IG-88 said:

can you try the usb created with 1.04b and the disk on a different hardware?

are you sure you set the vid/pid of the usb the right way (i once  hat a typo and only on 3rd look i saw it, in some cases your brain makes you see things you expect to see), so check both read vid/pid in windows again and check that against the grub.cfg

Between every attempt I delete all partitions on the usb, recheck grub.cfg and rewrite the IMG to USB again...checked about 10 times, even copy pasted MAC and VID&PID from the original (working) 1.02 grub.cfg to make sure I'm not blind. Same USB stick installs 1.02b + 6.1.5   without a hitch...

By now I've seen it so many times I know them by heart ;)

 

I appreciate your help, sorry it's such a bummer...

Share this post


Link to post
Share on other sites
Posted (edited)

Also, just successfully installed 6.2.2 (3615sx) with 1.04b on ESXi 6.7U3 (following  Luchuma's tutorial) on the same machine. Without a hitch...

Edited by CheapSk8

Share this post


Link to post
Share on other sites
21 hours ago, CheapSk8 said:

Also, just successfully installed 6.2.2 (3615sx) with 1.04b on ESXi 6.7U3 (following  Luchuma's tutorial) on the same machine. Without a hitch...

I got the error 13 installing ds918/1.04b until I swapped processors

Share this post


Link to post
Share on other sites
On 9/30/2019 at 5:04 PM, IG-88 said:

no never heard of that one before, i might integrate it in a new extra.lzma

but the link you provided also goes to a git and there is a spk package for download that can be installed to get the driver into a already working system

that should be good enough to get it working on a running 918+, so you dont need to wait for a new extra.lzma to use this usb adapter

https://github.com/bb-qq/aqc111/releases/download/1.3.3.0-1/aqc111-apollolake-1.3.3.0-1.spk

 

would there be anything the loader does that would prevent me from getting over 1Gbps link rate? I've confirmed a 5Gb link between this USB adapter and an Aqtion 10Gb NIC on PCs so I know the hardware and cable is good for it. I've put some more info over in software forum.

Share this post


Link to post
Share on other sites
4 hours ago, Black6spdZ said:

I got the error 13 installing ds918/1.04b until I swapped processors

I'm starting to believe it is the CPU or maybe the non-Intel NIC. Well...I can't swap CPU and just tried everything for one last time before going back to 6.1.7.

I used a different USB stick, every single USB port on the machine, turned on and off any bios setting that could have any effect on the install... still, the same error.

I'm giving up on this for the moment, it will either work in the future (new loader)  or it never will with this particular PC.

 

Thanks everyone for your help!

Share this post


Link to post
Share on other sites
8 hours ago, Black6spdZ said:

would there be anything the loader does that would prevent me from getting over 1Gbps link rate? I've confirmed a 5Gb link between this USB adapter and an Aqtion 10Gb NIC on PCs so I know the hardware and cable is good for it. I've put some more info over in software forum.

 

the used driver 1.3.3 is the latest available (used it for the extra.lzma), you can try to have a look if you can manually steer the speed with ethtool

ethtool --show-priv-flags

 

the source code shows that it also can handle 100mbit, so you might need to contact the vendor of your product or try different 1Gb nic's

 

Share this post


Link to post
Share on other sites
5 hours ago, CheapSk8 said:

I'm giving up on this for the moment, it will either work in the future (new loader)  or it never will with this particular PC.

i once had a case were i could not install dsm, but when using a disk installed on another system, it did work, just transferred usb and hdd to the box with install problems

2nd would be 1.03b 3615 with new extra.lzma, but its not finished yet, turns out my new nas hardware runs fine with 918+ but freezes with 1.03b 3615 after starting the boot process (even serial console does not show anything after grub), i need to get some older hardware for testing

Share this post


Link to post
Share on other sites
13 hours ago, IG-88 said:

 

the used driver 1.3.3 is the latest available (used it for the extra.lzma), you can try to have a look if you can manually steer the speed with ethtool

ethtool --show-priv-flags

 

the source code shows that it also can handle 100mbit, so you might need to contact the vendor of your product or try different 1Gb nic's

 

Ethtool tells me 2500 and 5000 are invalid speeds even though I've tried the command in their documentation to force it. What's odd is 5Gb has been tested successfully on real ds918+ with this exact adapter

 

Share this post


Link to post
Share on other sites

does setting it to 100 or 1000 work?

did you look in the log (like "dmesg")?

918+ uses kernel 4.4.59 so its <4.10 as mentioned in the other thread, maybe it's more then just not seeing 2.5/5G

btw its i little complicate as you kind of double posted and we try to write in 2 different threads about he same thing

we should continue in the other thread as its no loader problem, more a specific driver problem

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, IG-88 said:

i once had a case were i could not install dsm, but when using a disk installed on another system, it did work, just transferred usb and hdd to the box with install problems

2nd would be 1.03b 3615 with new extra.lzma, but its not finished yet, turns out my new nas hardware runs fine with 918+ but freezes with 1.03b 3615 after starting the boot process (even serial console does not show anything after grub), i need to get some older hardware for testing

Alright, GOOD NEWS! Last ditch attempt ... I followed your suggestion. Took 3 different computers before I was able to boot and find it on LAN.

Installed 23739 without a hitch, updated to 24922, all working just fine. Moved over to the original Acer (updated MAC, VID & PID) and right after reboot, DSM is in 'migratable' status (essentially like after the failed install attempts) and subsequent attempts end up in error (13) - corrupted file.

 

Went back to original PC, installed only 23739, did not update any further and moved over to Acer. So far, so good, WORKING.

I still have all the configuring left to do and installing Domoticz, so if there is any problem I'll report back, but at the moment this is the furthest I ever got with 6.2. 

 

Thank you very very much kind sir for sticking with me and not giving up on this!

I will be more than happy to check out the 1.03b 3615 when it's ready!

Edited by CheapSk8

Share this post


Link to post
Share on other sites
17 hours ago, CheapSk8 said:

Moved over to the original Acer (updated MAC, VID & PID) and right after reboot, DSM is in 'migratable' status

 

you should move the usb drive together with the hdd drive, on upgrading the system on disk is upgraded but also your usb drive (new kernel and rd)

so if you, after upgrading the disk, reset the usb to jun's original (older) dsm state both will not match anymore, the booted kernel (older) recognizes the mismatch and will offer to migrate

17 hours ago, CheapSk8 said:

I still have all the configuring left to do and installing Domoticz, so if there is any problem I'll report back, but at the moment this is the furthest I ever got with 6.2. 

as long as you dont allow direct access to your dsm over internet and dont have malware in you local network the missing security patches of you "older" version you use now might be ok, but keep in mind you dsm box is vulnerable in this state as it has unpatched security issues

Share this post


Link to post
Share on other sites
3 hours ago, syno406 said:

is there a step by step tutorial on how to update to DSM 6.2 from DSM 6.1-15047?

Hello, with another bootloader I had active 2 x LAN  3615xs.
Now with this img only 1 x LAN? What is wrong?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.