jun

DSM 6.2 Loader

Recommended Posts

1 hour ago, flyride said:

This is what I did in a similar situation:

set sata_args='SataPortMap=1 DiskIdxMap=0C00'

 

Also see this: https://xpenology.com/forum/topic/7613-disablehide-50mb-vmware-virtual-disk/

 

Thanks for that! it pointed me in the right direction atleast - i got around it by setting the vm disk as sata 0:20.

 

Does DiskIdxMap also work with 1.04b? When reading the post it indicates that it's already written in the grub file as hex 0C. Mine however didn't contain anything related to DiskIdxMap.

Atleast now works, and VMXNet3 flawlesssly too 🙂 (Reason i moved to DS918 loader from 3617)

 

Thanks again

 

 

 

Share this post


Link to post
Share on other sites
On 10/30/2018 at 9:31 PM, ideasman69 said:

hmm.. heres something for you guys...

 

i have 3 asrock j3455 boards and have tested 1.04b on two of them:

 

J3455-ITX: can't get /dev/dri to appear

J3455B-ITX: works perfectly

Hi I have J3455-ITX and for make some tests I've used a new usb drive and a small hdd unplugging my actual hard drives that are on DSM 6.1 with older bootloader.

How can i check if I have /dev/dri ? SSH, TELNET?

Share this post


Link to post
Share on other sites

Hi

with ssh cd /dev/dri...if there is no "dri" folfer => no transcoding, that's my case with J4105-ITX and real3x mod.

So back to 6.2.1

Share this post


Link to post
Share on other sites

Hi there,

i am current at DSM 6.2.1-23824 Update 6 with Junes Loader 1.04b / DS918+ @ ASRock J-5005 ITX

did not update for some time... in last updates it seems there was a problem with intern network card.

So anybody knows if i can update to DSM 6.2.1-24922 Update 3 without getting into trouble with my intern network card? do i have to pay attention to something special when upgrading?

 

thanks in advance

regards thorlaf

 

 

Share this post


Link to post
Share on other sites

Check which Network Driver is loaded with DSM. If it's not an e1000e you will have an issue. Look lower in the thread below on commands I used to check network drivers.

https://r.tapatalk.com/shareLink/topic?url=https://xpenology.com/forum/topic/19009-migration-hp-gen8-with-nc365t-from-23739-to-24922/&share_tid=19009&share_fid=107315&share_type=t

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, bglf83 said:

Check which Network Driver is loaded with DSM. If it's not an e1000e you will have an issue. Look lower in the thread below on commands I used to check network drivers.

https://r.tapatalk.com/shareLink/topic?url=https://xpenology.com/forum/topic/19009-migration-hp-gen8-with-nc365t-from-23739-to-24922/&share_tid=19009&share_fid=107315&share_type=t

 

thanks!

it says:

 

driver: r8168
version: 8.045.08-NAPI
firmware-version: 
bus-info: 0000:03:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

 

so i can not update?

any suggestions for an external network card to get rid of this Problem?

 

thanks in advance

Regards thorlaf

Edited by Thorlaf

Share this post


Link to post
Share on other sites
Le 28/08/2019 à 16:00, Thorlaf a dit :

i am current at DSM 6.2.1-23824 Update 6 with Junes Loader 1.04b / DS918+ @ ASRock J-5005 ITX

did not update for some time... in last updates it seems there was a problem with intern network card.

 

This is why there were on this forum a thread about each update where user report a successful update or not and the hardware they use, and if you go on this thread about 6.2.2-24922 update 2 you'll find 2 guys with a j-5005-ITX and a perfectly working update.

 

Last update 6.2.2-24922 update 3 change nothing for LAN card so if update 2 work, update 3 work too.

Share this post


Link to post
Share on other sites
2 minutes ago, real3x said:

 

This is why there were on this forum a thread about each update where user report a successful update or not and the hardware they use, and if you go on this thread about 6.2.2-24922 update 2 you'll find 2 guys with a j-5005-ITX and a perfectly working update.

 

Last update 6.2.2-24922 update 3 change nothing for LAN card so if update 2 work, update 3 work too.

 

thanks!

what is this real3x mod and how to use this?

 

regards thorlaf

Share this post


Link to post
Share on other sites

 

il y a 4 minutes, Thorlaf a dit :

 

thanks!

what is this real3x mod and how to use this?

 

See in his (realex) signature

Share this post


Link to post
Share on other sites

This extra has nothing to do with the lan driver, it just remove the i915 jun's driver to avoid KP on last update, your motherboard probably need it.

 

 

Share this post


Link to post
Share on other sites

thanks guys,

so i will try to update this weekend. hopefully it works without issues :)

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I'm trying to wrap my head around this loader.

 

I'm using the following setup:

 

- DSM version prior update: DSM 6.1.7-15284 UPDATE2

- Loader version and model: JUN'S LOADER v1.03b - DS3615xs

- Using custom extra.lzma: NO

- Installation type: BAREMETAL - HP Microserver N54L 

- Additional comments: I have an extra nic installed: Intel Pro 1000 PT PCI Express Gigabit NIC

 

Now according to the start post, it says the system will panic when running DSM 6.2.1+ is not having a e1000e NIC. 

I've also read that this ONLY APPLIES to an ESXi setup. 

So I can savely assume that the when upgrading the newer 6.2 DSM I will not run into any problems with the intel pro nic?

 

And is this still valid:

Builtin card will work with 1.03b loader and DSM 6.2.

It WILL NOT work with DSM 6.2.1 and 6.2.2

 

Is it also possible to do a cross-upgrade from ds3615xs to ds918+? Or is a clean install adviced here. Thank you in advance.

 

 

Edited by martva
- added question about internal nic -

Share this post


Link to post
Share on other sites
22 hours ago, real3x said:

you'll find 2 guys with a j-5005-ITX and a perfectly working update.

Does hw transcoding work?

Share this post


Link to post
Share on other sites
1 hour ago, martva said:

I'm trying to wrap my head around this loader.

 

I'm using the following setup:

- DSM version prior update: DSM 6.1.7-15284 UPDATE2

- Loader version and model: JUN'S LOADER v1.03b - DS3615xs

- Using custom extra.lzma: NO

- Installation type: BAREMETAL - HP Microserver N54L 

- Additional comments: I have an extra nic installed: Intel Pro 1000 PT PCI Express Gigabit NIC

 

Now according to the start post, it says the system will panic when running DSM 6.2.1+ is not having a e1000e NIC.  I've also read that this ONLY APPLIES to an ESXi setup.  So I can safely assume that the when upgrading the newer 6.2 DSM I will not run into any problems with the intel pro nic?

 

And is this still valid:

Builtin card will work with 1.03b loader and DSM 6.2.

It WILL NOT work with DSM 6.2.1 and 6.2.2

 

The 1.03b loader seems to panic whenever an e1000e compatible card is not in the system.  It doesn't matter whether it's virtual or physical.  Therefore many folks have added Intel PCI NICs and disable onboard or other NICs to HP baremetal systems to get it to work.  There are many, many posts about this.  I don't think your PT card uses the e1000e driver, but that is pretty easy to verify. Check the DS3615 6.2 driver list to be sure (see my signature for links to the driver spreadsheets).

 

I'm not sure if the 1000PT card works fine on the 1.04b loader.  1.04b does seem more functional with embedded drivers - however, many that are in the DS3615 PAT file are not in the DS918 PAT file. Again, check the DS918 6.2 driver list to be sure.

 

1 hour ago, martva said:

Is it also possible to do a cross-upgrade from ds3615xs to ds918+? Or is a clean install adviced here. Thank you in advance.

 

Yes, you can switch DSM platforms, you are just installing a new loader which results in a system migration.  No different than moving disks from physical Diskstation to Diskstation.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/30/2019 at 11:28 PM, flyride said:

 

The 1.03b loader seems to panic whenever an e1000e compatible card is not in the system.  It doesn't matter whether it's virtual or physical.  Therefore many folks have added Intel PCI NICs and disable onboard or other NICs to HP baremetal systems to get it to work.  There are many, many posts about this.  I don't think your PT card uses the e1000e driver, but that is pretty easy to verify. Check the DS3615 6.2 driver list to be sure (see my signature for links to the driver spreadsheets).

 

I'm not sure if the 1000PT card works fine on the 1.04b loader.  1.04b does seem more functional with embedded drivers - however, many that are in the DS3615 PAT file are not in the DS918 PAT file. Again, check the DS918 6.2 driver list to be sure.

 

 

Yes, you can switch DSM platforms, you are just installing a new loader which results in a system migration.  No different than moving disks from physical Diskstation to Diskstation.

 

Thank you very much!

This is what I see in dmesg:

 

Where eth0 is the PRO/1000 card. 

And eth1 is my onboard.

[874639.684089] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[874639.925890] tg3 0000:03:00.0 eth1: Link is up at 1000 Mbps, full duplex
[874639.925890] tg3 0000:03:00.0 eth1: Flow control is off for TX and off for RX

So in theory I should be able to upgrade, with the exception of loosing the onboard card.

Edited by Polanskiman
Added code tag.

Share this post


Link to post
Share on other sites

I have 1.03b 3617xs running 6.2.2 on ESXi 6.7u1. Only seem to be able to boot VMs with this setup using SATA disks. I used to be able to boot SCSI virtual disks before 6.2. Is there anyway to get virtual SCSI disks/SCSI controller on VM working again instead of SATA? The performance seemed way better with SCSI emulation.

Share this post


Link to post
Share on other sites
6 hours ago, ilovepancakes said:

I have 1.03b 3617xs running 6.2.2 on ESXi 6.7u1. Only seem to be able to boot VMs with this setup using SATA disks. I used to be able to boot SCSI virtual disks before 6.2. Is there anyway to get virtual SCSI disks/SCSI controller on VM working again instead of SATA? The performance seemed way better with SCSI emulation.

 

I think we covered this in your thread here, I don't know what might have changed though.

Share this post


Link to post
Share on other sites
5 hours ago, flyride said:

 

I think we covered this in your thread here, I don't know what might have changed though.

 

Nothing changed other than going to 6.2.2 from 6.2.1 but it never worked as described on that thread either. Is there something particular you do in terms on moving the disks to SCSI after. I boot up DSM with the SATA setup, everything works. I shutdown the VM, add a SCSI controller, change the volume1 disk only (not synoboot) to the new SCSI controller. Boot back up, and the following screen comes up.

 

If I change the disk back to SATA controller, it seems to boot up all okay again.

Screen Shot 2019-09-12 at 8.06.09 AM.png

Share this post


Link to post
Share on other sites

No difference except as on that thread, DS3615xs instead of DS3617xs.  FWIW, I don't think the speed difference has anything to do with the connection type.  It's all virtual anyway.  Subjectively, 6.2 is slower than 6.1 even on a real Synology.

Edited by flyride

Share this post


Link to post
Share on other sites
2 hours ago, flyride said:

No difference except as on that thread, DS3615xs instead of DS3617xs.  FWIW, I don't think the speed difference has anything to do with the connection type.  It's all virtual anyway.  Subjectively, 6.2 is slower than 6.1 even on a real Synology.

 

On that one I was 3617 too. I have a 3615 VM too but didn't try the change on that one yet. Although I am guessing it still won't work since before 6.2 SCSI did work on 3617. But, I guess its possible like you say that 3615 retained something that 3617 did not. Will try it later.

 

As for speed, okay interesting, I just assumed it was disk related but definitely did not slower load times of DSM and logging in, etc... when I went to 6.2.1/SATA virtual disks.

Share this post


Link to post
Share on other sites

Dear all,

 

I have been using xpenology for quite some years now and it is great! I used to have a Asus AMD setup and was able to upgrade to 6.1.7 on a DS3615.

As I wanted to upgrade further, I bought a Gigabyte GA-Z87-HD3 motherboard with realtek NIC (and put my 6 SATA harddrives in with data). After some fiddling around, I was able to use Jun's loader 1.04b and install DSM 6.2.2-24922 update 3 on a 918+. The system starts up and I am able to login in the web interface. HDD configuration loads well and I am able to access the files on my drives.  However, the system says it cannot connect to the internet, and I am missing various apps like file explorer (they show up initially but dissappear after 1-2 minutes). Internet is working on all other machines by the way. In the logfile, the system is turning off various services like SMB after they have been succesfully started up. As in the configuration / network menu  it doesn't show the LAN interface, I think there is going something wrong there.

 

Has anybody experienced such strange behaviour? And... could anybody propose a solution to me? It would be highly appreciated!

 

Thanks in advance and have a great day, Machiel

 

System configuration:

- DSM version prior update: DSM 6.1.7-15284 UPDATE2

- Loader version and model: JUN'S LOADER v1.04b - DS918+

- Using custom extra.lzma: NO

- Installation type: BAREMETAL - Gigabyte GA-Z87-HD3, realtek NIC  

- Additional comments: system boots and can be accessed,  but misses essential apps 

Edited by mrtiddy
Added system configuration

Share this post


Link to post
Share on other sites
2 hours ago, mrtiddy said:

Dear all,

 

I have been using xpenology for quite some years now and it is great! I used to have a Asus AMD setup and was able to upgrade to 6.1.7 on a DS3615.

As I wanted to upgrade further, I bought a Gigabyte GA-Z87-HD3 motherboard with realtek NIC (and put my 6 SATA harddrives in with data). After some fiddling around, I was able to use Jun's loader 1.04b and install DSM 6.2.2-24922 update 3 on a 918+. The system starts up and I am able to login in the web interface. HDD configuration loads well and I am able to access the files on my drives.  However, the system says it cannot connect to the internet, and I am missing various apps like file explorer (they show up initially but dissappear after 1-2 minutes). Internet is working on all other machines by the way. In the logfile, the system is turning off various services like SMB after they have been succesfully started up. As in the configuration / network menu  it doesn't show the LAN interface, I think there is going something wrong there.

 

Has anybody experienced such strange behaviour? And... could anybody propose a solution to me? It would be highly appreciated!

 

Thanks in advance and have a great day, Machiel

 

System configuration:

- DSM version prior update: DSM 6.1.7-15284 UPDATE2

- Loader version and model: JUN'S LOADER v1.04b - DS918+

- Using custom extra.lzma: NO

- Installation type: BAREMETAL - Gigabyte GA-Z87-HD3, realtek NIC  

- Additional comments: system boots and can be accessed,  but misses essential apps 

I was able to fix this by deleting .xpenoboot ussing ssh. Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Is it possible to run 1.04b 918+ with sandy bridge cpu? It does have quicksync, would be cool to be able to allow hw transcoding.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.