jun

DSM 6.2 Loader

Recommended Posts

The tutorial reference link says I should be using e1000e and not e1000! Is it safe to shut down the VM and change network adapters or do I need to do something else?

 

Assuming this works, is it then OK to install 6.2.1 from the DSM 6.1.7 GUI?

 

(I will switch from EFI to BIOS too)

Share this post


Link to post
Share on other sites
On 1/27/2019 at 4:44 AM, rony said:

Hello, what are the DS3617 users doing about updates?

Should we wait for a new loader until we can update to 6.2.1?

6.2 has very serious security flaws that have led me to deny my NAS access to the Internet.

 

If you have 4th Gen CPU or newer then you can upgrade using 1.04 loader.

 

The loader is customised to set 16 drives visible on the system on every boot. So it’s all good if you have up to 16 drives. 

 

See compatible hardware here

 

Edited by chipped

Share this post


Link to post
Share on other sites

Im sorry But IT Dose Not Word for me

 

My System is a ASROCK J4205-ITX with 4GB ddr4 RAM and 2x 1TB hdd drives

 

Im Not able to install dsm 6.2.1 on this System i geht an error 21

Share this post


Link to post
Share on other sites
6 hours ago, chipped said:

 

If you have 4th Gen CPU or newer then you can upgrade using 1.04 loader.

 

The loader is customised to set 16 drives visible on the system on every boot. So it’s all good if you have up to 16 drives. 

 

See compatible hardware here

 

 

Good morning,
thank you for your answer.

 

So I installed a 3617xs.
There is no 1.04 loader for that - or do I see it wrong?

I have a Skylake CPU (5th generation?)


A LSI RAID controller in IT mode.
and a Mellanox Connect-X 3 10Gbit NIC.

I only use the onboard SATA controller for the SSD cache.

I use 8 HDDs, 2 SSD as cache and one SSD as system drive - no virtualization.

Share this post


Link to post
Share on other sites
3 минуты назад, rony сказал:

There is no 1.04 loader for that - or do I see it wrong?

I have a Skylake CPU (5th generation?)

On 1.04 you must install 918 DSM only! Read this.

Share this post


Link to post
Share on other sites
51 minutes ago, Olegin said:

On 1.04 you must install 918 DSM only! Read this.

So I have to change from 3617xs to 918+ to upgrade to version 6.2.1?

Share this post


Link to post
Share on other sites
1 минуту назад, rony сказал:

So I have to change from 3617xs to 918+ to upgrade to version 6.2.1?

Yes.

Share this post


Link to post
Share on other sites
On 11/9/2018 at 10:26 AM, ideasman69 said:

J3455B-ITX: works

J3455-M: works

J3455-ITX: i915 driver fails which explains why /dev/dri is missing:

The same issue on Asrock J4205ITX, MCDP2800 chip is on both MB. 

I think that this bug is the source of this issue, but i don't know ho to fix it (

 

Edited by TeleDDim

Share this post


Link to post
Share on other sites

That's bad.  So I am stopped at 3615xs.  Hope it can still be supported.

12 minutes ago, Olegin said:

No, it's 3rd.

 

Share this post


Link to post
Share on other sites
3 hours ago, Olegin said:

Yes.

 

All right - is there a guide that you can recommend that I use for the change?

Share this post


Link to post
Share on other sites
3 минуты назад, rony сказал:

All right - is there a guide that you can recommend that I use for the change?

Use and enjoy 😉

Share this post


Link to post
Share on other sites
4 часа назад, rony сказал:

 LSI RAID controller in IT mode.

and a Mellanox Connect-X 3 10Gbit NIC. 

Ups... stop!

It seems that this hw will not work on 1.04.

 

Скрытый текст

alx.ko
atl1.ko
atl1c.ko
atl1e.ko
ax88179_178a.ko
bnx2.ko
BusLogic.ko
button.ko
cnic.ko
e1000.ko
ixgbe.ko
jme.ko
libphy.ko
mdio.ko
megaraid.ko
megaraid_mbox.ko
megaraid_mm.ko
megaraid_sas.ko
mii.ko
mptbase.ko
mptctl.ko
mptsas.ko
mptscsih.ko
mptspi.ko
netxen_nic.ko
ohci-hcd.ko
pcnet32.ko
qla3xxx.ko
qlcnic.ko
qlge.ko
r8168.ko
r8169.ko
scsi_transport_spi.ko
sfc.ko
skge.ko
sky2.ko
tg3.ko
uio.ko
usbnet.ko
vmw_pvscsi.ko
vmxnet3.ko

 

Edited by Olegin

Share this post


Link to post
Share on other sites
23 minutes ago, Olegin said:

Ups... stop!

It seems that this hw will not work on 1.04.

 

  List of bild in drivers on 1.04 (Hide contents)

alx.ko
atl1.ko
atl1c.ko
atl1e.ko
ax88179_178a.ko
bnx2.ko
BusLogic.ko
button.ko
cnic.ko
e1000.ko
ixgbe.ko
jme.ko
libphy.ko
mdio.ko
megaraid.ko
megaraid_mbox.ko
megaraid_mm.ko
megaraid_sas.ko
mii.ko
mptbase.ko
mptctl.ko
mptsas.ko
mptscsih.ko
mptspi.ko
netxen_nic.ko
ohci-hcd.ko
pcnet32.ko
qla3xxx.ko
qlcnic.ko
qlge.ko
r8168.ko
r8169.ko
scsi_transport_spi.ko
sfc.ko
skge.ko
sky2.ko

tg3.ko
uio.ko
usbnet.ko
vmw_pvscsi.ko
vmxnet3.ko

 

 

Dude, you're about to mess with my head. :D

 

So the LSI controller is currently working.
And the Mellanxo NIC is in Synology's supported hardware list.

Currently I'm running Loader 1.03 and DSM 6.2.

 

But it is possible that the hardware would not work anymore?

 

edit...

Wait a minute ..

in your list ist megaraid - and "Megaraid" in a productname for the LSI raidcontroller

Edited by rony

Share this post


Link to post
Share on other sites
21 минуту назад, rony сказал:

So the LSI controller is currently working.
And the Mellanxo NIC is in Synology's supported hardware list. 

Better safe than sorry. If you did not add any drives in extra.lzma by yourself or not use modified by IG-88 1.04 will work.

Share this post


Link to post
Share on other sites
30 minutes ago, Olegin said:

Better safe than sorry. If you did not add any drives in extra.lzma by yourself or not use modified by IG-88 1.04 will work.

mmmh,

i think i'll disconnect the HDD for my updated installation, and reinstall it with the Loader 1.04 - then i'll check with a dummy HDD if everything works - if so, i'll try to downgrade from 3617xs to 918+ somehow

Share this post


Link to post
Share on other sites
9 минут назад, rony сказал:

mmmh,

i think i'll disconnect the HDD for my updated installation, and reinstall it with the Loader 1.04 - then i'll check with a dummy HDD if everything works - if so, i'll try to downgrade from 3617xs to 918+ somehow

It's good idea. I'm always test new loaders and DSM versions on clean old HDD and disconnecting work HDDs and SSD.

Share this post


Link to post
Share on other sites
6 hours ago, rony said:

 

Good morning,
thank you for your answer.

 

So I installed a 3617xs.
There is no 1.04 loader for that - or do I see it wrong?

I have a Skylake CPU (5th generation?)


A LSI RAID controller in IT mode.
and a Mellanox Connect-X 3 10Gbit NIC.

I only use the onboard SATA controller for the SSD cache.

I use 8 HDDs, 2 SSD as cache and one SSD as system drive - no virtualization.

 

DS918 probably will not properly support your add-in cards.

 

You should also be able to use 1.03b and DS3615xs

You must also use the Intel NIC for it to boot.  But ask yourself why you want to upgrade, and if you still must, test compatibility thoroughly before you commit your data.

Share this post


Link to post
Share on other sites
15 hours ago, unmesh said:

The tutorial reference link says I should be using e1000e and not e1000! Is it safe to shut down the VM and change network adapters or do I need to do something else?

 

Assuming this works, is it then OK to install 6.2.1 from the DSM 6.1.7 GUI?

 

(I will switch from EFI to BIOS too)

 

Yes, you can change vNIC when you want, same with Legacy Boot vs. EFI.

Share this post


Link to post
Share on other sites
4 minutes ago, flyride said:

 

DS918 probably will not properly support your add-in cards.

 

You should also be able to use 1.03b and DS3615xs

You must also use the Intel NIC for it to boot.  But ask yourself why you want to upgrade, and if you still must, test compatibility thoroughly before you commit your data.

 

Unfortunately my motherboard has only one Realtek network card, which doesn't work anymore since the upgrade from 6.1 to 6.2 - but for me it's not a pain, because I use the 10Gbit network card anyway.

 

I want to update because I am afraid that my NAS can be attacked from the outside by the open security holes in 6.2.
And I just don't like completely encrypted data or the like ;)

Share this post


Link to post
Share on other sites

The only way you will be able to run 6.2.1 then will be to run DS918 and compiled drivers to support your cards (which may not exist at this point).

 

What's wrong with the security fixes in 6.1.7 U3?

Share this post


Link to post
Share on other sites
6 minutes ago, flyride said:

The only way you will be able to run 6.2.1 then will be to run DS918 and compiled drivers to support your cards (which may not exist at this point).

 

What's wrong with the security fixes in 6.1.7 U3?

Because, as I wrote above, I am on version 6.2 (23739).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.