jun

DSM 6.2 Loader

Recommended Posts

15 minutes ago, flyride said:

 

Are you using DS3615 PAT file?

Not in last attempts. Installed new network card, under 6.1.7, all okay. Then 1.03b loader and DS3617 PAT. 

Tried 3615 earlier, but without Intel network cards. Also no luck.

Edited by Gronaldo

Share this post


Link to post
Share on other sites
2 minutes ago, mmkt said:

please have a look at:

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

only 1.03b with 3615 works with 6.2.1.

3617 is not working due to usb kernel crash in 6.2.1. Intel nic or not, dosn't matter.

 Thanks, I'll give that a try! Did come accross overview, but did not pick up this detail :(

Share this post


Link to post
Share on other sites

Is the new loader / DSM supporting HP Ethernet 1Gb 2-port 332i Adapter on HP Gen8 ?

Share this post


Link to post
Share on other sites
19 hours ago, mmkt said:

just do it, the same hardware is working fine for me ...😀

Pfff...it is running now. After some tests, I updated my 6.1.7 version to manual 6.2.1 PAT, using the Intel server network card.

It took machine more time than usual to become available again. I almost gave up and pull the plug...

In the end machine rebooted a second time, while Assistant show 'Starting services'. After finally completing all, it now runs with upgrade 4, much to my surprise.

But anyway, we're in business again! Thanks!

 

Share this post


Link to post
Share on other sites
20 hours ago, ygor said:

Is the new loader / DSM supporting HP Ethernet 1Gb 2-port 332i Adapter on HP Gen8 ?

Just tried this, see my posts above. Answer is No. This is Broadcom based, while you need Intel based. 

Share this post


Link to post
Share on other sites

I have xpenology 6.1 running just fine, with the new bootloader, I can not create a bootable USB stick, not with rufus, Etcher or dd command in Linux. anybody else having that struggle or a solution??

 

Thanks for any help ;-)

 

Dirk

Edited by dirkme

Share this post


Link to post
Share on other sites

Hello,

 

can anybody with J3455 Apollo Lake motherboard and working transcoding on DSM 6.2 add "drm.debug=14" as a grub kernel boot option and post dmesg output here?

 

And possibly once booted can you share your modinfo for i915.ko module?

 

Thanks!

Share this post


Link to post
Share on other sites

So to confirm, to run 6.2.1 with 1.04 loader on ESXI 6.7, I just need to have an Intel NIC, any Intel NIC added to the VM as passthrough? I don't actually have to use the Intel NIC to pass traffic it just has to be present?

Share this post


Link to post
Share on other sites
21 hours ago, dirkme said:

I have xpenology 6.1 running just fine, with the new bootloader, I can not create a bootable USB stick, not with rufus, Etcher or dd command in Linux. anybody else having that struggle or a solution??

 

Thanks for any help ;-)

 

Dirk

Try Win32 Diskimage

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, ilovepancakes said:

So to confirm, to run 6.2.1 with 1.04 loader on ESXI 6.7, I just need to have an Intel NIC, any Intel NIC added to the VM as passthrough? I don't actually have to use the Intel NIC to pass traffic it just has to be present?

 

These comments are specific to install of 6.2.1 on ESXi, to avoid confusion with any baremetal users that happen across this post:

  • Using 1.03b loader (DS3615) you must either configure a virtual e1000e NIC or passthrough a physical e1000e NIC.  If you use a vNIC the physical NIC in the system can be anything supported by ESXi.
  • Using 1.04b loader (DS918), any NIC natively supported by DSM should work, which includes many non-Intel NICs.

Share this post


Link to post
Share on other sites
1 hour ago, painkiller895 said:

Try Win32 Diskimage

Downloaded , will try soon ;-) thanks

Share this post


Link to post
Share on other sites
On 1/24/2019 at 6:21 AM, dirkme said:

I have xpenology 6.1 running just fine, with the new bootloader, I can not create a bootable USB stick, not with rufus, Etcher or dd command in Linux. anybody else having that struggle or a solution??

 

Thanks for any help ;-)

 

Dirk

 

Sometimes I had problems too.

 

Run command prompt as Admin > diskpart > list disk > select disk 2 (number is your USB, whatever it is in the list) > clean > exit

 

This will clean the disk quickly, it basically gives you a raw disk like they come out of the box.

 

For some reason Rufus doesn’t like my usb unless I do this first.

  • Thanks 1

Share this post


Link to post
Share on other sites
6 hours ago, flyride said:

 

These comments are specific to install of 6.2.1 on ESXi, to avoid confusion with any baremetal users that happen across this post:

  • Using 1.03b loader (DS3615) you must either configure a virtual e1000e NIC or passthrough a physical e1000e NIC.  If you use a vNIC the physical NIC in the system can be anything supported by ESXi.
  • Using 1.04b loader (DS918), any NIC natively supported by DSM should work, which includes many non-Intel NICs.

 

Hmm, I must have another issue then because upon trying 1.04b, the bootloader loads and I can install 6.2.1 PAT file but then after install it reboots and I can no longer access DSM, even though bootloader seems to fully load correctly still.

Share this post


Link to post
Share on other sites

I got it sorted, shame on me but the bootloader worked, just not on my hardware where I run DSM6.1. Tried to boot from my laptop just to see and it booted up just fine.

 

Thank you all for your help, this is a great community!!

 

Dirk

Share this post


Link to post
Share on other sites
On 1/22/2019 at 6:30 AM, Olegin said:

Can somebody test extra.lzma from my previous post on ASRock-4205-itx or 3455-itx? Seems that hw transcoding will be work.

 

Does it make any sence to test it on 3455-itx after test was not successfull on 4205-itx?

Share this post


Link to post
Share on other sites
2 минуты назад, deklan сказал:

Does it make any sence to test it on 3455-itx after test was not successfull on 4205-itx?

It seems that not, yet. 😡 But you can try and report.

Share this post


Link to post
Share on other sites
В 24.01.2019 в 14:56, merlincs сказал:

can anybody with J3455 Apollo Lake motherboard and working transcoding on DSM 6.2 add "drm.debug=14"

Specialy for you from @Kizilkum his log.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you Olegin and Kizilkum!

 

This is the first line missing in J3455-ITX I think.

[drm] Disabling framebuffer compression (FBC) to prevent screen flicker with VT-d enabled

 

as per https://wiki.archlinux.org/index.php/intel_graphics#Framebuffer_compression_(enable_fbc)

 

I would try "i915.enable_fbc=1" or "i915.enable_fbc=0" kernel parameter?

 

Cannot test too much now as I got only one productive machine.  But I will continue research.

 

Have a great weekend.

 

Share this post


Link to post
Share on other sites
15 hours ago, merlincs said:

I would try "i915.enable_fbc=1" or "i915.enable_fbc=0" kernel parameter?

 

try to enable VT-d in bios аnd you wiil see this line )

Edited by TeleDDim
  • Thanks 1

Share this post


Link to post
Share on other sites

Hello, what are the DS3617 users doing about updates?

Should we wait for a new loader until we can update to 6.2.1?

6.2 has very serious security flaws that have led me to deny my NAS access to the Internet.

Share this post


Link to post
Share on other sites

I have a DS3615 6.1.7 running with the V1.02b loader on ESXi 6.7 with an E1000 VNIC configured and EFI boot and tried to first upgrade only the loader to V1.03b. I can select the ESXi entry in Grub, see the "screen will stop updating shortly" message but Synology Assistant does not see a server on the LAN.

 

Should it work or does V1.03b have to be paired with DSM 6.2.x?

 

Thanks.

Edited by unmesh

Share this post


Link to post
Share on other sites

1) try non-uefi

2) use the older accepted 1.03b firmware (6.1.x)

3) make a serial output and examine the output text to see if there is anything wrong.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.