Jump to content
XPEnology Community

N54l Plex won't upgrade as wrong non supported hardware?


mccltd
 Share

Recommended Posts

Hi,

Ive been running Plex on my HP N54l running Synology DSM 5.2-5644. for years now but the recent Plex upgrade wont load :1.13.4.

Its currently running 1.13.2 ok.

Says the package is not supported on this platform of disk station.

 

Has something changed do you know, Ive tried the other packages incase its downloading the wrong one but still no go.

 

 

Link to comment
Share on other sites

  • 2 weeks later...
1 hour ago, mccltd said:

Hmm, looks like im going to have to backup all my data and try and upgrade.

Dont fancy loosing all my data

The N54L will run 6.1 using jun's 1.02b loader quite happily, just remember to disable C1E support in the bios.

Link to comment
Share on other sites

took the chance, backed up config and all my files and followed the tutorial exactly as written by Polanskiman at https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/ which went like a dream with no problems on my N54L. Did the updates to 6.1.7 Update 2 with no problems,  then uninstalled Plex and reinstalled 64bit version and everything now working okay, all files intact and lost nothing. 

 

  • Thanks 1
Link to comment
Share on other sites

  • 3 years later...

Hey guys!

I'm still running my N54L on DSM 5.0-4493.

The last weeks the one happend I was always feared before :-) The plex client is not able to use my plex server anymore. (wife is angry: worst case happend)

 

So I also want to follow the tutorial for the upgrade written by Polanskiman to 6.1.7.

 

My problem is, he starts from DSM 5.2 and I cannot find how to upgrade from my 5.0-4993 version to DSM 5.2 before? :-/
Do you guys have tips for me to find a tutorial for that?

Link to comment
Share on other sites

Thanks for your quick reply! So because you sent me the list of loaders, I have to ask here one question more:

Right now I use NanoBoot for 5.0.x DS3612xs.

 

So to upgrade now I just have to do another USB-Stick with another loader and boot my Server? Then I will upgrade over the DSM Upgrade function to the correct version by the downloaded package?

 

If I'm right, which loader would I choose now exactly for the next step? Each single minor update? Or directly the last one of the 5.2 version?
And do I have to care about the step that my loader now let my server think it's an DS3612xs and with the newer ones it's an DS3615xs?

Link to comment
Share on other sites

Thanks a lot for that! I was able to boot from the stick and the server booted.

 

Connecting to the IP over web was possible and the DSM recognized that the hard drives were put from a DS3612xs to a DS3615xs and asked me to migrate.
I let the DSM migrate the settings and data and everything went through. Then the 10 minutes countdown for the reboot of the server came across and I waited for more than 2 hours, but the server didn't come up again. So I connected a monitor to the server and checked the local video output.

I got the following output:
IMG_20210817_180822.thumb.jpg.261bcc128efc7629bc1dc50fdd9084e6.jpg

 

 

So the update logs seemed to be fine, but the boot then didn't work.

Hearing that the drives didn't work anymore and more than 2 hours later I decided to do a hard shutdown and booted up again.

Now I get the following output:

IMG_20210817_185345.thumb.jpg.09be911a74d84c0b7b24eb8a1b9e2938.jpg

 

Everything I did was booted with the new stick and did the migration. Until now I never was asked to use the new .pat-file for the OS itself, is this my mistake? Using the new loader but still the old OS?

 

 

 

 

Link to comment
Share on other sites

Thank you for your support Dfds!

 

May I ask where I should have used the .pat file? Using it with the old loader of course didn't work over the DSM Webfrontend as manually upgrade file.

Then booting from the new bootloader directly led to the migration dialogue. That's all I was able to do, wasn't I?

 

The local monitor shows me the grub at the boot process where the 5.2 version is the only option, so the system thinks it has it.
But I wonder how it should ever really have loaded the 5.2 DSM, if I never was asked to load up the pat file. When should I have used it in the general process in your opinion?

 

I have also another option in the grub to choose 5.2 install/upgrade. Should I manually choose this option?

 

Thanks a lot for this individual support here!!

Link to comment
Share on other sites

You were totally right - DSM tried to install the newest version. With the grub option here I was able to start again the migration wizard, but the pat file was not accepted for the "migration" option to keep all data AND settings, because it was too old now.

So I decided to choose the fresh installation for that pat file loosing the settings, but keep the data at least.

 

This worked fine for the OS itself, I have the DSM run now, but my four HDDs are just recognized and not mounted. DSM shows the four HDDs as "not in use":

2021-08-18_11-46.thumb.png.5de3a6bc1294fa718430bdd7f0a3f3a1.png

 

I think the reason is, because there is no Volume created (before I had just a "Volume1" for all HDDs together). But I am feared now to create a new volume what will erase all data on the HDDs through the new created volume:

2021-08-18_11-47.thumb.png.ad3830c9f57dd0f8174fe168fd32bbff.png

 

Should I just create it? Or can I start in any way the migration for the HDDs again? I didn't find anything for that 😕

 

Thanks a lot! After that I am able to follow just the tutorial from Polanskiman then O:-)

 

 

 

 

 

 

Link to comment
Share on other sites

2 Questions:

1. I saw that you have linked the pat file of 5.2-5967.1, but the bootloader file of 5.2-5644.5. Was this your intention or maybe accidentally linked the one time older bootloader?
2. If I sticked in my old usb stick with the 5.0-4493 version - would this boot again or is this a bad idea and would corrupt even more the HDDs?

 

What I try to find out:
Should I start with my old working original usb stick again (if possible?!) to get settings back and avoid my one-time mistake of upgrading too far?(and then do the migration correctly new again)
Or should I just try to bring up one new stick with the fitting bootloader for 5.2-5967.1, what is the actual system right now and boot again?


The first way would give me the chance to get settings back and try the clean migration way again, but I don't want to do too much try and error before asking in fear to damage my HDDs now for sure :-) 

Edited by BerziOnline
Link to comment
Share on other sites

Everything worked like a charm now on my N54L. Running the 5.2 version with the correct loader recognized the correct volume with all my data again. The system itself was a little buggy (i.e. no packet management anymore), because of my different tests of loaders and more I think.

I went on with the tutorial from Polanskiman to go from 5.2 to 6.1.7-15284. Worked great!
I chose the new installation and not the migration, because my settings were lost anyway and so I tried to avoid permission errors and bugs from my upgrade mistakes from 5.0 to 5.2.

 

Now: The system runs fine, data volume there, no errors on any place, old bugs are gone!

 

THANK YOU Dfds - you did it!

Edit:
I also updated with the dsm frontend from 6.1.7-15284 to 6.1.7-15284 Update 3 without issues.

Edited by BerziOnline
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...