Recommended Posts

Hi I'm new here but in need of a driver for my 10Gb lan card ( Asus XG-C100C) Aquantia chipset. I got a xpenology nas running (DS3617XS) with jun's bootloader 1.03a and DSM 6.2....

I know the guru's here got it already running on DSM 6.1 and bootloader 1.02 but I would realy like it work on my NAS to ... some help with that would be great.

 

https://www.asus.com/us/Networking/XG-C100C/

Edited by Klasos
Link to post
Share on other sites
  • 2 weeks later...
On 2/22/2019 at 1:16 PM, Klasos said:

Hi I'm new here but in need of a driver for my 10Gb lan card ( Asus XG-C100C) Aquantia chipset. I got a xpenology nas running (DS3617XS) with jun's bootloader 1.03a and DSM 6.2....

I know the guru's here got it already running on DSM 6.1 and bootloader 1.02 but I would realy like it work on my NAS to ... some help with that would be great.

 

https://www.asus.com/us/Networking/XG-C100C/

Is it possible to copy the extra.lmza from an earlier version (DSM 6.1.. ) to the USB stick that has boatloader 1.03a on it ??

Link to post
Share on other sites

Second network port is not coming up. Wondering if the drivers need to be updated. I chose to go with the 1.0.3b bootloader with 3617.

 

Motherboard - Z390M-ITXac

Ethernet - - 1 x Giga PHY Intel® I219V, 1 x GigaLAN Intel® I211AT

 

Really odd, but I see one of the required drivers listed in lsmod, but it says it's not used by any devices. Checked the intel website, and the I219 is the "em" driver, and the 211 is "igb".

 

igb is present, but listed with 0 devices.

"ash-4.3# lsmod | grep igb
igb                   175161  0"

 

em is not present at all.

 

e1000e which is listed as the supporting driver also shows 0 devices.

ash-4.3# lsmod | grep e1000
e1000                  99771  0
e1000e                169025  0

 

I believe I have all the grub settings correct. As far as I can tell the hardware is definitely not showing up at all in the OS.

ash-4.3# grep -r '.*'  /sys/class/net/*/device/vendor
0x8086
ash-4.3# grep -r '.*'  /sys/class/net/*/device/irq
17
ash-4.3#
 

grub.conf

 

set mac1=macfromswitch
set mac2=macfromswitch
set rootdev=/dev/md0
set netif_num=2

 

I started a pxe boot on each port and recorded the mac address from the switch. mac1 is working just fine.

Edited by specter9mm
Link to post
Share on other sites
  • 1 month later...

Hi all,

Is it possible to add drivers for the Supermicro HBA AOC-S3008L-L8e (which is based on the LSI 3008 chipset)...?
I don't know if this is even needed, but just wondering.

Information: https://www.supermicro.com/products/accessories/addon/AOC-S3008L-L8e.cfm

Drivers: https://www.supermicro.com/wftp/driver/SAS/LSI/3008/Driver/ (FreeBSD, Linux, UEFI and Windows)
Firmware: https://www.supermicro.com/wftp/driver/SAS/LSI/3008/Firmware/ (both IR / IT mode firmware; no need to x-flash)

 

Would be great if these drivers could be added? For now and future use obviously. Seems not much of a hassle?
 

Link to post
Share on other sites
On 4/11/2019 at 10:08 AM, HHawk said:

Hi all,

Is it possible to add drivers for the Supermicro HBA AOC-S3008L-L8e (which is based on the LSI 3008 chipset)...?
I don't know if this is even needed, but just wondering.

Information: https://www.supermicro.com/products/accessories/addon/AOC-S3008L-L8e.cfm

Drivers: https://www.supermicro.com/wftp/driver/SAS/LSI/3008/Driver/ (FreeBSD, Linux, UEFI and Windows)
Firmware: https://www.supermicro.com/wftp/driver/SAS/LSI/3008/Firmware/ (both IR / IT mode firmware; no need to x-flash)

 

Would be great if these drivers could be added? For now and future use obviously. Seems not much of a hassle?
 


Is this possible?
(sorry for re-asking)

Link to post
Share on other sites
32 минуты назад, Gronaldo сказал:

You make it sound, like it never will? Why?

Because since version 6.2.1 syno signs drivers in the bootloader with its code and what to add there using the methods described by IG-88 will not work. And drivers for i219 are not initially in DSM.

You can look at the new files (checksum.syno and grub_cksum.syno) in partition 1 of the bootloader that appear after you install version 6.2.1 or later.

root@your_DS:~# mkdir -p /tmp/synoboot_part1
root@your_DS:~# cd /dev
root@your_DS:/dev# mount -t vfat synoboot1 /tmp/synoboot_part1
root@your_DS:/dev# ls /tmp/synoboot_part1
checksum.syno  extra2.lzma  extra.lzma  grub_cksum.syno  rd.gz  Sone.9  zImage

Some NICs with i219 is working in 6.2.1 DSM, you can read about it here (thanks to flyride).

Intel Ethernet Connection I219-LM	8086	15B7 156F
Intel Ethernet Connection I219-V	8086	1570 15B8

 

Edited by Olegin
Link to post
Share on other sites
  • 4 weeks later...

hi can some one do the drivers for my dell poweredge r710 please they are       

Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: lpc_ich
        Kernel driver in use: ata_piix
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: megaraid_sas

and i have added a text file of all the hardware within the system the main network drivers are listed from line 1594 i got of the drivers from when i ran ubuntu desktop in trial mode

DELL R710 Hardware.txt

Link to post
Share on other sites
11 hours ago, djwayne1985 said:

hi can some one do the drivers for my dell poweredge r710 please they are

 

        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: lpc_ich
        Kernel driver in use: ata_piix
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: megaraid_sas

and i have added a text file of all the hardware within the system the main network drivers are listed from line 1594 i got of the drivers from when i ran ubuntu desktop in trial mode

DELL R710 Hardware.txt 130.84 kB · 0 downloads

 

Untitled1.jpg

Link to post
Share on other sites
  • 2 weeks later...
On 5/11/2019 at 4:31 PM, nicoco78 said:

Hi,

 

I can't find my device in find.synology.com. I have a broadcom bcm57781. I think it uses driver Tigon 3.

How can I do?

 

Thanks

 

get linux bootable, boot into linux, open terminal run sudo -i then lspci -k check if your network card is being seen in linux and  is on spreadsheet for dsm version you are using (the commands will give you device id and vendor id which you can match on spreadsheet). Make a loader and remove all your imporatant drives and add 1 crap drive so you can rapidly test if your nic is working once it works and you can see it works do your upgrade / install). If it is not working or on the excel list find or purchase a nic on the list for dsm 6.1 or 6.2 and use it had to go through this myself recently. Tutorials and Guides section of forums is really helpful try it out.

 

 

Edited by Wreid23
Link to post
Share on other sites
  • 2 months later...

Hi all,

Is it possible to add drivers for the  Intel® I219V in 6.2 with DS918+ 1.04b

 

Motherboard - Z390M-ITXac

Ethernet - - 1 x Giga PHY Intel® I219V, 1 x GigaLAN Intel® I211AT  

 

Thanks

 

 

Edited by Martin77
Link to post
Share on other sites
  • 3 weeks later...

Please Create Driver for 'RTL8156 USB3 2.5GB' on DS918+

 

https://github.com/bb-qq/r8152 Exist but not worked

 

You can download source on https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-usb-3-0-software or here

 

I try to compile it with linux-4.4.x.txz for Synology but failed

 

please add it for miniPC or Laptop or other machines without PCIe slot

r8152.53.56-2.12.0.tar

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...

Hello can i install xpenology DMS 6.1.7 or the latest version of the xplenology on my Hyper-V machine? Wil it not work wihtout any drivers? I have virtual switch. DSM 5.2 works very fine and stable.

 

I have downloaded Jun's official v1.02b | DS3610 ISO file but it don't boot up. Do i need any modification on that ISO file?

Link to post
Share on other sites
8 hours ago, thekarmola said:

Hello can i install xpenology DMS 6.1.7 or the latest version of the xplenology on my Hyper-V machine?

no, not working, its not just a bunch of drivers, we are bound to use the original dsm kernel and that one does not have hyper-v support and there is not proper independent virtual-hardware support in hyper-v like for a intel 1000e card or a lsi sas controller as we have in vmware esxi

its staying with dsm 5.2, switching to esxi and use dsm 6.2 or maybe finding a replacement for dsm 5.2 that runs on hyper-v

Link to post
Share on other sites
On 10/19/2019 at 11:03 AM, IG-88 said:

no, not working, its not just a bunch of drivers, we are bound to use the original dsm kernel and that one does not have hyper-v support and there is not proper independent virtual-hardware support in hyper-v like for a intel 1000e card or a lsi sas controller as we have in vmware esxi

its staying with dsm 5.2, switching to esxi and use dsm 6.2 or maybe finding a replacement for dsm 5.2 that runs on hyper-v

 

But is it possible to install some security updates on 5.2? Is it possible to update 5.2 in Synology Webpage to install the latest security updates? I have never tried that. If that is possible o don't really upgrade to 6.2

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.