IG-88

Driver extension jun 1.03a2/DSM6.2.x for DS918+

Recommended Posts

oh sorry. well im still on 6.1.7. Just trying to get a driver added so that i can make my intel 1211AT adapter work, but having no luck so far.

Share this post


Link to post
Share on other sites
В 14.08.2018 в 18:35, alirz1 сказал:

oh sorry. well im still on 6.1.7. Just trying to get a driver added so that i can make my intel 1211AT adapter work, but having no luck so far.

Intel® I211-AT work fine !)

Share this post


Link to post
Share on other sites
2 hours ago, 4sag said:

Intel® I211-AT work fine !)

in 1.03b with the extra ram disk for the DS918+? or does it also work for Ds3716 with 1.02b loader?

Share this post


Link to post
Share on other sites

ok so i tested. To aovid messing up my ds3617 xpenology disk, i unplugged them just to test booting off the DS918+ loader to test my two lan nics.

This is what i observed:

 

- with the stock 1.03a2 jun loader for Ds918+, the functional NIC is the intel 1211 and the intel 1219 DOESNT work. (on my ds3617 1.02b loader, the 1219 works but the 1211 does not)

-with the 1.03a2 jun loader for Ds918+ with the extra ram disk lzma included. Both my NICs work. So obviously the ram disk for the ds918+ has some additional drivers that the 3617 ram disk does not!.

I think the extra ram disk for the ds3617 needs a new driver module for "igb" because that module seems to be responsible for the intel 1211 NIC. 

Share this post


Link to post
Share on other sites
19 часов назад, alirz1 сказал:

ok so i tested. To aovid messing up my ds3617 xpenology disk, i unplugged them just to test booting off the DS918+ loader to test my two lan nics.

This is what i observed:

 

- with the stock 1.03a2 jun loader for Ds918+, the functional NIC is the intel 1211 and the intel 1219 DOESNT work. (on my ds3617 1.02b loader, the 1219 works but the 1211 does not)

-with the 1.03a2 jun loader for Ds918+ with the extra ram disk lzma included. Both my NICs work. So obviously the ram disk for the ds918+ has some additional drivers that the 3617 ram disk does not!.

I think the extra ram disk for the ds3617 needs a new driver module for "igb" because that module seems to be responsible for the intel 1211 NIC. 

What do you need 3617 or 918?

6.1 or 6.2 ?

Edited by 4sag

Share this post


Link to post
Share on other sites
 
3617 on 6.1. Thanks.


So please take this to the 6.1 custom ramdisk topic. This topic is for 6.2.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 8/14/2018 at 2:15 PM, Polanskiman said:

 


Yes but we are in DSM 6.2 topic. There is no custom ramdisk for the 3617xs or 3615xs for DSM 6.2 available other than for 918+.

 

1

 

Is a custom ramdisk for 3617xs or 3615x DSM 6.2 planned for the future or is the intention to support only the 918+ loader?

 

 

 

Share this post


Link to post
Share on other sites

Who knows, this driver pack improve hw transcoding on j3455 cpu with valid sn/mac and activated codecs?? Thanks. 

Edited by T-REX-XP

Share this post


Link to post
Share on other sites

hi,

 

tinyupload.com says

File was deleted from server. 
File was deleted by owner or exceeded maximum storage time (100 days from last download).

i did not delete them but it cant be 100 days without download so clearly a error on there side - but hey its for free, i re-uploaded them

 

Share this post


Link to post
Share on other sites
On 8/22/2018 at 9:03 PM, T-REX-XP said:

Who knows, this driver pack improve hw transcoding on j3455 cpu with valid sn/mac and activated codecs?? Thanks. 

 

no, it does not change anything about this, its just more drivers for network and storage

as long as its not compiled directly into the kernel (*.ko file in /lib/modules/) it might be possible - any suggestions?

Edited by IG-88
  • Thanks 1

Share this post


Link to post
Share on other sites

hello!

 

i seem to be missing something. all the talk in this topic is about the extra.lzma for jun's loader 1.03a2 for ds918+ image.

 

however, on jun's topic there is available only loader 1.03b for other ds versions. 

 

where cane we get a loader for ds918+? i am trying to test this on an asrock j3455b itx board. 

 

thanks!

Share this post


Link to post
Share on other sites

Hello,

 

I have been able to install DSM 6.2 using the 1.3b loader on my N40L. (DS3617xs)

But I would like to use the DSM for the DS918+, because I would like to use the SHR functionality.

This, I can not manage, it does not show up on the network.

So I have the following questions:

1. Where do I get a serial for the DS918+?

2. How do I add the extra.lzma file, in case I need it? (I have OSFMOUNT running, but I don't know where to put is aor which file I need to replace. I can not find any extra.lzma on partition 0)

3. What is really my problem installing it? Has anybody succeeded with my hardware?

 

Regards, Tomte

Share this post


Link to post
Share on other sites

Update:

I have understood now, that I have to replace the extra in the second partition. 

Did it, but it is still not working.

 

Share this post


Link to post
Share on other sites
13 hours ago, Tomte said:

1. Where do I get a serial for the DS918+?

 

you dont need a sn for normal nas usage

 

Quote

2. How do I add the extra.lzma file, in case I need it? (I have OSFMOUNT running, but I don't know where to put is aor which file I need to replace. I can not find any extra.lzma on partition 0)

 

read the faq about migrating to dsm 6.1 its also the install instructions for a fresh install,

 

Quote

3. What is really my problem installing it? Has anybody succeeded with my hardware? 

 

cpu is to old i guess

if you read the 1st post carefull you might recognize this

"CPU list for DS918+ Image - 4th gen Intel Core aka Haswell seems to be minimum requirement (Hide contents)"

 

13 hours ago, Tomte said:

because I would like to use the SHR functionality. 

 

you dont need 916/918+ for SHR

try the FAQ section

"3 - How can I use SHR in DSM6?"

 

after adding a SHR it will work even if the additional entry's are removed (bigger dsm updates), its only needed to create SHR, the code for using it is there and will be used if a SHR raid is found

 

Edited by IG-88

Share this post


Link to post
Share on other sites

Hello IG-88,

 

thank you so much for your help, I have got it now up and running.

I feel really embarassed, that part of my questions is answered by the FAQ.

This makes me even more thankful that you pointed me in the right direction.

 

Regards, Dieter

Share this post


Link to post
Share on other sites

Are the virtio drivers included in this package? Have DSM running on KVM but the difference between e1000 and virtio for network i really big 3.5gbps to 40gbps. Want to be able to saturate my 10G connections at least. 

Share this post


Link to post
Share on other sites
19 hours ago, liuhangcheng said:

can u add new i915 gpu driver for 8gen intel UHD  gpu ?

 

if you have a source repository i might try but afaik that driver is part of the kernel and is maintained in the kernel so getting it into the old 4.4 kernel will be backporting

but if you have a solution lets hear it (i guess its not like a network driver, that one might be closely tied to the cpu support and if you try to backport it you end up patching the whole kernel and as we cant use another kernel with dsm ... i dont think that will be possible)

 

Share this post


Link to post
Share on other sites

Is it possible to compile this package for 3817 as well?

Or can I include them directly?

 

I have an LSI 9211-8i (IR) which is not recognized from one day to the next.
With Ubuntu all hard disks are recognized perfectly.

Even a replacement controller recognizes all hard disks under Ubuntu but not under DSM 😕

Share this post


Link to post
Share on other sites

beside that it should be IT und not IR (R like RAID)

one day to another like update from 6.2.(0) to 6.2.1?

dis you see the announcements on the start page?

https://xpenology.com/forum/announcement/17-dsm-621-23824-warning/

 

since 6.2.1 all not synology modules are not working anymore, so if you have 918+ then the dsm update broke your mpt2sas.ko driver as this diver is not from the 918+ image by synology

BUT the 3615 and 3617 image contain this driver by default and jun's 1.03b loader is for 3615/3617

depending on your nic you could switch to 3617 with a new loader, but only if the nic is supported by the original 3617 (in *.pat file, hda1.tgz, /usr/lib/modules)

(realtek would be a deal breaker that one is part of 918+ org. pat file but not in 3615/3617

 

the other option is to downgrade back to 6.2.(0) or better to 6.1.x (to get all new security updates)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.