• 0
RKG90

LED prevent hibernation

Question

Hi

 

I just built a NAS server with at ASROCK J3455-itx

everything is working perfectly except hibernation.

I think i figured out it has something to with the computer trying to read the LED brightness. But it cant and wakes up again.

 

i found this in scemd.log:

2018-06-29T19:37:31+02:00 Grevy-NAS scemd: led/led_brightness.c:244 Fail to read /usr/sbin/i2cget
2018-06-29T19:37:31+02:00 Grevy-NAS scemd: led.c:35 SYNOGetLedBrightness fail()
2018-06-29T19:37:51+02:00 Grevy-NAS scemd: event_disk_hibernation_handler.c:42 The internal disks wake up, hibernate from [Jun 29 19:37:27]
2018-06-29T19:48:16+02:00 Grevy-NAS scemd: led/led_brightness.c:244 Fail to read /usr/sbin/i2cget
2018-06-29T19:48:16+02:00 Grevy-NAS scemd: led.c:35 SYNOGetLedBrightness fail()
2018-06-29T19:48:34+02:00 Grevy-NAS scemd: event_disk_hibernation_handler.c:42 The internal disks wake up, hibernate from [Jun 29 19:48:15]
2018-06-29T19:58:35+02:00 Grevy-NAS scemd: led/led_brightness.c:244 Fail to read /usr/sbin/i2cget
2018-06-29T19:58:35+02:00 Grevy-NAS scemd: led.c:35 SYNOGetLedBrightness fail()
2018-06-29T19:58:55+02:00 Grevy-NAS scemd: event_disk_hibernation_handler.c:42 The internal disks wake up, hibernate from [Jun 29 19:58:35]
2018-06-29T20:09:27+02:00 Grevy-NAS scemd: led/led_brightness.c:244 Fail to read /usr/sbin/i2cget
2018-06-29T20:09:27+02:00 Grevy-NAS scemd: led.c:35 SYNOGetLedBrightness fail()
2018-06-29T20:09:40+02:00 Grevy-NAS scemd: event_disk_hibernation_handler.c:42 The internal disks wake up, hibernate from [Jun 29 20:09:26]

 

As you can see it keeps on waking up right away and go to hibernate 10min after.

Can someone tell me how i turn off the brightness reading ?

 

Best Regards

RKG90

Edited by Polanskiman
Added code tag

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hello,

 

   If you are running DSM 6.2 .. go to Control Panel | Hardware & Power ... Scroll down to "LED Brightness Control" and drag the slider to the OFF position.

Share this post


Link to post
Share on other sites
  • 0

Hi 

 

Thx for the answer. 

But I already tried that. It still Makes the same error and Wakes up

Share this post


Link to post
Share on other sites
  • 0

So i updated to DSM 6.2 with jun 1.03a2 918+ 

Now the errors is coming every 6 seconds and it is not even going to hibernation.

 

No one have a solution, on how to make DSM not read the brightness of the LED ? 

Edited by RKG90

Share this post


Link to post
Share on other sites
  • 0

 

I solved this on my 6.1 station by removing scemd.log and link it to /dev/null, which is kind of logging to nowhere. Of course, you won't be able to see the log contents this way.

 

This can be done by enabling ssh, log in and execute the following commands.

sudo -i
rm /var/log/scemd.log; ln -s /dev/null /var/log/scemd.log

I don't remember if a restart was needed but I think it does.

 

I always wanted to test if I can redirect the logs to an UBS stick but I didn't have the time for this.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.