Joly00

Hardware Acceleration with Asrock j5005

Recommended Posts

1 minute ago, liuhangcheng said:

i got j4105 (same gpu as j5005) work with emby in openmediavault. 

Yeah, i know. Its a Problem in Xpenology, not the Cpu itself. Xpenology just doesnt support Gemini Lake Gpus atm, i think a driver is missing or something like that, i dont know, but i guess, we have to wait.

Share this post


Link to post
Share on other sites
Just now, Joly00 said:

Yeah, i know. Its a Problem in Xpenology, not the Cpu itself. Xpenology just doesnt support Gemini Lake Gpus atm, i think a driver is missing or something like that, i dont know, but i guess, we have to wait.

Linux kernel 4.14 start support uhd gpu with set boot arg, synolgy kernel is much older than that

Share this post


Link to post
Share on other sites
5 minutes ago, liuhangcheng said:

Linux kernel 4.14 start support uhd gpu with set boot arg, synolgy kernel is much older than that

Well. There has to be a way, to compile the Kernel in Xpenology

Share this post


Link to post
Share on other sites

So the Asrock j5005 is atm no recommendation if i want to build a Xpenology NAS?

 

I am a total noob to Xpenology and i am looking for the best solution  ;)

Share this post


Link to post
Share on other sites
30 minutes ago, chemistry said:

So the Asrock j5005 is atm no recommendation if i want to build a Xpenology NAS?

 

I am a total noob to Xpenology and i am looking for the best solution  ;)

Well, the j5005 is definitly a recommendation, simply because of the good Performance, especially if you consider the Price of the Cpu-Mobo combi.

 

The only Problem this Cpu has atm, is that is not cappable of encoding with Intel Quick Sync, which might change in the future.

 

I would like to see this feature come, this would make many things easier, but hey, atm i am running a few Gameservers, Mediaserver and a Teamspeak server on it, and still can use it normally.

 

And thats the reason why i bought this, although Quick Sync wont work.

Share this post


Link to post
Share on other sites

Ok - i think i can handle that missing atm ;)

I don't see why this is such a big thing for many.

 

I have an extra htpc - so that station itself is playing the videos and not my possible new XPEnology NAS.

 

Edited by chemistry

Share this post


Link to post
Share on other sites

I have Asrock J4205-ITX. Works perfectly.

Hardware acceleration is enabled and working, activations.conf shows success and the enabled codecs. The serial is from my old DS214.

 

 

Share this post


Link to post
Share on other sites
14 hours ago, cdrvbfhq said:

Hardware acceleration is enabled and working, activations.conf shows success and the enabled codecs

What about the dev / dri directory?

Share this post


Link to post
Share on other sites
14 часа назад, cdrvbfhq сказал:

I have Asrock J4205-ITX. Works perfectly.

Hardware acceleration is enabled and working, activations.conf shows success and the enabled codecs. The serial is from my old DS214.

 

Show the result of the commands, please:

cd /
ls /dev/dri

 

Share this post


Link to post
Share on other sites
57 minutes ago, Olegin said:

Show the result of the commands, please:


cd /
ls /dev/dri

 

 

Hm, it seems its not working as expected. Thanks for letting me know.

 

ash-4.3# cd /
ash-4.3# ls /dev/dri
ls: cannot access /dev/dri: No such file or directory

 

So my license is okay, but the GPU is not initialized, right?

Sorry I didn't know these commands, but now I see what is the issue here. This CPU is not fully supported by the kernel, maybe missing drivers. :(

Edited by cdrvbfhq

Share this post


Link to post
Share on other sites
30 минут назад, cdrvbfhq сказал:

 

Hm, it seems its not working as expected. Thanks for letting me know.

 

ash-4.3# cd /
ash-4.3# ls /dev/dri
ls: cannot access /dev/dri: No such file or directory

 

So my license is okay, but the GPU is not initialized, right?

Sorry I didn't know these commands, but now I see what is the issue here. The iGPU is not supported. :(

HW trancoding isn’t work with Asrock J4205-ITX yet. Sem’s that trouble is in bios. I can’t start hw on my mb (see signature) before the bios was updated.

Edited by Olegin
  • Like 1

Share this post


Link to post
Share on other sites

So, to give this Thread a Solution:

Hardware Acceleration works for me with the j5005-ITX by Asrock when using the new 1.04b Jun Loader and install Emby (You have to enable VAAPI and not Intel Quick Sync).

The /dev/dri folder is also available.

Share this post


Link to post
Share on other sites
2 hours ago, Joly00 said:

So, to give this Thread a Solution:

Hardware Acceleration works for me with the j5005-ITX by Asrock when using the new 1.04b Jun Loader and install Emby (You have to enable VAAPI and not Intel Quick Sync).

The /dev/dri folder is also available.

 

Good news !

Could you give us the exact HW config please ? (I am looking for Home Made NAS and this Mobo is intresting) :)

Thanks

Share this post


Link to post
Share on other sites
Just now, tomsauy said:

 

Good news !

Could you give us the exact HW config please ? (I am looking for Home Made NAS and this Mobo is intresting) :)

Thanks

Just search for "ASROCK J5005-ITX" and  you will definitly find it. Added to that, i just used a Supermicro Case, because it was small and has easy accesible Hot-Swap Drive cages, althought it was a bit expensive for just a Home Server Case (~160 Euro).

Share this post


Link to post
Share on other sites
3 minutes ago, Joly00 said:

Just search for "ASROCK J5005-ITX" and  you will definitly find it. Added to that, i just used a Supermicro Case, because it was small and has easy accesible Hot-Swap Drive cages, althought it was a bit expensive for just a Home Server Case (~160 Euro).

 

What I am looking for is especially the Case / Power supply informations and memory you used :) 

 

I plan to build NAS for Storage (with 4 or 6 x 6To) + VM + Docker + MediaServer

 

Share this post


Link to post
Share on other sites
17 minutes ago, tomsauy said:

 

What I am looking for is especially the Case / Power supply informations and memory you used :) 

 

I plan to build NAS for Storage (with 4 or 6 x 6To) + VM + Docker + MediaServer

 

If you are German or the Language doesnt bother you (I think, u can change it) here is the Link for my Wishlist with all parts, i used for the NAS https://geizhals.de/?cat=WL-986884

but if u want to use the exact same Case, i recommend you to buy this https://www.amazon.de/gp/product/B000ONYSR4/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

also, because the frontpanel header Supermicro uses ist not a propiatary standard so you need this adapter cable.

 

In this exact Case and with this exact Mainboard, u can only use 4 HDD´s because the Case only has 4 drives (although there are 2 additional 2,5" places to add Ssd cache or something) and the Mainboard has only 4 Sata-headers, you can sure add a few more, but the Pcie slot is only pcie 2.0 x1.

 

Btw, Asrock , or to be exact Intel, only specifies the Mainboard with 8gb Ram support, but many people, me included, tested that, and it also works with 16 gb, some people also tested it with 32gb, but it seems like, that this can become a bit unstable, if u dont choose the right kit.

Share this post


Link to post
Share on other sites
On 12/17/2018 at 6:18 PM, Joly00 said:

If you are German or the Language doesnt bother you (I think, u can change it) here is the Link for my Wishlist with all parts, i used for the NAS https://geizhals.de/?cat=WL-986884

but if u want to use the exact same Case, i recommend you to buy this https://www.amazon.de/gp/product/B000ONYSR4/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

also, because the frontpanel header Supermicro uses ist not a propiatary standard so you need this adapter cable.

 

In this exact Case and with this exact Mainboard, u can only use 4 HDD´s because the Case only has 4 drives (although there are 2 additional 2,5" places to add Ssd cache or something) and the Mainboard has only 4 Sata-headers, you can sure add a few more, but the Pcie slot is only pcie 2.0 x1.

 

Btw, Asrock , or to be exact Intel, only specifies the Mainboard with 8gb Ram support, but many people, me included, tested that, and it also works with 16 gb, some people also tested it with 32gb, but it seems like, that this can become a bit unstable, if u dont choose the right kit.

 

Thanks a lot for all this informations, I thinks it exactly what I need so I will try to look for the same on amazon.FR or other french shops :) 

 

 

Share this post


Link to post
Share on other sites

I just upgraded my HP Gen7 (N54L) with a Asrock J4105B-ITX + Avago LSI9211-8i. It was a little tricky, but I did it. My second plan was to buy a new case.  This one.

 

By the way. Asrock Gemini Lake are only UEFI compatible, not legay BIOS (CSM mode). I don't know if it bothers you, but you would´t boot Freedos, for example. No way to flash MAC and some other issues.

Edited by Eduardo
Adding info

Share this post


Link to post
Share on other sites

@Eduardo

Flash the Mac is not an issue, after contacting Asrock support, they gave me this tool (wMAC_v1.0.61.zip)

you must run this tool from windows 10 cmd line, i did a win 10 enterprise temp install then a run that tool as usua,l wMAC c XXXXXXXXXX /s

et voila

Share this post


Link to post
Share on other sites
6 hours ago, sergelhr said:

@Eduardo

Flash the Mac is not an issue, after contacting Asrock support, they gave me this tool (wMAC_v1.0.61.zip)

you must run this tool from windows 10 cmd line, i did a win 10 enterprise temp install then a run that tool as usua,l wMAC c XXXXXXXXXX /s

et voila

Yes, you are right. They gave me same tool, just before Christmas and they told me Asrock would be on holidays untill 2th january. I didn't dare flashing on Asrock's holidays and been busy later... Thanks a lot

Share this post


Link to post
Share on other sites
On 1/9/2019 at 3:19 PM, sergelhr said:

@Eduardo

Flash the Mac is not an issue, after contacting Asrock support, they gave me this tool (wMAC_v1.0.61.zip)

Hi @sergelhr I also wrote to support (I got a J4105-ITX) but they did not provide me the same tool.. could you please share it?

Many thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.