jun

Progress of 6.2 loader

Polanskiman

Let me get things straighten up here before this thread starts going sideways. This is the developper discussion room. Not a newbie forum to start asking for guides and whatnot. @jun hasn't even said anything about the loader he has uploaded to his repository. So I would advise self control. Also, to those in panic mode trying to make things work desperately please use your personal jugement and experience. If you want to have a positive contribution to this thread then please do so by posting about possible bugs or things that don't work (beyond the "no network" boring posts of course). I am talking about serious bugs or the such. All other requests will from now on be deleted or moved if appropriate. I have no time to babysit anymore. Use the forum subsections.

Message added by Polanskiman

Recommended Posts

I picked up an Asrock J3455B-ITX motherboard and performed a bunch of tests. Here's what I've found:

  • When a screen is plugged in (i was using VGA), the system was very unstable - rebooting every 5-10mins. Disconnecting VGA cable and USB keyboard helped. Used serial cable to monitor boot progress.
  • Hardware transcoding worked in both Plex and Video station. I had 3 hardware transcoded streams (1 x video station, 2 x plex) running simultaneously without any problems. However - after a some time, hardware transcoding wouldn't work from either app until the system was restarted. 
    • transcode.thumb.png.23cdf255437cb4cbd07f262d70f5eb73.png
  • When using the 2 onboard SATA ports only, the kernel would panic and reference something about activating the AHCI_LED. Adding in a 2 port AHCI SATA card seemed to get around it (although i need to do this anyway as 2 ports isn't enough!)
  • Booting is pretty slow compared to 1.02b. Seems to hang at "Post init" for some time. Maybe due to the following "failed to send sync event, type resync, finish 0, interrupt 0?"
  • Network speeds are pretty disappointing too.
    • File transfer to my existing NAS (4 drive SHR array / jun loader 1.02b / DSM 6.1.7):
    • nas.png.574c1d8f7083beedff0c3e61e6d909ae.png
    • Whereas to the new "test" nas (4 drive RAID 0 array / jun loader 1.03b / DSM 6.2):
    • nas_test.png.4177e5bb58c6e9c17a16905b307c72fa.png

 

So for me to get a working system i need to:

  • Install a 2 port PCI-e SATA controller to get around the AHCI_LED panic
  • Switch to CSM/BIOS boot mode. Otherwise the boot process doesn't always pickup the SATA controller
  • Ensure no VGA cable plugged in
  • Ensure boot USB stick is in USB2 port (only 1 on the back, the rest are USB3)

 

Need to investigate the transcoding issue and try speed up the network as it's terrible :(

Edited by ideasman69
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 7/3/2018 at 9:55 AM, Bi0 said:

On esxi 6.5 looking good so far.

 

Not working for me, why is this working for some people :(

 

 

image.thumb.png.8f8ae2b67014341b4cca93e53884997f.png

 

Not showing up on the network, same for the 6.1 Loader.

Xpnology Loader (5.2) is the last one working for me.

Share this post


Link to post
Share on other sites
Not working for me, why is this working for some people
 
 
image.thumb.png.8f8ae2b67014341b4cca93e53884997f.png
 
Not showing up on the network, same for the 6.1 Loader.
Xpnology Loader (5.2) is the last one working for me.
Post a screen of your vm settings maybe I can see what you did wrong. Think most important is this sata settings.
Also you should change the MAC address in the boot image to the one vmware is generating after first boot.
a975ba637c588b60cb44fb7650b9b3d5.jpg

Gesendet von meinem ONE A2003 mit Tapatalk

Share this post


Link to post
Share on other sites
On 7/13/2018 at 2:51 PM, modboxx said:

That's a nice cpu for Plex transcoing :) 

 

Sonny can you also do below command and post result?

dmesg |grep drm

 

Okay, here it is:

 

[   13.448102] [drm] Initialized drm 1.1.0 20060810
[   13.517978] [drm] Memory usable by graphics device = 4096M
[   13.517979] [drm] VT-d active for gfx access
[   13.526807] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   13.526809] [drm] Driver supports precise vblank timestamp query.
[   13.540217] [drm] Disabling framebuffer compression (FBC) to prevent screen flicker with VT-d enabled
[   13.600790] [drm] GuC firmware load skipped
[   13.604722] [drm] Initialized i915 1.6.0 20160919 for 0000:00:02.0 on minor 0
[   13.607928] [drm] Cannot find any crtc or sizes - going 1024x768
[   13.820752] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   14.731309] [drm] RC6 on
 

Share this post


Link to post
Share on other sites
On 7/13/2018 at 1:55 PM, Olegin said:

Can you post here the result of this command in telnet/ssh:


cat /usr/syno/etc/codec/activation.conf

 

Here is the other one:

 

{"success":true,"activated_codec":["h264_dec","h264_enc","ac3_dec","hevc_dec","mpeg4part2_dec","aac_dec","aac_enc"],"token":"********************"}

Share this post


Link to post
Share on other sites
25 минут назад, Sonnyboy666 сказал:

Here is the other one:

{"success":true,"activated_codec":["h264_dec","h264_enc","ac3_dec","hevc_dec","mpeg4part2_dec","aac_dec","aac_enc"],"token":"********************"}

Thanks, it's a good news. I'll try on my xeon e3 1285l v3, may be kodecs will work too.

Share this post


Link to post
Share on other sites

Hi there!

 

Is there a possibility to build a new fork of this loader for DS3615xs/DS3617xs for older CPUs?

How this can be done?

 

Thanks in advance!

  • Like 1

Share this post


Link to post
Share on other sites
Hi there!
 
Is there a possibility to build a new fork of this loader for DS3615xs/DS3617xs for older CPUs?
How this can be done?
 
Thanks in advance!
I am waiting for this too as I have no use for plex and my Xpenology 6.1.7 under Vmware 6.5 on HP Microserver Gen8 is working awesome.
  • Like 1

Share this post


Link to post
Share on other sites
24 minutes ago, john_matrix said:

Is there a possibility to build a new fork of this loader for DS3615xs/DS3617xs for older CPUs?

How this can be done? 

 

get yourself stuff like debugger, IDA, ... reverse engineer jun's "patch" (its part of the loader) and redo it for the other systems (kernels, the loader is pretty much the same, the hack is specific for every platform aka kernel)

 

i guess the 918+ is just the test to see if all protections are gone and the patch is 100% working, investing work on two other platforms and having to redo it because something was missing in the 1st try is not much fun i guess, if everything with 918+ goes well for a while i expect jun will release more just give it a while

i guess its like solving a problem (doing one/1st platform patch) is fun and maintaining stuff (doing more platforms) is work, to make it useful for many people you will have to do both but you want to minimize the 2nd part, i think (just logic) jun will at least do a patch for 3617 later to see if potential problems are found, if 3617 can handle all hardware like 3615 it makes not much sense to maintain 3615 further, the update support of synology will end earlier for 3615, but i don't know anything about how jun's point is there so its pure speculation based on things i've catched here in the forum

 

so be patient or start hacking ;-) (an if you are on hacking, just have a look for the sata kernel mod's synology did so we can have sata_*.ko/pata_*.ko drivers)

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, Sonnyboy666 said:

Okay, here it is:

 

[   13.448102] [drm] Initialized drm 1.1.0 20060810
[   13.517978] [drm] Memory usable by graphics device = 4096M
[   13.517979] [drm] VT-d active for gfx access
[   13.526807] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   13.526809] [drm] Driver supports precise vblank timestamp query.
[   13.540217] [drm] Disabling framebuffer compression (FBC) to prevent screen flicker with VT-d enabled
[   13.600790] [drm] GuC firmware load skipped
[   13.604722] [drm] Initialized i915 1.6.0 20160919 for 0000:00:02.0 on minor 0
[   13.607928] [drm] Cannot find any crtc or sizes - going 1024x768
[   13.820752] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   14.731309] [drm] RC6 on
 

 

Thanks!  That's a bad ass CPU for Xpenology.

Edited by modboxx

Share this post


Link to post
Share on other sites
2 hours ago, IG-88 said:

 

get yourself stuff like debugger, IDA, ... reverse engineer jun's "patch" (its part of the loader) and redo it for the other systems (kernels, the loader is pretty much the same, the hack is specific for every platform aka kernel)

 

i guess the 918+ is just the test to see if all protections are gone and the patch is 100% working, investing work on two other platforms and having to redo it because something was missing in the 1st try is not much fun i guess, if everything with 918+ goes well for a while i expect jun will release more just give it a while

i guess its like solving a problem (doing one/1st platform patch) is fun and maintaining stuff (doing more platforms) is work, to make it useful for many people you will have to do both but you want to minimize the 2nd part, i think (just logic) jun will at least do a patch for 3617 later to see if potential problems are found, if 3617 can handle all hardware like 3615 it makes not much sense to maintain 3615 further, the update support of synology will end earlier for 3615, but i don't know anything about how jun's point is there so its pure speculation based on things i've catched here in the forum

 

so be patient or start hacking ;-) (an if you are on hacking, just have a look for the sata kernel mod's synology did so we can have sata_*.ko/pata_*.ko drivers)

Thanks IG-88,

 

If Jun has planed to take a look on DS3615xs/DS3617xs loader, I will wait ;)

Share this post


Link to post
Share on other sites

I just built a new NAS with 1.03a2 loader with DS918+ successfully. Couldn't wait to open this account and report this : D

 

My set up:

Intel Pentium Gold G5500 2 Cores 4 Threads @3.80 GHz
ASUS PRIME H310I-PLUS
DDR4-2133 RAM 8GB
Toshiba 3TB SATA3 Harddisk, JBOD
Toshiba 4TB SATA3 Harddisk, moved from another SynologyNAS, SHR with files (later formated into JBOD too)

 

I updated to version DSM 6.2-23739 Update 1 right the way.

Everything works fine for 4 days: Starting/Rebooting, packages like drive/moment, video station, surveillance station & community packages like CouchPotato

 

Btw has anyone updated to DSM 6.2-23739 Update 2 yet? How's that?

Share this post


Link to post
Share on other sites
1 hour ago, ming0070913 said:

Btw has anyone updated to DSM 6.2-23739 Update 2 yet? How's that?

 Results for that are reported here: 

 

 

 

Share this post


Link to post
Share on other sites
19 hours ago, turbo21psi said:

 Results for that are reported here: 

 

No problem updating on 918+ on ESX6.5

 

 

Share this post


Link to post
Share on other sites
В 12.07.2018 в 06:31, marsb007 сказал:

J4205 seems to work fine out of the box. I do have a PCIe SATA adapter which was recognized just fine. I also have 3 bonded NIC connections (1 internal, 2 gigabit ethernet USB 3.0 dongles), so I did have to increase the settings in synoinfo to reflect the additional NIC (standard is 2, had to bump to 3). Thank you guy that figured that out before me!!!

 

Hw accelerated transcoding seems to work. One stream is averaging about 20-35% cpu via Emby streaming when I was playing it in a different resolution. Idles at 1-3% when running native resolution. 

 

The system has been rock solid for me. No resets, no dropped connections, no errors that I can see. I have 6x4TB WD Gold drives.

Overall, 1.03a2 configured as DS918+ on the Asrock J4205 is running great.

I also have asrock j4205 Board. When booting from USB station is not visible in the network. 

Share this post


Link to post
Share on other sites

In I5 7500 + MSi B250M-MORTAR / ESXi 6.5,  it work.  But the system time is incorrect,  the clock is very slow.   And the VM can't shut down from dsm.

Share this post


Link to post
Share on other sites

Btw: shouldn't Synology release the source code of the kernel? Shouldn't this make things a lot easier?

Share this post


Link to post
Share on other sites
21 час назад, error403 сказал:

Btw: shouldn't Synology release the source code of the kernel? Shouldn't this make things a lot easier? 

here

Share this post


Link to post
Share on other sites

FX-8300/Gigabyte 970A-UD3P ESXi 6.7 not working (freeze after GRUB), nothing unexpected though.

Share this post


Link to post
Share on other sites

In Jun's whatsnew.txt file he says:

Quote

DS918+ does not make use of cmos rtc, so rtc related function does not work properly.

 

Can this have an affect on the overall speed of the system? Just looking up a few posts, @hoverfly mentions that his clock is running slowly and got me wondering...

 

How does the 918+ keep its time? just NTP?

Share this post


Link to post
Share on other sites

 

Good day. I bought the Asrok j3455 Installing 4 disks with 1 TB in raid 10 The serial from the current 918 and popup addresses as well. Do not work transcoding, how to check in what is the problem that needs to be driven in a Putty command. Also, there is a problem in the speed of data transfer, downloading from the NAS on the straight to the laptop by LAN cable of all 13 megabytes. You may need to configure the BIOS In the VS checkbox is the included transcoding

Share this post


Link to post
Share on other sites

hello all long time did not come here just to let you know i have loaded and testing DS918+ with my ASerock h110M CPU it I5-6600 with 16 gig of ram and  6*3 TB hard drive raid 5

 

i am transferring data on it to test . Will test Plex and let you know how it goes.

 

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.