zeratul75

script at boot for wake on lan

Recommended Posts

Hello

I installed nanoboot 5.0.3.1 in a old notebook, just for testing purpose.

Everything is working fine, but not able to use wake on lan feature.

 

In DSM control panel, under hardware setting, wake on lan is not checked, but I am not able to actually enable it. Infact, if I check it, every time I press "apply" the option returns unchecked.

 

I searched on google a lot, and eventually find the "solution":

by using ethtool in ssh session I can see wake on lan is supported by my nic, but it is disabled. (wake on lan status d).

I launch the command

ethtool -s eth0 wol g

and the status changed to g. after shutting down the nas wake on lan is working.

 

The problem is that at every startup/reboot of the system, It returns to d (disabled) status.......

In DSM there is the possibility to lauch a script created by user, so I did it, and it is actually working. I mean, after manually execute it, by ssh session I can see the status of wake on lan changing from d to g.

But there is no option to make DSM execute it at every system startup; only option to execute one a day, one a week, etc......

 

So basically, I need to insert that simple command (ethtool -s eth0 wol g) at boot scripts. But I have no idea which boot file I need to edit.

I feel very closed to the solution, but unfortunately my linux knowledge is very limited......

Is this the right way to do this? Or is there any config file that DSM lauches at start up, which can be edited by user adding that command?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now