Jump to content
XPEnology Community

Сертификат Let's encrypt


Recommended Posts

Здравствуйте, несколько раз уже обновлял сертификат на lrts encrypt без проблем, но сегодня написал "Нет ответа от целевого сервера. Повторите попытку попозже"

В чем может быть проблема?

Link to comment
Share on other sites

1 минуту назад, Архип сказал:

доступен ли домен(на который выписывается сертификат) dsm из внешки на 80 и 443 порту?

 

да

мне смысла нет сейчас выполнять эту команду ведь я пробовал снова создать сертификат и удалил тот что истек поэтому нечего перерегистрировать

Edited by USemmy
Link to comment
Share on other sites

Только что, Архип сказал:

не знаю что там у вас за сбой но по умолчанию всё обновляется автоматом

у меня обновлялось до сегодняшнего дня

 

Link to comment
Share on other sites

21 минуту назад, Архип сказал:

лог ошибки выкладывайте сюда из /var/log/Let'sEncrypt

Все решилось из за косяка в нат сервере, проблема с DNS

Edited by USemmy
Link to comment
Share on other sites

  • 3 years later...

И? как решилось то? "А всё зашибись, спасибо адьёс, я убежал" форум для того и форму что не чат - есть вопрос есть решение, оставленное потомкам... Сейчас вот 2022 и летсэнкриппт шлёт всех лесом на 6.2.3 говорят на 6.2.4 там что-то поправили, но апдейтиться туда нельзя ибо слетит всё к чёрту...  И как быть? Бэкапить всё, сноситьь всё, ставить РэдПил+7,0,1 и руками-руками всё возвращать

  • Like 1
Link to comment
Share on other sites

  • 4 months later...
В 14.01.2022 в 12:58, VitaliyAT сказал:

И? как решилось то? "А всё зашибись, спасибо адьёс, я убежал" форум для того и форму что не чат - есть вопрос есть решение, оставленное потомкам... Сейчас вот 2022 и летсэнкриппт шлёт всех лесом на 6.2.3 говорят на 6.2.4 там что-то поправили, но апдейтиться туда нельзя ибо слетит всё к чёрту...  И как быть? Бэкапить всё, сноситьь всё, ставить РэдПил+7,0,1 и руками-руками всё возвращать

Приветствую, людей из 2022!

Столкнулся с описанной проблемой. как писали что проблема в DNS, проверил не в этом.

Далее нашел это Tutorial: Let's Encrypt certificates on DSM 6.1.X (change API from v01 to v02) почитал вроде логично, сделал и у меня не заработало.

мож такое только у меня.

 

DSM 6.1.7-15284 Update 3

Link to comment
Share on other sites

В 24.05.2022 в 23:23, bilalline сказал:

DSM 6.1.7-15284 Update 3

Чет в памяти отложилось, что на 6.1. не поддерживается больше. Могу ошибиться.

Link to comment
Share on other sites

5 часов назад, Olegin сказал:

Чет в памяти отложилось, что на 6.1. не поддерживается больше. Могу ошибиться.

Заработало!!!

Итак, плюс к моему предыдущему сообщению по сене API с версии 01 на 02 сделал еще

sudo mv /etc/ssl/certs/ca-certificates.crt /etc/ssl/certs/ca-certificates.crt.bak && sudo curl -Lko /etc/ssl/certs/ca-certificates.crt https://curl.se/ca/cacert.pem

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...