Jump to content
XPEnology Community

MAC address Workaround


Recommended Posts

It seems one of the biggest headaches when installing Xpenology is centered around matching the MAC address(es) in the vender file (or GRUB kernel line) to your installed NIC(s). If the addresses don't match, Synology Assistant can't make a connection and the installation aborts. But what if you don't know your NIC's MAC address?


Fortunately, there is a simple workaround. Set the MAC address in the vender file (or grub.conf) to ffffffffffff, When the install boots, networking will use the MAC address of the installed NIC and the installation completes without complaining.


@Trantor: Thanks for all your efforts! If the MACs in the vender file you provide were set in this manner it would save a lot of headaches and questions.

Link to comment
Share on other sites

I have had no issues with MAC address


Easiest way I found is


Make usb stick


Pop it in and boot up


Install xpenology pat file




Once up and going, ssh into box and use dmesg output to find your REAL MAC address


Then edit the grub.conf file on the usb stick to reflect the real MAC address



Vi /volumeUSB/......./boot/grub.conf


Change the number of interfaces MAC address's and serial


Save and reboot


Then ssh back in and edit both synoinfo.comf files to your liking

For wake on LAN and number of internal/usb/esata ports etc


And your away and going



Link to comment
Share on other sites

My issue was Synology Assistant wouldn't let me install the pat file due to connection errors.

No install = no known login from the console, ssh not enabled, etc.

This precludes the suggestions above.


However, since I had a console, I press 'e' at the GRUB boot screen. Delete hw and vender lines and add mac1=ffffffffffff to the kernel line.

Boot and now I can install the pat and try some of the suggestions above.

Link to comment
Share on other sites

Thank you for the tip :smile:


If I remove the vender file and add sn=xxx in grub, Synology Assistant show empty sn :sad:


Any idea ?


I am able to add sn= to grub and it shows in Synology assistant.

Using SA 4.3-4359


My grub modification



Link to comment
Share on other sites

@gnoboot : How did you managed to remove the vender file and get sn working ?


As I said above if I remove the vender file and put sn in grub, sn is not showed (dsm and Synology Assistant) :sad:


You need to patch /etc/rc.network in hda1.gz as well, and stick the sn GRUB option as per don389.

Link to comment
Share on other sites


  • Create New...