FlorisVN

changel diskstation model of Jun's bootloader Xpenology

Recommended Posts

Hi All,

I have been testing Xpenology on my spare DS1511+ diskstation, and so far it run's great !

But I want to change the model of diskstation (DS3615xs) to a more close and accurate model, like a DS1513+ 1515+ or 1517+.
I can't find info on how to do so..
Something i read, was that I had to change GRUB Stage 2 or something, but i really don't know how to do it..

I have tested and changed the model code in the grub config file, but that was not enough..

can somebody here help me.. ?

Thanks in advance,

 

Floris

Share this post


Link to post
Share on other sites

every model comes with its own (~200MB ) *.pat file to install and gets its own set of kernel, drivers, ..., the hack jun created is specific for that model so if you want a different model you would need a different kernel and pat file and a newly matched hack, as jun is the only one with the code (and the knowledge) there is no way of adapting, even if you manage to change the model in bootloader you would end up with a dsm with working protections preventing you from using it on non synology hardware

Share this post


Link to post
Share on other sites

In short not possible unless you have same similar skills than Jun and can recreate a hack enabling you to do what you want to do,

Share this post


Link to post
Share on other sites
Posted (edited)

aah ok,

Unfortunately this is not possible then, I hope that Jun can maybay create an DS1517 or DS1515+ version of his bootloader.
Maybay I can write an e-mail to him, and ask him...

He also made an DS916+ version.. ?


Or he is also active on this forum I guess.. ?

 

Thanks for your answers so far btw..

Edited by FlorisVN

Share this post


Link to post
Share on other sites
Posted (edited)

he already commented he will not do more models

btw top priority would/should be a model with a newer kernel (4.4 instead of 3.10.102, Broadwellnk, Apollolake) like the 918+ or 3018xs

 

lets see what happens when 6.2 comes out, if we are in luck and he already has to do a hack, maybe he replaces the 916+ by 918+ (at least that's what i hope), or maybe the good old 3615 is not getting support in a while and has to be "replaced"

don't push it, its not going to work that way

Edited by IG-88

Share this post


Link to post
Share on other sites

ok,

Thanks for your message I understand.
I don't want to push anybody here :)

 

Main reason why I actually want another type of diskstation is because I want to test if my DX510 expension Unit can be made compatible.. ?
Last time I tried with the DS3615XS my DX510 expansion Unit was not visible nor available in DSM.
I know officialy it's not supported, people got it working on the DS1518+ for example..


maybay some modding is needed in the syno config files.. ?

Maybay some of you guys, can help me out with this.. ?
That would be great...

Best regards,
 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, FlorisVN said:

Last time I tried with the DS3615XS my DX510 expansion Unit was not visible nor available in DSM.

 

are you sure you connected it on a sata port supporting sata multiplier?

synology did use sil chips in the past, not sure what they use now

Edited by IG-88

Share this post


Link to post
Share on other sites

Hi,

Yes indeed I have connected it like normal to my DS1511+.
And it uses SIL chips indeed..

Maybay there is a way to make the DS3615XS model, to see the DX510..
That would be awesome.

The DS3615XS is totally not officially compatible with the DX510 nor the DX513, so modding is needed..

Anybody knows how to fix this.. ?

Share this post


Link to post
Share on other sites

never had a original expansion unit (to expansive), i was trying to use esata and 3rd party external port multiplier to get more disks to my 509+

looks like there is lots of splitting with generations and consumer/business

https://www.synology.com/en-global/knowledgebase/DSM/tutorial/Compatibility_List/Which_Synology_DiskStation_RackStation_can_I_use_with_Synology_Expansion_Units

as the scenario i kind of exotic (expansive syno expansion, cheapo xpenology) i would not hope some one will work out a solution

my advice, if you cant figure it out by yourself sell it and use the money for extending the old way like bigger case or external unit with sas (some people trying >40 drives seemed to have used sas expansions), but i guess as long as its max. 24 its cheaper to use one big case, onboard + 16 port controller and connect disks by sata, even 45-60 is possible in a 19" case (-> backblaze storage pod's, open design)

 

Share this post


Link to post
Share on other sites
Posted (edited)

hi,

Thanks for your message.
I understand..

I have one last attempt I want to try, that might give me succes.
I have tried running the DS916 bootloader, since the DS916 might work with the DX510, since it officialy works with the DX513.
(others got the DX510 working with the DS1817+ for example)

However, i'm getting error (13) that the there is corrupution, and I can't install DSM at all to test it..
I have looked this error up here om the forums, and found that I need to change PID/VID values in the grub configuration file.
I have changed those, but still i got the same error.

Is there another way to fix this ?
That would be great...

Thanks again for your help !

Edited by FlorisVN

Share this post


Link to post
Share on other sites

make sure your destination disk is empty (remove all partitions)

double check an the vid/pid

you could try the install for testing with the 3615 to be sure its nothing special about the 916+

 

Share this post


Link to post
Share on other sites

hi,

thanks for your message.
I know 3615 works fine, have tested it.

The destination disk was indeed not empty, will do that also and clean it first.
(it was asking for migration during the setup wizard)

 

I will test it again tommorow, thanks for your help !

 

Share this post


Link to post
Share on other sites
Posted (edited)

unfortiontly it did not work the second time.
I have completely wiped the HDD, but got same error (13)

Please see provided screenshot, for more details.
(language is in dutch)

I have changed the PID/VID of my own stick in the grub config file,  please see my example below :
Is this correct ?

set vid=0x0930
set pid=0x6544
set sn=1230NZA123456
set mac1=0011360E80D1
set rootdev=/dev/md0
set netif_num=1
set extra_args_916=''

Please see te following 
Flashdrive Information Extractor rapport : 

Volume: E:
Controller: SSS BE
Possible Memory Chip(s): Not available
Flash ID: 983A98A3 7651
Flash CE: 1
VID: 0930
PID: 6544
Manufacturer: TOSHIBA 
Product: TransMemory 
Query Vendor ID: TOSHIBA 
Query Product ID: TransMemory 
Query Product Revision: 1.00
Physical Disk Capacity: 15500574720 Bytes
Windows Disk Capacity: 16417792 Bytes
Internal Tags: 396H-QAH4
File System: EXT2
Relative Offset: 31 KB
USB Version: 2.00
Declared Power: 200 mA
ContMeas ID: 26AA-01-00
Microsoft Windows 10 x64 Build 16299

 


How can this be fixed, so I can run the DS916+ , the DS3615 works just fine btw..
i don't understand :S

 

 

Thanks again for all the help.

dsm error (13).JPG

Edited by FlorisVN

Share this post


Link to post
Share on other sites

please, has anybody got an idea how to fix my problem.. ??

Thanks in advance,

Share this post


Link to post
Share on other sites
On 3/20/2018 at 3:56 AM, IG-88 said:

the only thing i can think about might be the wrong pat file

but i guess you already checked this

https://usdl.synology.com/download/DSM/release/6.1.5/15254/DSM_DS916+_15254.pat

 

 

If it was the wrong pat file the error would be different. This is a vid/pid error.

 

@FlorisVN You might want to double check your vid/pid. If you check and it still doesn't work try a different USB key and make sure to edit vid/pid again. Also make sure to use Win32DiskImager and not some other imaging software.

Share this post


Link to post
Share on other sites

@IG-88

Thx Yes, I have tried with that .Pat file, aswell as let DSM download the latest version trough the installation wizard.
Both ended with same error.

@Polanskiman

Thx, Yes I have tried another USB Stick, a Kingston this time.
But got same error. (13) files are damaged.
And yes I have used Win32DiskImager..

I have changed the PID/VID values in the Grub config file,

This USB stick has the following PID/VID values, acording to usbflashdrive info program :
VID: 0951 
PID: 1665

So I have changed the following in the grub.cfg file : 
set vid=0x0951
set pid=0x1665


Have I done something wrong here ?
How can this problem be fixed, So I can install DSM successfully..

Hope someone can help me out here, thanks in advance,

 

 

Share this post


Link to post
Share on other sites

i don't think it will make a difference but try another usb port?

Share this post


Link to post
Share on other sites

@IG-88

Thx for your message, yes indeed I have tried different USB ports, but no good result..

Anyone else got a fix for me ??

Share this post


Link to post
Share on other sites
On 21/3/2018 at 5:04 PM, FlorisVN said:

@IG-88

Thx for your message, yes indeed I have tried different USB ports, but no good result..

Anyone else got a fix for me ??

Same problem here. Any solution yet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now