Jump to content
XPEnology Community

Moniteur de ressource


Guest MPaladin
 Share

Recommended Posts

Guest MPaladin

Bonjour,

 

Je suis sur Xpenology non virtualisé, en verion 4.3-3810

Le moniteur de ressource ne fonctionne pas

 

en fouillant un peu, je m'aperçois qu'il y a un problème avec snmp

 

monNAS> /usr/syno/etc/rc.d/S96synosnmpcd.sh restart

Stoping Synosnmpcd
Starting Snmpd
/usr/syno/sbin/snmpd -Ln -c /usr/syno/etc/snmpd.conf -p /var/run/snmpd.pid udp:161,udp6:161,tcp:161,tcp6:161
Segmentation fault (core dumped)

Starting Synosnmpcd

 

même si j'execute le fichier tout seul, c'est pareil

monNAS> /usr/syno/sbin/snmpd
Segmentation fault (core dumped)

 

Avez-vous été confronté à ce problème ? Je ne trouve aucune solution nulle part.

 

ma version :

monNAS> /usr/syno/sbin/snmpd -v

NET-SNMP version:  5.7.1

 

J'ai vu sur le site net-snmp qu'il est maintenant en version 5.7.2, dois-je faire l'upgrade et si oui, comment à votre avis ?

Link to comment
Share on other sites

Hello

je ne sais pas si c'est le même problème mais je te donne quand même cette info.

Pour ma part, j'ai installé CACTI (pour faire du monitoring + évolué/paramétrable que celui du DSM). pour cette utilisation, j'ai du installer net-snmp (via les packages ipk) et après le moniteur de ressources ne fonctionnait plus.

voici la solution http://forum.synology.com/enu/viewtopic ... 07#p221518

 

Ca ne semble pas exactement le même pb (pour moi le snmpd natif semble tjs fonctionner). As tu effectuer qqe chose qui aurait corrompu cette application (genre le remplacer par un + récent...)

 

Bon courage

Link to comment
Share on other sites

Guest MPaladin

J'ai lu effectivement ce topic, j'ai cherché dans cette direction mais rien sous ipkg et en plus le killall ne fait rien pour la simple et bonne raison que le service ne démarre même pas, ni au démarrage, ni avec un restart

 

Dès mon installation il ne fonctionnait pas, je n'ai rien changé d'autre

 

J'ai installé celui par ipkg, j'ai essayé de faire pointer le script de démarrage vers le snmp installé par ipkg, ça n'a rien changé je l'ai donc désinstallé et je suis revenu à la situation d'origine

Link to comment
Share on other sites

  • 2 weeks later...
Guest MPaladin

[   21.488037] snmpd[9123]: segfault at 0 ip           (null) sp 00000000fff4232c error 14 in snmpd[8048000+5000]
[   23.876002] EXT4-fs (sdu1): mounted filesystem without journal. Opts: nodelalloc,synoacl,data=ordered,oldalloc
[   24.146011] eth0: no IPv6 routers present
[   34.124426] snmpd[9891]: segfault at 0 ip           (null) sp 00000000ffec4b4c error 14 in snmpd[8048000+5000]
[   34.240118] synosnmpcd[9896]: segfault at f2e3dfaa ip 00000000f2e3dfaa sp 00000000ffb0fff0 error 14 in libhwcontrol.so.1[f6af8000+13000]

 

Ca ne parle à personne ce genre d'erreur sous dmesg ?

Link to comment
Share on other sites

 Share

×
×
  • Create New...