Jump to content
XPEnology Community

N54L with Xpenology DSM 4.3 + 5-bay eSata enclosure ?


Recommended Posts



I have trouble to get working with an external eSata 5-bay enclosure.


First I tried a Lian Li EX-503 (with JMicron 393 Chipset) at the eSata Port from the N54L. Clean Modus, each drive should be separatly visible. I'm using modded BIOS so I think eSata Port Multiplier is enabled, but it seems it doesn't work.

Standard settings was: esataportcfg=0x1000, internalportcfg=0xfff, usbportcfg=0xffe000 --> Only the first HDD from the Lian Li EX-503 was recognized, but as SSD, not as HDD. Also as Drive 5, not as Drive 6. (I using 4 drives + 1 drive in the ODD slot. They are recognized as HDD 1-4 and 6)

I changed settings to esataportcfg=0x30/esataportcfg=0x20, internalportcfg=0xf, usbportcfg=0x1fc0 --> Only the first HDD from the Lian Li EX-503 was recognized, now as eSata, Drive 5.

Then I changed settings to esataportcfg=0x10, internalportcfg=0x2f, usbportcfg=0x1fc0 --> I' sure this settings are correct, but if Lian Li EX-503 is on and connect to N54L, the N54L doesn't boot anymore!



Ok, I think Port Multiplier isn't working, so I buyed a Hantz Edgestore Das501t 5bay eSata enclosure (with a Sil Port Multiplier Chipset) and a PCI-e eSata Card (with Sil3132).

Lian Li EX-503 + PCI-e eSata Card (with Sil3132): No added drives are visible in DSM storage manager.

Hantz Edgestore Das501t + PCI-e eSata Card (with Sil3132): No added drives are visible in DSM storage manager.

Settings are still esataportcfg=0x10, internalportcfg=0x2f, usbportcfg=0x1fc0



Can anyone please help me?

Link to comment
Share on other sites

  • 2 weeks later...

I have not been able to make my 5-drive esata enclosure working on N40L.


From the on screen message, it seems that the system recognizes the port multiplier, but won't allow connection. The conspiracy devil on my shoulder told me that Synology only wants people use their expansion units, like this one:


http://www.amazon.com/Synology-Plug-n-U ... B003DTLXKG


Anyone wants to give it a try?



[EDIT. add expansion cable details]

From Synology's product page:


...The Synology DX513 securely connects to the Synology DS1512+ via an eSATA cable of specially-designed connectors on both ends to ensure maximum throughput. ...


So, the unit is connected by some type of eSATA cable, but the connectors on both ends are changed.

Link to comment
Share on other sites

I saw a thread from synology forums before. Synology users tried to remove the limit on Synology only esata unit. The posts are beyond my current understanding. But it might have useful information that kernel builder can use:


http://forum.synology.com/enu/viewtopic ... 12&t=66228


One of the post points to libata:


  tf.feature = reg & 0xff;
  tf.hob_feature = (reg >> 8) & 0xff;
  tf.device = link->pmp;


and said it has been changed (over different version, maybe??) from:

tf.feature = reg;
tf.device = link->pmp;


Another mentioned he compiled a kernel with a patch libata-pmp.c . but did not specify what he had changed.

Link to comment
Share on other sites

  • 6 months later...

I'm also hot after getting xpenology to work with a port multiplied enclosure. I have an n54l and a sans digital tr4m+bnc w/same drives, same size - they would make a great pair (sans digital for attached backups) but the synology code seems to be shutting me out of what otherwise would be perfect combo.


Hopefully someone can figure out some sort of mod to get this working at some point.

Link to comment
Share on other sites

  • 5 months later...

I am able to use the N54L onboard eSATA's port multiplier connected to my Cineraid 4 bay right out of the box with Xenserver used as a hypervisor. I do have the bios mod installed as well.


I'm using Xenserver 6.5, and have successfully added 4 additional local disks from my Cineraid box to my Xenserver base install. Xpenology 5.1 is loaded as a VM and can utilize up to 2 of these disks right now. The main problem I am having right now is since the N54L does not support IOMMU I can't pass-through the sata disks right to Xpenology, which I posted about in another thread:




Getting around this current pass-through limitation I think would set everyone home free to use the onboard eSATA port.....

Link to comment
Share on other sites

  • 2 years later...

I've not tried using a port multiplier on a microserver but have on bare metal, with no success.

I don't think this this is a limitation of DSM/Synology but how the sata controller drivers work in xpe

for example, I have a jmicron 5 port multiplier and xpe/dsm only sees the drive on the first channel of the 5 port unit. I think this is because the multiplier is based on 'cascading' the sata controller chips and the channels on the cascaded chip are not seen by the drivers. I had the same results with a marvell chipset port multiplier too 

Link to comment
Share on other sites

Thank you svb3000!


That's frustrating. As far as I was able to find out, the problem is on the side of Xpenology boot loader which is unable to present the port multiplier in a way that DSM would get it. I've read that people managed to get it working if Xpenology is running under a Xen server. But that brings some performance drawbacks when transcoding. Also remote start/shutdown gets complicated this way.


If you want, please support me at drivers request for xpenology here:


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...