Jump to content
XPEnology Community

[SOLVED] Connectivity loss when getting files out of NAS


Recommended Posts



I really need the help of the community, as i am unable to solve it after many tries.


My config:

  • - MB Asus E35M1-Pro, 4GB RAM, 4x4TB WD Green in RAID5.
  • - The NAS is connected to my main PC by a simple 5-port 1GBE Netgear switch ($20 device).
  • - No jumbo frame
  • - WOL activated by applying this forum method: doing in rc.local a "ethtool -s eth0 g" or something like that + changing synoconf by adding "g" option where it is needed.


What happens:

  • - I am able to move TB of data to the NAS. I thus moved there all my movies & photos (total 7 TB).
    • * I consider my CAT5 ethernet cable, and Netgear switch are ok.

  • - I am unable to do the reverse. When copying a movie from the NAS to whichever of my PC, i lose connectivity: "ping -t @NASIP" shows that the NAS stops answering, and then 5 to 10s later i comes back :cry: . When this happens, the NAS seems to restart all network services, including SAMBA. I see that in log files.


What i tried to solve/diagnose:

  • - I was in DSM 4.2 at first.
    • * I then tried to restart the samba service, but it does not work.
    • * Restart of NAS has no effect either.
    • * I tried to de-activate all services but samba (just in case...), no change.
    • * Tried to activate jumbo frame, no effect.
    • * Tried to de-activate "SMB2 large MTU", but no change
    • * Tried to get the content via FTP: no change, it also loses connectivity!!
      => Here, i concluded it was not an problem from Samba, right?
    • * Tried to do the copy action with network share using admin credentials (also just for the sake of it), no effect.


  • - I then did a leap of faith and i upgraded/migrated to DSM 4.3 hoping it would solve my problem (for example thanks to a NIC driver update within the kernel): no change, even though DSM4.3 does format system partition and is re-installing the system. BTW, i confirm it does not touch data (/volume1) :smile:
    • * First conclusion: as DSM4.3 reinits all config from scratch, it was not from a config issue in my DSM4.2, right?


  • - I wiped out the DSM4.3, without losing the /volume1 data, and re-installed the DSM4.3: no change even with a fresh install (thus not applying any of additional configuration above the default install one).
    • * I concluded it does not come from one of my change of parameters within the DSM Manager: i did none after the install.
    • * BTW, FYI, to wipe out DSM4.3 without losing data, i experimented first on a Virtualbox VM. It appeared that by doing "rm -rf" on a certain list of directories (of course not /volume1), i was able to force Syno Assistant to re-format system and re-install DSM4.3 total fresh. :idea:


The only thing i did not do yet: install DSM4.3 update4 (tried to do it just once via the update page in the DSM Manager, and it failed).


I must say i have no more idea. Please help..?? :cry::roll:

Edited by Guest
Link to comment
Share on other sites

in my last try "wiped out DSM4.3" it was re-install, in the sense that Syno Assistant displayed it was formatting the system partition during the .pat deployment.

However, i did not wipe the /volume1 partition. I saw there were other config DSM files (mysql or something) in /volume1, but this i did not try to delete... Maybe i should try on my VM first and see if 1) i can do it safely and 2) it changes something later on.

Link to comment
Share on other sites

I just tried to go further in DSM4.3 wipe out. I removed "rm -rf @*" files within the /volume1, additional to other directories above. I then re-installed DSM4.2 (so downgraded). I did not lose the /volume1 data. I will thus try that later on with my real NAS. Will see if it solves the issue. I fear it won't... (pessimistic). I think i am going to google on "regular" linux forum to see if it happened for somebody else. I start to think this is not synology related.

Link to comment
Share on other sites

I have more or less the same problem

I can copy data to the nas, but when streaming media it looses connection (both on pc and xbian on raspberry pi)

So I'm watching a serie or a movie (doesn't matter if it's SD or HD) and the playback just stops, If I'm copying at that moment, then that will stop to


I have it running on an e35m1-m, so I see a common denominator here

Link to comment
Share on other sites

Exactly. This is how i discovered the issue initially: XBMC stopping playing a 1.2GB MKV movie. When looking at why i understood the issue.

I think i might purchase on amazon a separate NIC card, and if it does not solve then to return it. If solving, then keeping it.

I start to believe it comes from the NIC in the motherboard, so i have no other clue.

And now that all my 7TB collection of movies/shows/photos is in the NAS, and that i can not recover them due to this issue, i am stuck with it.

Link to comment
Share on other sites

Photos are backed-up, but they represent only dozens of GB. 90% of my 7TB is not backed-up (movies, shows, documentaries...).

This is why i always tried my tests on a VM first to reset/wipe-up the DSM install without losing data.

If i lose my media, my wife will kill me :smile:


The more i think about it, the more i am going to try to purchase a discrete/separate NIC card.

Bolle's feedback above is striking.

Link to comment
Share on other sites

Have you changed any network settings... Like jumbo frames etc?


What happens when you try a different transfer method? Eg use FTP instead of smb?



If FTP works fine for downloading multiple TB's then the network card / driver is not your problem.... Either samba or a setting in samba is related.


Failing that, buy a cheap ( not cheapy ) say intel CT card ..... Known good cards for about $28 ....

Pop that in, disable the one you have now in bios

Search dmesg output and find your NEW MAC address


Apply new MAC address as you did the old network adapter.


Test again.



Link to comment
Share on other sites

I've been thinking the same, but all the pc-shops in my neighbourhood only have cards whit a realtek port

So I'm still searching for a decent card


I've had to reinstall a couple times before I could copy without connection loss, and now It's still only at 20MB/s (even from USB)

also copying over lan is limited to 20MB/s (gigabit switch and cat5.e cables) both read and write, but reading stops very quick


I'm now running XPEnology DS3612xs DSM 4.2 build 3211++ (repack v1.2) from trantor

Link to comment
Share on other sites

Another option is to try a different LAN cable


I have had some mighty weird shit go on due to a flaky LAN cable.


Eg by mighty weird shit ....an example is


I can transfer multiple ISO files over from one box to another.... Multiple sizes etc.....but it would not transfer ANY ISO that were Microsoft.... Eg winxp win7 win server etc


Totally stumped me for days..... Swapped a different cable... And could transfer all ISO's over.

So yeah weird shit can happen.



Link to comment
Share on other sites

Well, it worked ! :smile:


The new additional NIC on PCIe port was automatically considered as eth0, and the embedded one changed to eth1.

As i switched the cable from the embedded to the Intel PCI card, the Syno assistant detected 2 NAS: "diskstation" with status offline on the embedded port (not connected to network) and the "NAS" hostname on the intel port.

The intel nic was attributed the synology mac address that was previously on the embedded port, and thus it automatically got the same IP address from my router.

All fine with no effort!


I immediately tested copying 10GB of data from the NAS to the PC, and worked perfectly. Hip, hip, hip.


I just needed to use a ubuntu live usb key to catch the real Intel card MAC address so that i be able to use WOL. Bad luck that this mac address was not printed on the sticker on the intel card.


I spent a lot of time on this problem, and 7 euros to purchase the second-hand Intel card, but i am happy to have closed the issue!

Link to comment
Share on other sites

  • Create New...