XPEnology DS3612xs DSM 4.1 build 2668


Recommended Posts

http://yadi.sk/d/BvxkaDfm1SuIO

 

This archive have three files:

synoboot.img - Image file of synology boot disk (Use RAW-COPY tool to create the USB stick http://hddguru.com/software/HDD-Raw-Copy-Tool/)

synoboot.vdi - VirtualBox boot disk.

DSM_DS3612xs_2668.pat - xpenology DS3612xs software installer.

 

Any question - welcome to thread !

 

P.S.

For VirtualBox and other VM !!!

Don't forget to set MAC address of Network Adapter1 in virtualbox "00113208D62A".

 

Tested hardware:[table=600,1][tr][td=300,white]

MB model

[/td][td=90,white]

Network

[/td][td=90,white]

SATA

[/td][td=90,white]

USB

[/td][/tr]

[tr][td=500,white]Asus E35M1I Mini-ITX AMD[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]ASUS P8H67[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]ASUS itx-220[/td][td=90,white]

+

[/td][td=90,white]

-

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]ASUS P8Z68-M PRO[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Asrock E350M1[/td][td=90,white]

+

[/td][td=90,white]

-

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]ASRock Fatal1ty Z68 Professional Gen3[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Asrock AD2700-itx[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]ASRock Z77 Pro4-M[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]ASRock Z77 Extreme 6[/td][td=90,white]

-

[/td][td=90,white]

-

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Gigabyte GA-X79S-UP5[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Intel DQ45EK[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Intel DQ45EQ[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Intel DZ68BC[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Intel BLKD525MW[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Foxcon H67S[/td][td=90,white]

+

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][tr][td=500,white]Zotac IONITX-P-E[/td][td=90,white]

-

[/td][td=90,white]

+

[/td][td=90,white]

?

[/td][/tr][/table]

 

Please send me test reports !

Link to post
Share on other sites
Virtualbox only say loading kernel ?

 

Any help ?

 

And thanks :mrgreen:

 

It's working OK, once you get the message loading kernel message, you have to run Synology Assistant in other computer connected to the same network, the assistant will detect your boot.

 

Now you only need to follow the instructions: viewtopic.php?f=2&t=3

Edited by Guest
Link to post
Share on other sites

Hi Andy,

 

Just wondering if this is only compatible with Intel, I've been watching the qnap forum for a while, hoping someone brings this fantastic software to HP N40L with AMD RS785E/SB820M chipset (a fantastic and cheap microserver)

 

I tried it in a Virtualbox, but the real goal is to have it installed directly to have all resources available.

 

For now, all the leads tell me that this is not possible, but I just want to be sure before giving up on this :D

 

Thank you

Link to post
Share on other sites
XoN said:
Hi Andy,

 

Just wondering if this is only compatible with Intel, I've been watching the qnap forum for a while, hoping someone brings this fantastic software to HP N40L with AMD RS785E/SB820M chipset (a fantastic and cheap microserver)

 

I tried it in a Virtualbox, but the real goal is to have it installed directly to have all resources available.

 

For now, all the leads tell me that this is not possible, but I just want to be sure before giving up on this :D

 

Thank you

 

The software working on my amd machine. Motherboard is an Asrock E350M1.

I also have a HP Microserver.

Link to post
Share on other sites

Hi and thanks, Andy, for making this possible.

 

I am running XPEnology on Intel BLKD525MW (Atom D525, NM10 chipset), SATA OK, network OK.

 

Restart/shutdown doesn't work (it shuts down, but after boot when logging in to DSM it writes "System is upgrading" instead, so I have to shut it down forcefully by holding the power button)

USB drive shows as internal (so no eject choice)

Tried USB WiFi dongle (EW-7811Un) and it works well, shows as wireless network and connects to it

 

How about using two or more XPEnologys on the same network? They all have the same MAC, right?

Link to post
Share on other sites

Tested xpenology on Asus E-350m1-m (direct on hardware, not vm). Working 99% usb ok, sata ok, network ok. Only problem is memory. I got 8 Gb ram and it only report 4 Gb. Is it possible to get an lsi 9260-8i raid adapter to work on this image?

Link to post
Share on other sites

Andy, thank you very much for sharing this work with us and for creating a board - XPEnology ROCKS :mrgreen:

 

I am running Xpenology as VirtualBox VM. No problems so far, everything works as it should.

 

Tried to do a manual update to latest beta version DSM 4.2 which aborts with a Error 21.

Tested using this file: http://ukdl.synology.com/download/beta/ ... s_3161.pat

 

Do I need to modify the file so that it can be used for XPEnology, or is there another problem?

Link to post
Share on other sites

Hi, Tried XPEnology yesterday. Very well done. All good on VBOX.

 

Tested on two MB's to see if the assistant can see it on the LAN before install, results as follows....

 

Gigabyte GA-X79S-UP5

- Built in 1GB Intel LAN : OK

- Intel X520-T2 10GB Card : Fail

 

ASRock Z77 Extreme 6

- Built in LAN : Fail

- Intel X520-T2 10GB Card : Fail

- 3Com 3C1000BT Card : Fail

- Realtek 8139D Card : fail

 

 

Any idea about the built in LAN for the Z77 board above? Also what 10GB network cards would work with the XPEnology? Could you get it to work with the Intels above, is it a fairly easy task? Happy to donate if get it working!

 

Kind Regards, and great work. Much appreciated!

Link to post
Share on other sites

I was testing it on a Dell Poweredge 850 Server with extra Bulid in Intel 1000 Pro NIc , now the synlogy assist. find the Server but no way to get the software installing , every time error . I think the Sata Ports didn´t work. On A HP Compaq 8510p laptop all works fine to 99% , only the shut down / reset didn´t work.

Link to post
Share on other sites

Andy, thank you very much for all your work!

 

So far, I have tested XPEnology DSM 4.1 build 2668 with the Zotac IONITX-P-E motherboard with Ion chipset/sata-controller (AHCI) and Realtek RTL8211CL gigabit ethernet.

 

When using the onboard Realtek RTL8211CL ethernet controller, the XPEnology is not recognized by Synology Assistant.

When connecting an Intel 9301CT (82574L) PCI-E ethernet controller, everything works fine.

 

I will test with more motherboards and report back.

 

Perhaps it would be a good idea, to include ethernet model/chip and sata-controller model/chip in the table of tested motherboards:

http://wiki.xpenology.hostteam.hu/index ... therboards

Link to post
Share on other sites

Works! :grin:

 

I have installed Openmediavault on my N36 HP microserver 8GB. Same like the HP N40 but with slower cpu.

Easy install of virtual box via the extra plugins (check forum omv). After that followed the instructions here.

Worked like a charm. Only some problems with choosing the right networkadapter and some useright problems with debian (hostsystem openmediavault).

Now i have an installed openmediavault server with a virtual xpenology server via VB.

See how in with run the next week

 

Waited a long time to get this....

 

Thanks

Link to post
Share on other sites

Andy,

perhaps you could list the included and loaded hardware modules in the USB boot drive? That way we get an idea of which hardware should work...

 

What modifications did you make to the software? What did you add?

 

Can you provide instructions to make/compile our own version from the synology source code?

Link to post
Share on other sites
Virtualbox only say loading kernel ?

 

Any help ?

 

And thanks :mrgreen:

 

It's working OK, once you get the message loading kernel message, you have to run Synology Assistant in other computer connected to the same network, the assistant will detect your boot.

 

Now you only need to follow the instructions: viewtopic.php?f=2&t=3

 

Big thanks for the info now installing & formating hdd :smile:

 

Device Info

http://de.msi.com/product/nb/X340.html

 

All working fine on my latop :wink: Thanks :lol::lol:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.