likeadoc

Members
  • Content Count

    27
  • Joined

  • Last visited

  • Days Won

    5

Everything posted by likeadoc

  1. @Vikarowitsch 1) delete /usr/syno/bin/synocodectool & /volume1/@appstore/VideoStation/bin/synocodectool 2) download https://github.com/likeadoc/synocodectool-patch/blob/master/synocodectool/original/synocodectool.6.2.1-23824-0_6.2.3-25426-3.original 3) rename it to "synocodectool" (without quotes) 4) copy the file to /usr/syno/bin/ & /volume1/@appstore/VideoStation/bin/ 5) apply patch for both copies (./patch.sh -p)
  2. @Vikarowitsch seems like something went wrong with patching - easiest fix is to just download the original file from here and try patching it again:)https://github.com/likeadoc/synocodectool-patch/blob/master/synocodectool/original/synocodectool.6.2.1-23824-0_6.2.3-25426-3.original
  3. @richx if you only want to enable transoding in the moments app patching /usr/syno/bin/synocodectool should suffice. Patching /volume1/@appstore/VideoStation/bin/synocodectool enables transcoding capabilities in Synologys VideoStation application.
  4. Hey guys, sorry for being absent that long - I had a lot on my plate workwise - thank you @IG-88 & @flyride for keeping this topic active & supported! I just merged support for DSM 6.2.3 25426-2 into the github repo - there seem to be no changes to the synocodectool binaries in this update. @iamheresy this patch should work fine with the Moments app since it utilizes the synocodectool binary located in /usr/syno/bin (automatic heic conversion in the Moments app was the reason I wrote that patch in the first place:))
  5. @Napalmd if you plan to utilize surveillance station, then yes you should patch that one too - I updated the script on Github accordingly:)
  6. @tigs you should definitely be able to patch more than one version - you just have to do it one by one. if that doesnt work could you please send a screen grab ?
  7. @Tuonorosso no need to restore just download the new version and only patch /volume1/@appstore/MediaServer/bin/synocodectool The other versions (/usr/syno/bin/synocodectool and /volume1/@appstore/VideoStation/bin/synocodectool) are already successfully patched:)
  8. @tigs @mervincm @Tuonorosso I updated the patch to work with DSM 6.2.3 25426-0. I also added support for patching the third executable (/volumeX/@appstore/MediaServer/bin/synocodectool) - theoretically it should work now. P.S.: Could you run the following command BEFORE patching and post the output here ? I am curious to see which version of synocodectool the MediaServer application uses. sha1sum /volume1/@appstore/MediaServer/bin/synocodectool Cheers
  9. @jeannotmer you only need this patch if you are using moments or videostation AFAIK @Tuonorosso that is a little bit weird because both versions of synocodectool seem to be patched - I am going to need a bit more details - which DSM Version, serial number format ((e.g. XXXXPDNXXXXXX for DS918+, XXXXODNXXXXXX for DS3617xs, XXXXLWNXXXXXX for 3615xs), the output of sudo cat /var/log/messages after you went online and lastly sudo find / -name synocodectool to see if there is a third synocodectool executable that overrides those settings...
  10. @MitkoVIP @Tuonorosso @jeannotmer sorry for the late response... Did you apply the patch to both copys of synocodectool? Please kindly provide the output of the following commands: sha1sum /usr/syno/bin/synocodectool sha1sum /volumeX/@appstore/VideoStation/bin/synocodectool volumeX is the drive where VideoStation is installed Cheers
  11. @dyter this patch only enables you to transcode (in hardware or software) within videostation or moments - it does not enable hw transcoding in general. For HW transcoding to work you would need to have the appropriate drivers installed, only then /dev/dri will be populated.
  12. @richv31 I updated the repo - should work now:)
  13. yes - it does not make a difference if you run it inside a vm or bare metal
  14. Did you update to the the latest commit of https://github.com/likeadoc/synocodectool-patch/blob/master/patch.sh ?
  15. @Rezdbic what's the output of sha1sum /usr/syno/bin/synocodectool and, if you are using VideoStation, this (please substitue volumeX for the volume where VideoStation is installed) command? sha1sum /volumeX/@appstore/VideoStation/bin/synocodectool AFAIK 24992-6 does not include an update to synocodectool..
  16. @ruchechnik hi:) currently there are two versions of synocodectool: 1) /volumeX/@appstore/VideoStation/bin/synocodectool -> this one is specifically for video station, currently the patch only works if it is located on volume1... 2)/usr/syno/bin/synocodectool -> this one is for all other applications the patch script lets you choose which one you want to patch:)
  17. @kggitj I am still working on the new serial generator for 918/3615/3617 - unfortunately your script does not detect all possible valid serial numbers! I am currently a little bit stuck at reverse engineering the generation algo - I would appreciate if you could contact me again so I can share my findings with you and get a little help;)!
  18. @The_Dave Regarding HW transcoding - if all the other prerequisites are met( loader 1.04b & /dev/dri exists) then it activates hw transcoding for all synology apps (i.e. Moments, VideoStation, PhotoStation, AudioStation..) ------ Plex, Emby & Jellyfin should be unaffected by this patch since they don't use synologys license checking mechanism and come bundled with their own version of ffmpeg.
  19. @pasden Regarding the serial number. For 3615xs it should be XXXXLWNXXXXXX (so yours is RIGHT) Unfortunately I somehow mixed up the device identifiers for 3615xs and 3617xs on Github - but that should be fixed now! Btw I am currently working on creating a bash based serial generator for DS3615xs, DS3617xs and DS918+ because the one I found generates serials in the wrong format ( https://github.com/xpenogen/serial_generator ), but that is stuff for another topic
  20. @Polanskiman exactly! The patch patches a function in synocodectool that checks with synologys servers if the serial number is valid and prevents it from erroring out. I added multipatch support two days ago, so applications like videostation (which ship with their own version) can also be patched. You can choose which binary you want to patch from a handydandy little menu. Furthermore, I also uploaded all original & patched binaries going back to DSM 6.0 to my Github repository. Should ******* hit the fan you can either try restoring the app from the automatically created back