intrax

Members
  • Content Count

    30
  • Joined

  • Last visited

Everything posted by intrax

  1. Have a look at synoinfo.conf. I remember tried this sometime ago, but was not able to get it working... Look here:
  2. I have been following this thread from the start and big thanks to @ThorGroup , @haydibe , @pocopico , @jumkey and others ! @RedwinX Appreciate your efforts to have synology publish the kernel sources for v.7.0.1 I can tell you that I have tried in the past to have synology publish genuine kernel sources on sourceforge and that they have not done so alltough they are obliged to do so according to the linux gpl. I suspect their reason for not publishing or publishing incomplete non-compiling sources is to protect their business and prevent projects like RP to be suc
  3. Try this: https://forum.xda-developers.com/t/script-repack-zimage-sh-unpack-and-repack-a-zimage-without-kernel-source-v-5.901152/
  4. Try f11 at startup to select boot from usb...
  5. Probably a driver problem. Check the nic specs of the F2-422 as it's realtek and what driver is in the extra.lzma. Weird booting uefi, would think you have to boot legacy ! Also check your dhcp for problems.
  6. Follow this guide: https://forum.terra-master.com/en/viewtopic.php?f=21&t=1546
  7. Post a picture and try to reset bios. If not possible to boot legacy mode the bootloader must be installed on efi partition ! Doesn't look promising:
  8. @ausmann post ifconfig and bootlog pls ?
  9. Hi tiras, That model is clearly not working for you. Try model TS-977XU...
  10. Post dan auch mal deine model.conf !
  11. Die download link ist nicht verfugbar sehe screenshot ! Schon geschrieben ist eine arm version...
  12. https://download.qnap.com/Storage/TS-X85/TS-X85_20210107-4.5.1.1540.zip Checked.... Link is working !
  13. Wichtig ist es die richtige Adressen im model.conf file einzutragen und dann initrd neu zu generieren. Dann lauft alles prima ! In diesem Thread kann man finden wie man das macht. Da ist schon vieles druber geschrieben...
  14. Hi, The model type can be found in the model.conf file inside the initrd in the qnap firmware download... If you run tiny linux you can easily find it in /home/tc/etc. Bye
  15. QTS. Ok so you used the default linux git source ? I tried to download the QNAP sources from sourceforge https://sourceforge.net/projects/qosgpl/ , but afik they have not included kernel module sources and just put some files there to comply with the GPL licence. Big scam imo!
  16. Hi pocopico, I now have 4.5.1.1495 running on vmware workstation. The addressing for the sata disks in model.conf is very strange, apparently need both pci and sata addresses to be in there. Would be interested in the kernel tree creation process and where you got the sources as I have not been able to find them. A document would be much appreciated ! Thank you.
  17. You will have to compile a kernel module for your realtek nic and load it at startup (see pocopico's post in this thread about loading additional kernel modules). Howto: https://www.modio.se/installing-realtek-8821ce-driver-on-system-with-secureboot-enabled.html
  18. Take a QNAP model that is closest to your proc archtecture and number of disks (see Hemps comment above). After run ./my_create_qnap_boot the model file (model.conf) can be found in /home/tc/initrd/etc directory. Run lspci to check addresses of your ethernet and diskcontrollers and edit de model.conf file accordingly. It's important to put the correct addresses as this connects the qnap os to your hardware ! Save the changed model.conf file and run the re_packing script. It will recreate the initrd. If finished succesfully you can now boot the QNAP os (option-1 from bo
  19. You can login using: user: admin pw: mac addres all capitals no colons pls post your lspci and model.conf for future reference of instalation on proxmox...
  20. You have to put the correct pci addresses for your disks in the model.conf file and regenerate the initrd. Read this thread especially pocopico's posts . Post your lspci and model file...
  21. Great job ! Thank you for the add. modules. Your vmdk boots ok in vmware workstation and sata drives are recognised. I'm now trying to understand why my version doesn't (see my above post)...
  22. Hier ahnliche Resultaten mit 5.1 in vmware ws. Netzwerk funktioniert, aber keine Festplatte wurde gefunden obwohl ich doch die richtige lspci Adressen verwendet habe. Versuch mal eine 4.4.2 version. Die 5.1 startet nicht richtig durch weil es keine login prompt gibt am Ende. Bin schon mit diese Hack unterwegs seit 2018. Damals hat es hier nur mit ide Festplatten funcktioniert. Gruss aus NL ! Bye
  23. Schon... Hast du dich mal den Lizensefile angeschaut ?