swords80

Transition Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

8 Neutral

About swords80

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @kachunkachunk I'm having a look at modifying the 1.04B loader to see if I can do a couple of things: Support older CPUs, I can't see anything that Braswell has but isn't available on Sandy Bridge as an example, I've asked Jun too, but no reply yet. Trying to play with DSDT. Support setting MaxDisks, SataPortMap, Sas/DiskIdxMap and sata_remap as OVF properties (asked during import/changeable from UI later). Support an auto value for the args above (script that figures them out and reboots on change). Integrate VMware Tools in boot loader (needed to be able to do #2/#3/make it easier to find DHCP address). Another thing I'm thinking about is a SPK with a UI to change/update the boot loader. I'm able to mount it, so I could overwrite it too.
  2. Why don't you take my OVA with 918+ (6 posts up)? That works without doing anything on Haswell i3-4130. Deploy OVA, add existing disks/controller, find with Synology Assistent and click migrate, which will take you straight to 6.2.1 update 4. As a bonus you'll get VMXNET3 and PVSCSI (when using virtual disks) which will give you better performance. It already has MAC/SN set correctly, bootloader disk moved outside of the visible range, etc, there is nothing left todo, besides installing VMware Tools (link included in that post) and maybe updating apps.
  3. OVA for DSM 6.2-23739 Update 2 • DS3617XS • VM HW Level 10 (ESXi 5.5 or newer, only imports on 6.5 and 6.7, use OVFtool with --shaAlgorithm=sha1 to convert for 5.5 or 6.0) • PVSCSI • VMXNET3 https://mega.nz/#!M1kX0TjR!S87LHngw1C3wa3i-3p-r9WyWCmFO4A9t3THhMWeea_w All DS3617XS OVAs use Jun v1.03b bootloader, DS918+ uses Jun v1.04b bootloader. Some instructions for the Intel passthrough VIB above, it puts "8086 ffff d3d0 false" (ffff = wildcard) in /etc/vmware/passthru.map. Put it on a datastore and goto the shell: esxcli software vib install -v /vmfs/volumes/myDatastore/intel-passthrough-1.0.0-01.x86_64.vib --no-sig-check -f Or when you want the latest ESXi ISO with it integrated using ESXi-Customizer-PS, put in in a folder and add: -pkgDir C:\myFolder -nsc -force
  4. OVAs for DSM 6.2.1-23824 Update 4 • DS918+ (requires Haswell/Braswell or newer CPU) • VM HW Level 10 (ESXi 5.5 or newer) • PVSCSI • VMXNET3 https://mega.nz/#!slFUCIwT!QHzujgbJeGtMKE5W2pvg8UoK7T6TputqQwFZHuNhxmY • DS3617XS (requires hardware that's supported by default DSM) • VM HW Level 10 (ESXi 5.5 or newer) • SATA • E1000E https://mega.nz/#!5wlSQCLK!WHVVNloohedGa_nAB6pgPMvC-twWlR32arZ0JqaFMvM VMware Tools: https://mega.nz/#!Q1FGyAbY!lmrry2WXNd7Lp7AtSsrduPpnlWPzEpPV9L96jrZn6HQ Deploy OVF, add disk(s) or passthrough a controller, find with Synology Assist and click install. Optionally if you've got an ESXi enterprise license you can change the serial port to network, server telnet://:1024 and have remote telnet access. If you want to passthrough a Intel Controller that doesn't contain ESXi boot or a datastore install this VIB and restart: https://mega.nz/#!p0dAhYYb!7AWamOXE6y0z-PBlW4VqtS1gYNuw-uG-dKYTuyI5tQM By default it will work with any combination of one or two 2, 4, 6 and 8 port SATA/SAS controllers. Only when using two 8+ port SAS controllers or one 12+ port SAS/SATA, or more than two extra (so more than three if you count the SATA controller for synoboot) controller changes to SasIdxMap/SataPortMap/DiskIdxMap/MaxDisks are required.
  5. There seems to be something odd with 6.1.6, on a ESXi VM with DS3617xs the paravirtual controller and virtual LSI SAS controller don't load either: Loading module vmw_pvscsi[ 3.849379] general protection fault Loading module mptsas[ 3.997779] BUG: unable to handle kernel paging request