wolf7610

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About wolf7610

  • Rank
    Newbie
  1. Что за материнка? Не видится какой-нибудь определенный винт или винт, подключенный к какому-то определенному sata-порту? Подключаем 5 винтов - в биосе видно 5- в DSM видно 4 - отключаем любой из тех, что были видны в DSM (по серийнику посмотри), остальное не трогаем - загружаемся - сколько теперь видно в DSM?
  2. [spoiler=usb-hdd и флэшки определяются как ssd и требуют инициализации] *** SOLVED *** проблема решена. каким образом решали: в synoinfo.conf есть 3 параметра, которые в нашем случае играют роль - esataportcfg, internalportcfg, usbportcfg. в моем серваке - 8 внутренних sata (через lsi-92408i), 4 usb, esata нет. вставляем диски, в диспетчере хранения они показываются начиная с 7. т.е. первые 6 - хз что. всегда пустые слоты показываются. esataportcfg="0x0000" (т.к. у меня их нет) internalportcfg="0x3fff" логика следующая: "0x"-обязательный кусок ,ставится везде. "3fff" (в hex) = 11111111111111. это как раз мои внутренние hdd (8 реальных и 6 которые хз что). usbportcfg="0x3c000" логика следующая: "0x"-обязательный кусок ,ставится везде. "3c000" (в hex) = 111100000000000000. 14 нулей - порты занятые на hdd, следующие 4 - мои usb. итого выходит: Hi All, I think i know how to enable the eSata ports to behave as external ports now: http://forum.qnap.com/viewtopic.php?f=93&t=20661&start=270 i have a Sata to small form factor eSata bracket . 1) enable the SSH service and login to NAS through SSH. . 2) go to and edit /etc/synoinfo.conf (you can (must) also edit /etc.defaults/synoinfo.conf because idk what file is primary). For the N40l there is 6 ports, the internal ones are 1(left) to 4 (right). so is left 0 and 5 The easiest to identify the port number is to connect a disk on the ports, look at the port number in the storage manager and generate the masks as below: . internalportcfg="0x1e" = 1e (hex) = 00011110 (binary) = four internal SATA ports enabled (on mask 1-4) . esataportcfg="0x21" = 21 (hex) = 00100001 (binary)= two ESATA ports (0,5) (because 1-4 internal ICH9R sata ports). It seem to have been mentionned in the chinese forum here: http://xpenology.com/forum/viewtopic.php?f=11&t=632&p=1806&hilit=eSata#p1806 but could not translate the page using google or chrome for some reason...
  3. [spoiler=sdu]8099.957667] usb 2-1: new high-speed USB device number 3 using ehci_hcd [ 8100.098000] scsi8 : usb-storage 2-1:1.0 [ 8101.117467] scsi 8:0:0:0: Direct-Access Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 4 [ 8101.118496] syno_disk_type_get: disk driver 'usb-storage' [ 8101.119313] sd 8:0:0:0: [sdu] 15131636 512-byte logical blocks: (7.74 GB/7.21 GiB) [ 8101.119512] sd 8:0:0:0: Attached scsi generic sg10 type 0 [ 8101.119812] sd 8:0:0:0: [sdu] Write Protect is off [ 8101.119816] sd 8:0:0:0: [sdu] Mode Sense: 45 00 00 00 [ 8101.120315] sd 8:0:0:0: [sdu] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA [ 8101.125566] sdu: [ 8101.127562] sd 8:0:0:0: [sdu] Attached SCSI removable disk поменял usbportcfg="0xf000000" на "0xf000" - та же песня, тоже sdu, тоже определяется только как ssd.
  4. День добрый! Делал по этой же схеме (1х lsi 9240-8i, 8 дисков) с такими же настройками в synoinfo.conf. Внутренние винты все видит, а все usb-hdd и флэшки определяет как ssd и предлагает их инициализировать. Не сталкивались с такой проблемой?
  5. День добрый! Поставили Xpenology 5.0-4493 на стоечный сервак, 8 дисков по 2 Тб через LSI 9240-8i c it-прошивкой. Все определилось, поставилось, работает. Сначала виделось только 4 диска (определялись как в вебморде как диски 7-10) По инструкции viewtopic.php?f=5&t=3905 "В конфигурации через SSH сделаны следующие изменения: в файлах /etc/synoinfo.conf /etc.default/synoinfo.conf исправлены значения: maxdisks="22" esataportcfg="0x0000" internalportcfg="0x3fffff" usbportcfg="0xf000000" Диски все увиделись, но при подключении внешнего usb-hdd или обычной флэшки система воспринимает их как ssd и предлагает инициализировать. Может кто подскажет, в какую сторону копать?
  6. Hi everybody! I try to setup 7-BETA from Trantor (hba) viewtopic.php?f=2&t=1361&start=360#p12750 on my IBMx346 with ServeRAID-7k scsi adapter. Computer crashed after words : Autodetecting XPEnology RAID arrays. Scanned 0 and added 0 devices. autorun ... autorun DONE. Video : https://drive.google.com/file/d/0Bzs_u2 ... sp=sharing I tried other versions of XPEnology with this adapter and scsi disks and always got "Server error (Error 38)" (it's not real text, I saw it in russian ). I tried other versions with pata disks and installation was successful. I boot from Live-CD GRML (kernel 3.10) and I see this raid-controller with virtual disks. Dmesg from this booting is here: https://drive.google.com/file/d/0Bzs_u2 ... sp=sharing Can XPEnology GURUS help me with this problem? RHEL drivers for this controller : https://drive.google.com/file/d/0Bzs_u2 ... sp=sharing
  7. Да, пробовал.Там 2 загрузчика: hba (под sas/scsi) - с ним комп виснет при загрузке, второй загрузчик - без sas/scsi. с ним соот-но не видит raid-контроллер и винты.
  8. День добрый! Пытаюсь поднять Xpenology на железке IBM X346, scsi ultra-320 raid контроллер IBM Servraid-7k. Перепробовал наверное все выложеные на форуме прошивки. С флэшки загружается, ip получает, в Synology assistant виден. При попытке установить перед Форматирование диска пишет "Ошибка сервера (код ошибки 38) Если Вы выполняете установку через беспроводное сетевое подключение, перейдите на кабельное подключение Ethernet на DiskStation и клиентском ПК и повторите попытку. При установке произошла ошибка. Сервис Telnet DiskStation включен для определения ошибок. Настройте маршрутизатор для переадресации порта 23 на DiskStation и обратитесь в службу поддержки Synology". Пробовал последние беты от Trantor (которые hba) viewtopic.php?f=2&t=1361&start=360#p12750 - комп виснет при загрузке, снять логи соответственно не получается. Воткнул туда же ide-винт - винт нашелся, xpenology поставилась без проблем. Но виден только этот ide-винт, scsi не видны. Просил Trantor`а добавить драйвера для своего контроллера, но пока тишина. Может кто-нибудь подсказать, в какую сторону копать? Заранее спасибо!
  9. Sorry for spaming... What can I say about this controller? I see it only in IBM X346 server. It's ultra-320 scsi raid controller with bbu. There https://docs.google.com/file/d/0Bzs_u27 ... edit?pli=1 you can find drivers and readme for RHEL and SLES from original IBM disk . If I have to give you some special info - write me please how I can get it. XPEnology is really needed on this machine.
  10. Hi, Trantor! Thank for such great work on DSM! Can you add drivers for IBM_ServeRAID-7k_Ultra320_SCSI_controller (IBM eSeries x346)? Drivers: https://drive.google.com/file/d/0Bzs_u2 ... sp=sharing I try Beta 6 (both standard and hba), but it don`t see any of my disks.