manuelin

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

1 Neutral

About manuelin

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Yes, totally agree. If I currently bought a dvb card, I would not buy a PCI card, I would buy a SAT>IP. I simply try to use my DVBSky card for the simple reason that I already had it from a few years ago. Finally, I have two questions: 1. Days ago you mentioned this file (when I asked you for the .config file) : ds.bromolow-6.2.dev.txz When I need to compile, I do this: git clone https://github.com/SynologyOpenSource/pkgscripts-ng.git pkgscripts-ng/EnvDeploy -v 6.2 -p bromolow cd build_env/ds.bromolow-6.2/source etc... I have the doubt if your method is better (or m
  2. Okay, you're right. As soon as I can I will compile the modules again. Although it works, but to prevent. Ok, when I recompile these I will indicate that these are for DS3615xs (Bromolow). I compiled the drivers in a normal way, so I didn't do anything in particular (for example, here is a guide to do it). Including DVBSky drivers in your extra.lzma would be a fantastic idea. But would the modules only be "stored" (without loading) or would all modules be included and also loaded? I say it, because at least my model needs to load several modules to work, not just
  3. @IG-88 Good news!! I've finally got it! Yes, it was PCIE_ASPM problem. Or so I think, since this time I used your .config file to compile the modules once more, and it finally worked. Tomorrow I pack all the DVBSky modules and upload them to the forum. Cheers and thanks again!
  4. Thanks for answering both. I was just commenting too and I didn't read your message. That was what I thought at the beginning, that the PCIE_ASPM had nothing to do with it. But I've been testing for days and it never works, the module always returns: Killed However, the same file/module in DSM 6.2 works fine, how is it possible? I have also thought that some of the modules included in your Driver extension could conflict with my module. Since here a similar error occurred to another user and he solved it simply by removing one of your modules. So I have decided to use the Ju
  5. I have continued with it, and I found this file: /build_env/ds.bromolow-X.X/source/XXXXX-kernel/.config When I run: cat .config | grep CONFIG_PCIEASPM CONFIG_PCIEASPM=y # CONFIG_PCIEASPM_DEBUG is not set CONFIG_PCIEASPM_DEFAULT=y # CONFIG_PCIEASPM_POWERSAVE is not set # CONFIG_PCIEASPM_PERFORMANCE is not set I think I simply have to change 'CONFIG_PCIEASPM=y' for 'CONFIG_PCIEASPM=n'. Right? Thanks again
  6. Hi, I have compiled the modules for my PCI card DVBSky S952 v2. All load well except one, the last one that needs to be loaded: cx23885.ko When executing the 'insmod cx23885.ko' command, it keeps thinking for a while and a few seconds later returns this message: Killed. I think the problem could be related to the CONFIG_PCIEASPM of the kernel config. Because the module work well in DSM 6.2.0, but in DSM 6.2.2 it does not work. But... I have no idea of doing that process, I have searched Google and I find little information. Exactly where can I disable CONFIG_PCIEASPM in the kerne
  7. Okay, you're right, sorry! Now I quote your message in the other thread. Thanks again
  8. Sorry, I already know they are not network or storage drivers. But I asked you because I think you are the most knowledgeable and indicated. No person in this forum made these modules. I made them myself. And these modules work well in DSM 6.2.0, but in DSM 6.2.2 the last module does not work. I have read your message from the other thread: I have no idea of doing that process, I have searched Google and I find little information. Exactly where can I disable CONFIG_PCIEASPM in the kernel config? (Is that a system file?) I compile the modules in DSM 6.2.2, in Debian
  9. Great work @IG-88!! Thanks to you I now have my HP ProLiant MicroServer Gen8 with DSM 6.2.2-24922 Update 4. Both built-in NICs are recognized and functional. I have done a fresh installation, simply replacing your files ('extra.lzma' -v0.5_test-, 'rd.gz' and 'zImage') on the 2nd partition (30MB) of Jun's Loader v1.03b (DS3615xs). But I have a problem that I can't solve and I need help: I have the PCI card DVBSky S952 v2. I have already compiled all the necessary modules that it needs. All load well except one, the last one that needs to be loaded: cx23885.ko When executing the 'ins
  10. No, I continue with the same problem, I have not advanced anything foster182, did you get the card to work? What problem do you have exactly? The part that fails me has worked for you? (When I try the "make" command) Regards
  11. I am very interested in two of these drivers compiled for DSM6: snd-pcm.ko and snd.ko I have tried compiling them for hours but I can not get it, if anyone can share these two files with me I would really appreciate it Thank you very much and sorry for my bad english. Regards! EDIT: I have already seen that I can get the drivers from the file drivers.lzma that is inside the loader.
  12. In principle all modules are loaded well, except this: insmod cx23885.ko dmesg | grep cx23885 As I said before, I think it's because I'm missing those two dependencies (snd-pcm.ko and snd.ko), but I am unable to "make" my drivers for the problems I explain above, so I am unable to get those two modules that I am missing. Thank you very much JMRR!
  13. Can anybody help me please?: viewtopic.php?f=2&t=3066&start=10#p92338 I copy and paste it in this thread: Hi, thank you very much for the tutorial! I also have DVBSky S952, but I have version 2, not version 3, the difference is that i need cx23885 (v2) instead of smipcie (v3). I got stuck on this part: When I try the "make" command it gives me this error: How did you get duck.? can anybody help me? In LinuxTV (https://www.linuxtv.org/wiki/index.php/DVBSky) I have read that you need to install required build tools (apt-get install kernel-package linu
  14. Hi, thank you very much for the tutorial! I also have DVBSky S952, but I have version 2, not version 3, the difference is that i need cx23885 (v2) instead of smipcie (v3). I got stuck on this part: When I try the "make" command it gives me this error: How did you get duck.? can anybody help me? In LinuxTV (https://www.linuxtv.org/wiki/index.php/DVBSky) I have read that you need to install required build tools (apt-get install kernel-package linux-headers-`uname -r`), but this command returns the following error: I have seen the dependencies of cx23885 and they are
  15. Hola, de acuerdo, yo te hablo en español, gracias! Si tu pudieses intentar compilar los drivers en unos días yo te lo agradecería mucho Mientras tanto, ¿tu conoces algún tutorial que yo pueda leer para yo intentar compilar los drivers?, aunque según tengo entendido es algo complicado, así que seguro que no me funciona , por eso yo quiero esperar unos días a que tú puedas compilar y ayudarme un poco Muchas gracias JMRR! Un saludo! Hola buenas, si, ese soy yo jaja Ya te leí por las páginas anteriores y vi ese minituto que escribiste, lo malo es que todos esos drivers