medric

Members
  • Content count

    33
  • Joined

  • Last visited

Everything posted by medric

  1. 1.02b-15152 'loader'

    Can you do this for the D3617xs as well?
  2. DSM 6.x.x Loader

    yeah its odd my 9211 card works both windows and xpe the 9240 flash to it mode works windows load in bios drives are found but xpe has issues with it. i will look at it some more later this week
  3. DSM 6.x.x Loader

    I am not sure what happen to this card it works with windows and bios sees in in both computer however the other card works fine i have two cards one p20 9211 and a p19 9240 flash to it mode which bios sees b ut does not load properly in xpe
  4. +1 That is great news we just have to have some let Jun know the importance of hyper-v drivers.
  5. DSM 6.x.x Loader

    very odd i will try to flash again that is very very odd so it has to be a bad flash (even though windows sees it fine and drives all work under windows) hmm
  6. DSM 6.x.x Loader

    my setup is normal is baremetal lsi 9211-it p19 1.02b so i know it works but why is it not working is the real question do i need to downgrade further i added my log where it shows something weird if a dev can step in and have a look .
  7. DSM 6.x.x Loader

    what version of firmware you're running on your card? that could be the difference i had my on the avago p20 downgrade it to the 19 if i need to go to an older code i can get it and flash it tonight let me know
  8. Jun's DSM 6 Loader - Driver List

    I have downgrade my lsi 9211-it sas2008 from p20 to p19 and i still does not work using jun 1.02b ds3617 6.1.3 can someone respond? [ 3.119995] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 200 6) [ 3.125607] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006) [ 3.142392] Fusion MPT base driver 3.04.20 [ 3.142395] Copyright (c) 1999-2008 LSI Corporation [ 3.152978] Fusion MPT SPI Host driver 3.04.20 [ 3.158430] Fusion MPT SAS Host driver 3.04.20 [ 3.163786] Fusion MPT misc device (ioctl) driver 3.04.20 [ 3.163888] mptctl: Registered with Fusion MPT base driver [ 3.163891] mptctl: /dev/mptctl @ (major,minor=10,220) [ 3.174735] megasas: 06.506.00.00-rc1 Sat. Feb. 9 17:00:00 PDT 2013 [ 3.180708] mpt2sas version 20.00.00.00 loaded [ 3.180846] scsi6 : Fusion MPT SAS Host [ 3.181255] mpt2sas 0000:08:00.0: enabling device (0000 -> 0002) [ 3.181309] mpt2sas0: 64 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (660 51852 kB) [ 3.181321] mpt2sas0: sending diag reset !! [ 3.332476] mpt2sas0: diag reset: FAILED [ 3.332635] mpt2sas0: _base_get_ioc_facts: failed getting to correct state [ 3.332903] mpt2sas0: mpt2sas_base_unmap_resources [ 3.332941] mpt2sas0: Controller resources are already freed [ 3.332943] mpt2sas0: failure at //source/lsi-mpt2sas/mpt2sas_scsih.c:11743/_ scsih_probe()! [ 3.339862] mpt3sas version 13.00.00.00 loaded
  9. DSM 6.x.x Loader

    I have downgrade my lsi 9211-it sas2008 from p20 to p19 and i still does not work using jun 1.02b ds3617 6.1.3 can someone respond? [ 3.119995] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 200 6) [ 3.125607] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006) [ 3.142392] Fusion MPT base driver 3.04.20 [ 3.142395] Copyright (c) 1999-2008 LSI Corporation [ 3.152978] Fusion MPT SPI Host driver 3.04.20 [ 3.158430] Fusion MPT SAS Host driver 3.04.20 [ 3.163786] Fusion MPT misc device (ioctl) driver 3.04.20 [ 3.163888] mptctl: Registered with Fusion MPT base driver [ 3.163891] mptctl: /dev/mptctl @ (major,minor=10,220) [ 3.174735] megasas: 06.506.00.00-rc1 Sat. Feb. 9 17:00:00 PDT 2013 [ 3.180708] mpt2sas version 20.00.00.00 loaded [ 3.180846] scsi6 : Fusion MPT SAS Host [ 3.181255] mpt2sas 0000:08:00.0: enabling device (0000 -> 0002) [ 3.181309] mpt2sas0: 64 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (660 51852 kB) [ 3.181321] mpt2sas0: sending diag reset !! [ 3.332476] mpt2sas0: diag reset: FAILED [ 3.332635] mpt2sas0: _base_get_ioc_facts: failed getting to correct state [ 3.332903] mpt2sas0: mpt2sas_base_unmap_resources [ 3.332941] mpt2sas0: Controller resources are already freed [ 3.332943] mpt2sas0: failure at //source/lsi-mpt2sas/mpt2sas_scsih.c:11743/_ scsih_probe()! [ 3.339862] mpt3sas version 13.00.00.00 loaded
  10. Jun's DSM 6 Loader - Driver List

    i am using ds3617 jun 1.02b works but my sas2008-it does not seem to work i am using the latest firmware is this a firmware issue and if so which version is recommended and if not then what can i do to get this working?
  11. DSM 6.x.x Loader

    i have tried the ds3617 and that works with efi boot but still my card does not work its sas2008-it mode it is using the latest firmware the avago (sp) could that be the issue? and if so which firmware should i be using. also for the ds3615 i am only showing 2 cpu and for ds3617 i am only showing 4
  12. DSM 6.x.x Loader

    just installed ds3615 on my machine it worked great the motherboard is a supermicro x9 inte e5-2695 v2 it boots but it does not see my lsi 9211 hba it is not showing up i thought the driver for this was already built into the kernel or do i have to inject it back
  13. Kernel building

    I uses windows 10 bash and download the source and tool chains and used old guides and drivers compiling as reference and compiled my own kernel with better cpu support for my 12 core cpu (E5-2695 v2 sandy bride) and then i took the bzimage and renamed it to zimage and use osfmount to copy over the org zimage but it did not boot (it booted normally with the org zimage file) I could use some pointers on how or what to do next. (please don't mention how powerful that cpu is and what i would use it for)
  14. Kernel building

    Here is the info that i pulled from https://github.com/kref/scripts juns script i can read and understand a bit of it but its a bash script not my strong suite https://xpenology.club/compile-drivers-xpenology-with-windows-10-and-build-in-bash/ https://github.com/HuxyUK/xpenology-3.x old but still has good info http://xpenology.com/wiki/en/building_xpenology old style for building the pat file but again has good place to start https://help.ubuntu.com/community/Kernel/Compile standard compile for linux https://github.com/0xAX/linux-insides/blob/master/Misc/how_kernel_compiled.md sandard compile for linux
  15. Kernel building

    I have found a lot of info but dont have a lot of coding skills only used in school and that was assembly programming I will post all the info i have found and i think we can work on this together to get this done i know we can we just need to put all the pieces together. later tonight i will link to all my sources
  16. can someone help with adding hyper-v synthetic drivers
  17. DSM 6 Boot Image for Hyper-V

    I was able to get 6.0 running in gen 1 hyper-v but it comes up as 100mbps and the image i use did not allow upgrade. What i am going to try is to do the nic SR-IOV and see if that works in gen 2 hyper-v; will net you now
  18. Did you try to convert the VMware image to Hyper-V and give it a try? I have had a ton of different VMware images ive converted and worked fine, always worth a shot in the name of SCIENCE! Not working. The loader needs the Hyper-V integration drivers. Mostly for the network part. Sent from my iPhone using Tapatalk I did get it to work with generation 1 hyper-v and with a tool from http://xpenology.com/forum/viewtopic.php?f=2&t=16114&hilit=DSM_DS3615xs_7393 [spoiler=](it seems the download link is gone but i have them if anyone needs them) DS3615xs_7393.iso i was able to install using the install option iso and then updating use the DS3615xs_7393.pat you have to use the install option for every boot and the nics only the show 100mbps
  19. I am putting up a Bounty of $200.00 Paypal for a DSM 6.0 set up for Hyper-v with proper nic support I can get it to work but the nics are only 100mb and i cant update pat files it says the patch file is not compatible with my system and the run/install thing is not so good i used DSM_DS3615xs_7393 iso/pat to get it to load gen 1 vhd on 2012 R2 hyper-v. Any one that wants in on this bounty we can pool our money and get this bounty higher any devs who want to take up the challenge?
  20. Hyper-v DSM 6.0 Bounty $200.00

    It seems like they are working on a Hyper-v solution so i will put my money where my mouth is and send that money to the devs for there hard work. I appreciate good work we all do and we should not be afraid to pay it forward to keep good working on going.
  21. Missing firmware for Brocade 10G

    what is your firmware version on the brocade?
  22. Missing firmware for Brocade 10G

    can anyone help with this it seems that the driver is not pulling even though it is suppose to be there, so its either I am missing something or the firmware on the card needs to be a certain version please help
  23. Missing firmware for Brocade 10G

    I have done this and i am still getting error in dmesg and it does not load i have posted updates to the post but the brocade works in windows and is showing in bios do i have to have certain firmware on the brocade adapter? please let me know i need this to move my data over.
  24. Missing firmware for Brocade 10G

    rmmod bna insmod /lib/modules/bna.ko dmesg [ 402.232673] Brocade 10G Ethernet driver - version: 3.1.2.1 [ 402.232687] bnad_pci_probe : (0xffff880807a9a000, 0xffffffffa0ee5c60) PCI Func : (2) [ 402.242749] bar0 mapped to ffffc90019a00000, len 262144 [ 402.242809] bna 0000:01:00.2: irq 47 for MSI/MSI-X [ 402.242813] bna 0000:01:00.2: irq 48 for MSI/MSI-X [ 402.242815] bna 0000:01:00.2: irq 49 for MSI/MSI-X [ 402.242820] bna 0000:01:00.2: irq 50 for MSI/MSI-X [ 402.242823] bna 0000:01:00.2: irq 51 for MSI/MSI-X [ 402.242825] bna 0000:01:00.2: irq 52 for MSI/MSI-X [ 402.697483] bnad_pci_probe : (0xffff880807abe800, 0xffffffffa0ee5c60) PCI Func : (3) [ 402.697543] bar0 mapped to ffffc90019a80000, len 262144 [ 402.697591] bna 0000:01:00.3: irq 53 for MSI/MSI-X [ 402.697594] bna 0000:01:00.3: irq 54 for MSI/MSI-X [ 402.697596] bna 0000:01:00.3: irq 55 for MSI/MSI-X [ 402.697599] bna 0000:01:00.3: irq 56 for MSI/MSI-X [ 402.697601] bna 0000:01:00.3: irq 57 for MSI/MSI-X [ 402.697603] bna 0000:01:00.3: irq 58 for MSI/MSI-X i tired to issues those comands and that is the output it seems to load but it does not show anything nor does it do anything after a reboot