Trauma

Members
  • Content Count

    18
  • Joined

  • Last visited

  • Days Won

    5

Trauma last won the day on October 3 2019

Trauma had the most liked content!

Community Reputation

12 Good

About Trauma

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. So the hypervisor do not expose any scaling capabilities to the VM's. Maybe the host scale fine, so the script is useless ( on top of not compatible...) Maybe try to check if your host burst freq or not and try to fix it.
  2. Yes it should still be usefull since VM's runs on there own kernel, the hypervisor only expose hosts cpu features.
  3. As said before, this script won't help with burst frequency, I guess it's handled by intel_pstate and not cpu_freq. This version of the kernel is cpu_freq only, even if it's appollo lake version (that weird).
  4. Hello nadiva, Thanks for you feedback, much appreciated. I look into your contribution later this month i think (quite busy at this time). Cheers.
  5. As @richv31 mentioned DS3615 kernel also use acpi_cpufreq by default. But i don't know if intel_pstate is available /usable with this kernel/os. IMHO the hypersisor has nothing to do with this, or at least should be able to provide the necessary to use both.
  6. Netdata is effectively a good too monitor your server. About "phys,phys,phys,virt,virt,virt,virt", seems like it's actually displayed/ordered like this. I also doubt HT core could be higher than physical cores. It's also possible that DSM kernel / drivers are missing something to handle this right (maybe bromowl kernel is working). About "load profil", isn't the readme clear enough ? Do you understand "loadaverage" thing ?
  7. Yes it seems like ! It certainly means acpi-cpufreq is not able to control threaded cores. You could use this simple loop to monitor cpu frequency, quick and dirty but works... (CTRL+C to escape): while true; do cat $(ls /sys/devices/system/cpu/cpufreq/policy*/scaling_cur_freq); done
  8. Please try this version of the script, and report us if it's OK... or not please : https://raw.githubusercontent.com/Trauma/cpufreq-userspace-scaler/ht-compat/scaler.sh
  9. If you want, you can use variables to adjust speed and steps according to you're load profil. acpi-cpufreq driver gather frequencies from ACPI tables, so it's certainly related to your bios ACPI implementation. Try to tweak cpu and acpi settings in bios, it may help. Maybe this CPU is not completly supported on this mobo (bios update ?). Try this, to see if it's more consistant : cat /sys/devices/system/cpu/cpufreq/policy0/bios_limit Obviously not ! Anyway I'm not sure cpuinfo is totally reliable here. Prefer sysfs informations in my opinion.
  10. Thanks ! Not 100% sure about this but i guess boost frequency is managed by intel_pstate, which seems to be enabled in the kernel, but the default cpu frequency driver is set to cpu_freq. I did not succeed to make it work on my rig. I've tried intel_pstate=enable in the grub cmd_line, but no luck. I've also tried to load a compiled module, and it don't load. I guess some guys here have proven it's actually working, while benchmarking the NAS with turbo boost enabled or disabled in bios (they use geekbench in a docker container I guess).
  11. Long answer : Your CPU don not have only 3 modes, synology kernel for DS918+ provides only three cpufreq governors : powersave > set the cpu to its minimal freq performance > set the cpu to its maximal freq userspace > allow you to specify the desired frequency. This script use this governor to modulate the frequency according to system load (that's basically whats explained in the README). Short answer : no need to "modify some text", just RTFM
  12. Installation in rc.d will not work since this script do not provide start and stop args. As @Olegin spotted you can launch it form the task manager, that's the way i use it. Installation example (from your nas cli) : sudo curl https://raw.githubusercontent.com/Trauma/cpufreq-userspace-scaler/master/scaler.sh -o /usr/local/bin/scaler.sh && sudo chmod +x /usr/local/bin/scaler.sh Then run it through a startup triggered task, as root, in your DSM, with the following command : /usr/local/bin/scaler.sh & or with parameters : lowload=100 highload=200 scalingm
  13. I guess some off you could be intersted in this :