Jump to content
XPEnology Community

apple3000

Members
  • Posts

    50
  • Joined

  • Last visited

Everything posted by apple3000

  1. thanks. i added rtmp part in nginx conf. but not working. so must be compile with module. default nginx does not support module. as you say, i need to set docker with ngnix rtmp module. thanks a lot.
  2. thanks. but i need nginx to support rtmp and hls and etc. does nginx in DSM support that? refer this. https://github.com/Looooopy/patch_synology_nginx
  3. example, default nginx version is 1.12.1 in DSM 6.2 Now I want to stream media with rtmp. But default 1.12.1 does not support. so I want to use nginx to support rtmp module. (there is at public forum.) is there method to change as another one? At Widows, Just stop nginx. and replace to new nginx.exe.
  4. hi. hp DL380 gen9. 1.02b Loader for dsm6.1 3617sx with extra.lzma 4.8. problem is no hdd. slot 0 is p440ar, no hdd attach. slot 3 is p840, 9 disks(1.8T x 6=raid5, 300G x 3=raid5). so how do i set sataport map in grub.cfg? sataportmap=0002 ? 02 ?how can i do?
  5. I use dsm 6.1.7 3615sx How to protect default share folders, video , photo, music? share foder option, check "To hide this folder in my network" and check "To hide to no previledge users" But shared folder was showed at network location in windows explorer. How to protect default share folders?
  6. same problem. Do I need above intel 4Gen cpu and licensed serial NAS 918+? I have just i7 6770 cpu and xpeno 918+ with 1.04b. Please tell me how to transcoding and hardware transcoding at Video Station.
  7. refer to this. rm -r /.xpenoboot/ . and reboot.
  8. yes, I succeeded before somedays from this replication , thank you, too. i succeeded from 5.2. 5967 DS3615sx to 6.2.23739 DS918+ with 1.03a2 boot loader. and upgraded 6.2.23739 to 6.2.23824 update1 with 1.04b boot loader. So now i am satisfied. but it was testing pc. Now I must apply to using pc. I have to upgrade cpu(at least intel 4gen) and motherboard. Maybe it will be succeed.
  9. i use dsm 5.2 3615sx Version. I would upgrade to 6.2 ds918+. I succeeded clean install dsm 6.2 ds918+. But migration was faild. 1. At Second booting, Assistant sometimes found nas, sometimes not found nas. 2. it is possible to access web station, and ssh terminal connection is OK. but network setting has some problem. up down shows 0kb/s and information center did not show network. So, i think it is not about version but vender(not exactly). So, is it possible 3615sx to 918+?
  10. After install connect both nic's to network, I use intel to ssh and check /var/log/dmesg , and i attached 3 log file. I input static ip address to both nic's. So intel has *.*.*.75 realtek has *.*.*.76 dmesg1 is first thing. intel + realtek. dmesg2 is second. rebooting and i connected to realtek , still has intel nic. dmesg3 is 3rd. i ejected intel nic and booting with realtek. by the way, this reatek nic has *.*.*.75 in lanport 1. but worked. dmesg3_connect_to_rtl8168(onboardreltek_removeintel) dmesg2_connect_to_rtl8168(intel+onboardreltek) dmesg1_connect_to_intel(intel+onboardreltek)
  11. in my case, I have realtek 8168 onboard NIC. Although trying several times, but assistant found xpenology on lan At First booting.after rebooting , at 5 step, error 23. Assistant did not find xpenology on lan. I don't know why. just was successful only using intel lan. thanks your testing report.
  12. 1. i7 6770 onboard Realtek 8168, chipset is 8168G First setup 916+8168G_NIC_onbard.txt After reboot 916+8168G_NIC_onboard_afterReboot.txt 2. i7 6770 onboard Realtek + intel CT1000 NIC pci-e type. and i connected lan to intel. First setup 916+intelCT1000.txt After reboot 916+intelCT1000_afterreboot.txt 916+intelCT1000.txt 916+8168G_NIC_onboard.txt 916+intelCT1000_afterreboot.txt 916+8168G_NIC_onboard_afterReboot.txt
  13. 1. yes, i used basic extra.lzma and your V4.5 extra.lzma. 2. with onboard realtek nic, 3770 is cpu panic (it is 3rd gen, so i will not test any more^^) in case i7 -6770, it has been done to "login prompt" when i saw console from serial comport. a) i install DSM 6.1.5 pat through Synology asistant b) and rebooting message in synology asistant. and pc was rebooted. c) and next, process went to "login prompt". but synology asistant did not find mypc, and "starting message" still shows and time out 500s 499s 498s,,,,,,,,,,,,. and last shows on error message. blablabla~~~~ Telnet ,,, 23. 3. my pc NIC realtek speccific chipset is below. 3770 is 8168E 4790 is 8168G 6770 is 8168G I hope my test will help you. i would attach serialport logfile after next days that i tested with 6770 realtek nic.
  14. you're right. i tested again yesterday. cpu i7 6770, 6 Gen, and its NIC is realtek 8168 . Boot success. but couldn't find at synology asistant. maybe NIC 8168 module problem. So I prepare another NIC, intel lancard "CT 1000 gigabit". when boot with intel lan, boot succeeded, and it was founded at synology asistant. and install finally succeeded. summary.. above all. PC1, 2, 3 have all realtek 8168 gigabit lan. PC1 -i7 3770 3rd Gen, not working. because CPU is not compatible. that's right. it shows "Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu ~~~" on log. PC2 - i7 6770 6th Gen, Working. but needs intel NIC. Realtek8168 not working. PC3- i7 4790 4th Gen, working on VMWARE. I didn't test real pc. but it will be succeed, too at real pc because 4th Gen pc. So, 916+ needs over 4th Gen CPU, and needs intel 1000 NIC or another NIC. realtek8168 not working. thanks.
  15. Ok. Thanks. I agree to you. And i would be care to use tag next time.
  16. i connected serial port to find error. So, below is result. i7 3770, DS916+ jun's mod 1.02b used. .[H.[J.[1;1H.[?25l.[m.[H.[J.[1;1H.[2;21HGNU GRUB version 2.02~beta2-36ubuntu3.9 .[m.[4;2H+----------------------------------------------------------------------------+.[5;2H|.[5;79H|.[6;2H|.[6;79H|.[7;2H|.[7;79H|.[8;2H|.[8;79H|.[9;2H|.[9;79H|.[10;2H|.[10;79H|.[11;2H|.[11;79H|.[12;2H|.[12;79H|.[13;2H|.[13;79H|.[14;2H|.[14;79H|.[15;2H|.[15;79H|.[16;2H|.[16;79H|.[17;2H+----------------------------------------------------------------------------+.[m.[18;2H.[19;2H.[m Use the ^ and v keys to select which entry is highlighted. Press enter to boot the selected OS, `e' to edit the commands before booting or `c' for a command-line. .[5;80H .[7m.[5;3H*DS916+ 6.1 Baremetal with Jun's Mod v1.02b .[m.[5;78H.[m.[m.[6;3H DS916+ 6.1 Baremetal with Jun's Mod v1.02b Reinstall .[m.[6;78H.[m.[m.[7;3H DS916xs 6.1 VMWare/ESXI with Jun's Mod v1.02b .[m.[7;78H.[m.[m.[8;3H .[m.[8;78H.[m.[m.[9;3H .[m.[9;78H.[m.[m.[10;3H .[m.[10;78H.[m.[m.[11;3H .[m.[11;78H.[m.[m.[12;3H .[m.[12;78H.[m.[m.[13;3H .[m.[13;78H.[m.[m.[14;3H .[m.[14;78H.[m.[m.[15;3H .[m.[15;78H.[m.[m.[16;3H .[m.[16;78H.[m.[16;80H .[5;78H.[22;1H The highlighted entry will be executed automatically in 1s. .[5;78H.[22;1H .[23;1H .[5;78H.[m.[5;3H DS916+ 6.1 Baremetal with Jun's Mod v1.02b .[m.[5;78H.[m.[7m.[6;3H*DS916+ 6.1 Baremetal with Jun's Mod v1.02b Reinstall .[m.[6;78H.[m.[m.[6;3H DS916+ 6.1 Baremetal with Jun's Mod v1.02b Reinstall .[m.[6;78H.[m.[7m.[5;3H*DS916+ 6.1 Baremetal with Jun's Mod v1.02b .[m.[5;78H.[m.[?25h.[H.[J.[1;1H.[H.[J.[1;1H.[H.[J.[1;1H.[H.[J.[1;1H[ 0.292388] invalid opcode: 0000 [#1] SMP [ 0.296520] Modules linked in: [ 0.299591] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 3.10.102 #15047 [ 0.306025] Hardware name: SAMSUNG ELECTRONICS CO., LTD. Samsung DeskTop System/SAMSUNG_DT1234567890, BIOS P04KJS.030.130809.XJ 08/09/2013 [ 0.318439] task: ffff8802148c1510 ti: ffff8802148c4000 task.ti: ffff8802148c4000 [ 0.325914] RIP: 0010:[<ffffffff8148f33e>] [<ffffffff8148f33e>] sha_transform+0x2e/0x12e0 [ 0.334194] RSP: 0000:ffff8802148c7d60 EFLAGS: 00010092 [ 0.339502] RAX: ffffffff819c2a80 RBX: 0000000010325476 RCX: 00000000e8a4602c [ 0.346629] RDX: ffff8802148c7db0 RSI: ffffffff819c2a80 RDI: ffff8802148c7d98 [ 0.353756] RBP: 00000000c3d2e1f0 R08: 00000000efcdab89 R09: 0000000010325476 [ 0.360882] R10: 0000000067452301 R11: 0000000098badcfe R12: 00000000f33d5697 [ 0.368010] R13: ffff8802148c7e66 R14: 0000000000000286 R15: 0000000000000004 [ 0.375138] FS: 0000000000000000(0000) GS:ffff88021f240000(0000) knlGS:0000000000000000 [ 0.383228] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033 [ 0.388966] CR2: 0000000000000000 CR3: 000000000180d000 CR4: 00000000001407e0 [ 0.396094] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000 [ 0.403221] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400 [ 0.410348] Stack: [ 0.412359] 0000000000000010 ffffffff81842cc0 ffffffff81842ce4 ffff8802148c7e66 [ 0.419818] 0000000000000286 0000000000000004 ffffffff812fa652 efcdab8967452301 [ 0.427273] 1032547698badcfe 00000000c3d2e1f0 ffffffff81842e10 0000000000000246 [ 0.434730] Call Trace: [ 0.437178] [<ffffffff812fa652>] ? extract_buf+0x62/0x140 [ 0.442666] [<ffffffff810579a5>] ? __wake_up+0x35/0x50 [ 0.447894] [<ffffffff812fa464>] ? account+0x104/0x290 [ 0.453113] [<ffffffff812fab9c>] ? extract_entropy+0x5c/0x170 [ 0.458940] [<ffffffff8115f047>] ? proc_register+0x67/0x140 [ 0.464595] [<ffffffff813e89fb>] ? neigh_hash_alloc+0x7b/0xb0 [ 0.470428] [<ffffffff813e8ab6>] ? neigh_table_init+0x86/0x2b0 [ 0.476342] [<ffffffff818a13af>] ? arp_init+0xc/0x47 [ 0.481387] [<ffffffff818a16c0>] ? inet_init+0x18e/0x27a [ 0.486780] [<ffffffff818a1532>] ? ipv4_offload_init+0x63/0x63 [ 0.492694] [<ffffffff810003aa>] ? do_one_initcall+0xea/0x140 [ 0.498522] [<ffffffff81876dc8>] ? kernel_init_freeable+0x13a/0x1bb [ 0.504868] [<ffffffff814909f0>] ? rest_init+0x70/0x70 [ 0.510088] [<ffffffff814909f5>] ? kernel_init+0x5/0x180 [ 0.515481] [<ffffffff814a2548>] ? ret_from_fork+0x58/0x90 [ 0.521046] [<ffffffff814909f0>] ? rest_init+0x70/0x70 [ 0.526265] Code: 8b 5f 08 44 8b 17 41 56 44 8b 47 04 44 89 d1 41 55 c1 c1 05 41 54 45 8d 23 55 8b 6f 10 41 81 c4 99 79 82 5a 53 8b 5f 0c 41 89 d9 <0f> 38 f0 06 45 31 d9 89 02 45 21 c1 41 c1 c8 02 41 31 d9 41 01 [ 0.546235] RIP [<ffffffff8148f33e>] sha_transform+0x2e/0x12e0 [ 0.552164] RSP <ffff8802148c7d60> [ 20.291066] Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu 1 ========================= how do you think? what problem is.. final line said 'Kernel panic.."
  17. i have a question. i installed 916P on vmware. and with putty, connected dsm in directory " /lib/modules# ", listed all file to find 8168 realtek. but i can not find those. like attached image. vmware's NIC is e1000 (intel). does have "lib/modules# " include only just existing NIC? no problem?
  18. 1. when i try before somedays, I use original extra.lzma from jun's 1.0.2b 916+. At the result, didn't find pc. So I changed 4.5 extra.lzma. 2. 1)Real testing PC1 - H61S1 (samsung OEM, onboard lan, realtek giga 8168), i7 3770 cpu 3rd gen. --> Failed. 2)Real testing PC2 - H110 (Juyeon OEM, onboard lan, realtek giga 8168), i7 6770 cpu 6th gen. -->Failed. 3)virtual testing PC3 -ASUS H81M-C (Juyeon OEM, onboard, lan reatek giga 8168, i7 4790 4th gen - VMWARE12 TESTing. i wrote above. vmware testing Success. All PC support intel -VT and enabled. 3. how to add the realtek card to the vm? i edited .vmx and add e1000 (intel) but i don't know how to add realtek lan. i tested network mod, NAT, Bridged. And i succedded at 2 methods. isn't bridge mode mean real host's lan adaptor? then bridge mode means my realtek8168 lan.. i will try to test more and more. Another check ? give me help. very thanks for your concerning.
  19. Thanks. I will try as your guide. Then i will report.
  20. Thanks. But i would like to test h/w transcoding with 916+ version. I know that It supports h/w transcoding.
  21. MyPC is i7 3770, realtek Giga family. RTL8168. I have same issue above. I used jun's 1.0.2b 916p synoboot.img. and extra.lzma v 4.5 from but, web browser or synology Asistant did not found my PC Test 2. I have tested on Vmware12 (network driver is intel1000e. i edited vmx.) my PC detected over network, and I installed successfully 916+ on vmware. extra.lzma not include my PC network driver? realtek 8168? But i saw extra.lzma 4.5 included r8168 driver from it 's driver list. Test3. with 3617sx synoboot.img MyPC detected over network. So, I guess that 916+ extra.lzma has driver issue.
  22. sATA 2 지원모델이군요. 디스크야 IDE가 아닌이상 장착에는 문제 없을 것입니다. 단지 보드 단자가 SATA2이므로 3TB하드가 SATA3 라면, 하드의 성능이 아깝게는 여겨지겠지요. Xpenol 붙여봐야 알아서 하드 구성하기때문에 문제되지는 않을 것 같습니다.
  23. I edited 2 files below. /etc.default/VERSION /etc/VERSION like this. majorversion="5" minorversion="2" productversion="5.2" buildphase="0" buildnumber="5592" smallfixnumber="1" builddate="2012/12/05" and boot from 5.2.5644 xpenoboot Image. and at web or at synology assistant, loading 5.2.5644 PAT. just that.
  24. I downgraded dsm from 6.1 to 5.2 FileStation Error. It did not show main. So, At packageCenter, i clicked recovery button, but did not work. I can't remove filestation and can't reinstall. How to resolve this problem?
  25. 파일 스테이션에 접근 가능한가보지요? 우선 스트리밍만 되게 하실려면, 1. 비디오스테이션을 활용합니다. 제어판-사용자-해당사용자편집 계정의 권한탭에서 Video 폴더에 접근금지로 주시고(물론 타 폴더도 접금금지할 폴더는 권한을 안주시면됩니다) 계정의 응용프로그램탭에서 비디오스테이션만 이용가능하게 체크합니다. 관리자는 파일 스테이션의 video폴더에 적절히 폴더와 파일들을 구성하여 두시면 됩니다. 사용자는 http://서버:포트/video 형식으로 로그인후 바로 접근이 가능하고 원하는 영상을 시청할 수 있습니다. 참고 : 제어판-응용프로그램포털-비디오스테이션항목더블클릭해서 주소부분에 리다이렉션 체크하시면 포트없이 http://서버/video형태로 접근가능합니다. 2. 포토스테이션을 활용합니다. 마찬가지로 권한은 없애시고, 포토스테이션의 권한은 여기서는 응용프로그램할당에서는 보이지 않습니다. 포토스테이션내에서 설정합니다. 포토스테이션은 http://서버/photo 로 접근하면 됩니다. 관리자는 파일스테이션 -photo폴더에 적당히 구성하여 파일을 넣어둡니다. 사용자의 접근을 위해서는 http://서버/photo 에 관리자로 로그인후 나열되는 포토폴더들에서 보면 개별폴더별로 속성을 지정할 수 있습니다. 거기서 접근권한을 두면되는데 비공개로 하실것이니까 비공개- 패스워드 방식이나 비공개-권한할당 (DSM의 계정으로 각 개별 폴더에 권한을 지정할 수 있음) - 권한할당을 눌러서 해당폴더에 접근할 계정에 "찾아보기" 혹은 "검색"이라는 부분에 해당 계정만 체크 하시면됩니다. <스트리밍을 위한 영상> 영상은 가능하면 폰에서도 PC에서도 원할히 재생가능하도록 MP4형식으로 인코딩해서 두는게 좋습니다. 그래야 플레이가 잘됩니다. 타임스킵(재생바 드래그 원하는 위치이동)가 잘 되도록 하려면 추가적으로 MP4에 더하시면됩니다. 이부분은 언급안합니다. 그리고 사용자는 PC접속의 경우, 가능하면, Internet explorer가 아닌 크롬계열의 브라우저로 접근해서 보는 것이 원할한 스트리밍을 위해서 필수입니다. 모바일은 아무거나 다 잘됩니다. 여기까지 제가 하고 있는 방법입니다.
×
×
  • Create New...